source: projects/specs/trunk/p/perl-Curses/perl-Curses-vl.spec @ 12120

Revision 12120, 5.0 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1Name:           perl-Curses
2Version:        1.36
3Release:        1%{?_dist_release}
4Summary:        Perl bindings for ncurses
5Summary(ja):    Ncurses の Perl バインディング
6
7Group:          Development/Libraries
8License:        GPL+ or Artistic
9URL:            http://search.cpan.org/dist/Curses/
10Source0:        http://search.cpan.org/CPAN/authors/id/G/GI/GIRAFFED/Curses-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15
16BuildRequires:  ncurses-devel
17BuildRequires:  libxcrypt-devel
18BuildRequires:  perl(Test::More)
19Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
20
21%description
22Perl bindings for ncurses, bringing terminal-independent character
23handling capabilities to Perl.
24
25
26%prep
27%setup -q -n Curses-%{version}
28test -f hints/c-linux.ncursesw.h || cp hints/c-linux.ncurses.h hints/c-linux.ncursesw.h
29sed -i -e 's|/usr/local/bin/perl|%{__perl}|' demo*
30sed -i -e 's|/usr//bin/perl|%{__perl}|' demo*
31
32%build
33%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS" \
34   PANELS MENUS FORMS
35make %{?_smp_mflags}
36
37# A note about the following alarming output...
38#
39#  WARNING: Your Curses form.h file appears to be in the default
40#  system search path, which will not work for us because of
41#  the conflicting Perl form.h file.  This means your 'make' will
42#  probably fail unless you fix this, as described in the INSTALL
43#  file.
44#
45#... can be ignored because /usr/include/form.h is a symlink to
46#/usr/include/ncurses/form.h, which the Makefile.PL finds and
47#uses quite happily.
48
49
50%install
51rm -rf %{buildroot}
52make pure_install PERL_INSTALL_ROOT=%{buildroot}
53find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
54find %{buildroot} -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
55find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
56chmod -R u+w %{buildroot}/*
57
58#Remove exec perm for file aimed to be bundled as %%doc
59chmod -x demo*
60
61%check
62make test
63
64
65%clean
66rm -rf %{buildroot}
67
68
69%files
70%defattr(-,root,root,-)
71%license Copying Artistic
72%doc README demo*
73%{perl_vendorarch}/auto/*
74%{perl_vendorarch}/Curses.pm
75%{_mandir}/man3/*.3*
76
77
78%changelog
79* Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.36-1
80- new upstream release.
81- rebuilt with perl-5.26.
82- added BR:libxcrypt-devel.
83
84* Thu Apr 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.32-1
85- new upstream release
86
87* Mon Jun 30 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.28-2
88- build with Perl 5.16
89
90* Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.28-1
91- initial build for Vine Linux
92
93* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.28-5
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
95
96* Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.28-4
97- Perl mass rebuild
98
99* Tue Jun 14 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.28-3
100- Perl mass rebuild
101
102* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.28-2
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
104
105* Sun Feb 6 2011 Steve Traylen <steve.traylen@cern.ch> - 1.28-1
106- Upstream to 1.28
107
108* Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.27-5
109- 661697 rebuild for fixing problems with vendorach/lib
110
111* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.27-4
112- Mass rebuild with perl-5.12.0
113
114* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 1.27-3
115- rebuild against perl 5.10.1
116
117* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.27-2
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
119
120* Thu Jul 16 2009 kwizart < kwizart at gmail.com > - 1.27-1
121- Update to 1.27
122- Remove exec perm for demo* provided as %%doc - Fix #510186
123
124* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.20-4
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
126
127* Tue Mar  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.20-3
128- rebuild for new perl
129
130* Thu Feb 14 2008 Garrick Staples <garrick@usc.edu> 1.20-2
131- forgot to update tarball, building
132
133* Thu Feb 14 2008 Garrick Staples <garrick@usc.edu> 1.20-1
134- bump to 1.20
135
136* Fri Aug 17 2007 Garrick Staples <garrick@usc.edu> 1.16-4
137- fix /usr//bin/perl, bz#253336
138
139* Thu Aug 16 2007 Garrick Staples <garrick@usc.edu> 1.16-3
140- need BR: perl(Test::More)
141
142* Thu Aug 16 2007 Garrick Staples <garrick@usc.edu> 1.16-2
143- rebuild
144
145* Thu Aug 16 2007 Garrick Staples <garrick@usc.edu> 1.16-1
146- bump to 1.16
147- correct License: tag
148- need BR: perl-devel
149
150* Sun Aug 27 2006 Garrick Staples <garrick@usc.edu> 1.15-1
151- bump to 1.15
152
153* Sun Aug 27 2006 Garrick Staples <garrick@usc.edu> 1.14-2
154- rebuild
155
156* Sun Aug 27 2006 Garrick Staples <garrick@usc.edu> 1.14-1
157- bump to 1.14
158- FC6 mass rebuild
159
160* Fri Apr 21 2006 Garrick Staples <garrick@usc.edu> 1.13-3
161- add a note about the falsely alarming warning
162- don't remove execute bit from demos
163
164* Thu Apr 20 2006 Garrick Staples <garrick@usc.edu> 1.13-2
165- spec cleanups
166- add doc files
167
168* Wed Apr 19 2006 Garrick Staples <garrick@usc.edu> 1.13-1
169- Initial spec file
Note: See TracBrowser for help on using the repository browser.