source: projects/specs/trunk/p/perl-Crypt-SSLeay/perl-Crypt-SSLeay-vl.spec @ 9176

Revision 9176, 7.5 KB checked in by inagaki, 9 years ago (diff)

2014-12-21 Ryoichi INAGAKI <ryo1@…>

  • perl-Class-{Load, Load-XS}, perl-Try-Tiny: updated
  • perl-Crypt-SSLeay: rebuit


Line 
1# -*- coding: utf-8 -*-
2%define origname Crypt-SSLeay
3
4Name:           perl-Crypt-SSLeay
5Summary:        OpenSSL glue that provides LWP https support
6Version:        0.57
7Release:        3%{?_dist_release}
8
9License:        GPL or Artistic
10Group:          Development/Libraries
11URL:            http://search.cpan.org/dist/Crypt-SSLeay/
12
13Source0:        http://www.cpan.org/authors/id/D/DL/DLAND/%{origname}-%{version}.tar.gz
14Patch1:         perl-Crypt-SSLeay-cryptdef.patch
15Patch2:         perl-Crypt-SSLeay-0.57-live-tests.patch
16Patch3:         perl-Crypt-SSLeay-Makefile_ssl1.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires:  openssl-devel
20BuildRequires:  perl(ExtUtils::MakeMaker)
21BuildRequires:  perl(URI)
22BuildRequires:  perl(Test::Pod::Coverage)
23BuildRequires:  perl-libwww-perl
24Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
25Requires:       openssl
26
27Distribution: Vine Linux
28Vendor: Project Vine
29Packager: iwaim
30
31%description
32This perl module provides support for the https protocol under LWP, so
33that a LWP::UserAgent can make https GET & HEAD & POST
34requests. Please see perldoc LWP for more information on POST
35requests.
36
37The Crypt::SSLeay package contains Net::SSL, which is automatically
38loaded by LWP::Protocol::https on https requests, and provides the
39necessary SSL glue for that module to work.
40
41
42%prep
43%setup -q -n %{origname}-%{version}
44%patch1 -p1 -b .cryptdef
45%patch2 -p1
46%patch3 -p1 -b .make
47
48# Filter unwanted Provides:
49cat << EOF > %{name}-prov
50#!/bin/sh
51%{__perl_provides} $* |\
52  sed -e '/perl(DB)/d'
53EOF
54
55%define __perl_provides %{_builddir}/Crypt-SSLeay-%{version}/%{name}-prov
56chmod +x %{__perl_provides}
57
58
59%build
60if pkg-config openssl ; then
61  export INC="$CFLAGS `pkg-config --cflags-only-I openssl`"
62  export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
63fi
64
65%{__perl} Makefile.PL --default --no-live-tests INC="$INC" \
66          LDFLAGS="$LDFLAGS" INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
67make %{?_smp_mflags}
68
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73
74%install
75rm -rf $RPM_BUILD_ROOT
76make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
77find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
78find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
79find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
80chmod -R u+w $RPM_BUILD_ROOT/*
81chmod -R 644 eg/*
82chmod -R 644 certs/*
83
84%check
85make test
86
87
88%files
89%defattr(-,root,root,-)
90%doc README Changes eg/* certs/*
91%{perl_vendorarch}/auto/Crypt/
92%{perl_vendorarch}/Crypt/
93%{perl_vendorarch}/Net/
94%{_mandir}/man3/*.3*
95
96
97%changelog
98* Sun Dec 21 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.57-3
99- rebuilt with perl 5.16.3
100
101* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 0.57-2vl6
102- build with perl 5.12.3
103
104* Wed Apr  7 2010 IWAI, Masaharu <iwai@alib.jp> 0.57-1
105- initial build for Vine Linux
106
107* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.57-16
108- rebuild against perl 5.10.1
109
110* Wed Nov 25 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.57-14
111- change Makefile for openssl 1.0, which couldn't be found properly before
112
113* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-13
114- rebuilt with new openssl
115
116* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-12
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
118
119* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-11
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
121
122* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-10
123- rebuild with new openssl
124
125* Mon Oct  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-9
126- add examples into doc
127
128* Wed Sep 24 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-8
129- fix patches for fuzz
130
131* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.57-7
132- rebuild for new perl
133
134* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.57-6
135- Autorebuild for GCC 4.3
136
137* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.57-5
138 - Rebuild for deps
139
140* Wed Dec  5 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-4
141- Rebuild for new openssl
142
143* Sat Oct 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-3
144- Remove unnecessary BR: pkgconfig
145
146* Fri Oct 26 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-2
147- Fix buildroot per package review
148- Resolves: bz#226248
149
150* Thu Oct 25 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-1
151- Update to latest upstream version.
152- Remove old patch (patch applied to upstream)
153- Several fixes for package review:
154- Fixed BuildRequires (added Test::Pod and LWP::UserAgent)
155- Apply patch to avoid prompting for input when building Makefile
156- Fix defattr line
157- Resolves: bz#226248
158
159* Mon Aug 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-2
160- perl(ExtUtils::MakeMaker::Coverage) is now available
161
162* Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-1
163- 0.56 is the latest CPAN version, not 0.55
164
165* Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.55-2
166- Update to latest version from CPAN: 0.55
167- Remove two old patches, update lib64 patch for Makefile.PL changes.
168
169* Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.53-1
170- New version: 0.53
171
172* Mon Nov 27 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-12
173- Resolves: bug#217138
174- fix a segfault on x86_64
175
176* Tue Oct 17 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-10
177- Filter out Provides perl(DB)
178- bug #205562
179
180* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2.1
181- rebuild
182
183* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2
184- bump again for double-long bug on ppc(64)
185
186* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.1
187- rebuilt for new gcc4.1 snapshot and glibc changes
188
189* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.51-9.2
190- rebuild for new perl-5.8.8 / gcc / glibc
191
192* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
193- rebuilt for new gcc
194
195* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
196- rebuilt for new gcj
197
198* Thu Nov 10 2005 Tomas Mraz <tmraz@redhat.com> 0.51-9
199- rebuilt against new openssl
200- added missing SSL_library_init()
201
202* Sat Sep 24 2005 Ville Skyttä <ville.skytta at iki.fi> 0.51-8
203- Own more installed dirs (#73908).
204- Enable rpmbuild's internal dependency generator, drop unneeded dependencies.
205- Require perl(:MODULE_COMPAT_*).
206- Run tests in the %%check section.
207- Fix License, Source0, URL, and Group tags.
208
209* Wed Mar 30 2005 Warren Togami <wtogami@redhat.com> 0.51-7
210- remove brp-compress
211
212* Tue Mar  8 2005 Joe Orton <jorton@redhat.com> 0.51-6
213- rebuild
214
215* Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-5
216- build for FC3
217
218* Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-4
219- build for RHEL3 U4
220
221* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
222- rebuilt
223
224* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
225- rebuilt
226
227* Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 0.51-1
228- update to upstream 0.51
229
230* Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
231- rebuilt
232
233* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com>
234- pass openssl includes to make as INC and ldflags in as LDFLAGS
235
236* Thu Nov 21 2002 Chip Turner <cturner@redhat.com>
237- patch to support /usr/lib64 before /usr/lib
238
239* Wed Nov 20 2002 Chip Turner <cturner@redhat.com>
240- rebuild
241
242* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
243- automated release bump and build
244
245* Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
246- description update
247
248* Tue Jun 25 2002 Chip Turner <cturner@redhat.com>
249- move to 0.39
250
251* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
252- automated rebuild
253
254* Fri Dec 7 2001 root <root@redhat.com>
255- Spec file was autogenerated.
256
Note: See TracBrowser for help on using the repository browser.