source: projects/specs/trunk/p/perl-Crypt-SSLeay/perl-Crypt-SSLeay-vl.spec @ 777

Revision 777, 7.3 KB checked in by iwaim, 14 years ago (diff)

new: perl-Crypt-SSLeay 0.57-1

Line 
1# -*- coding: utf-8 -*-
2%define origname Crypt-SSLeay
3
4Name:           perl-Crypt-SSLeay
5Summary:        Crypt::SSLeay - OpenSSL glue that provides LWP https support
6Version:        0.57
7Release:        1%{?_dist_release}
8License:        Perl's
9Group:          Development/Libraries
10Source0:        http://www.cpan.org/authors/id/D/DL/DLAND/%{origname}-%{version}.tar.gz
11Patch1:         perl-Crypt-SSLeay-cryptdef.patch
12Patch2:         perl-Crypt-SSLeay-0.57-live-tests.patch
13Patch3:         perl-Crypt-SSLeay-Makefile_ssl1.patch
14URL:            http://search.cpan.org/dist/Crypt-SSLeay/
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16
17BuildRequires:  openssl-devel
18BuildRequires:  perl
19BuildRequires:  perl-URI
20BuildRequires:  perl-Test-Pod-Coverage
21BuildRequires:  perl-libwww-perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23Requires:       openssl
24
25Distribution: Vine Linux
26Vendor: Project Vine
27Packager: iwaim
28
29%description
30This perl module provides support for the https protocol under LWP, so
31that a LWP::UserAgent can make https GET & HEAD & POST
32requests. Please see perldoc LWP for more information on POST
33requests.
34
35The Crypt::SSLeay package contains Net::SSL, which is automatically
36loaded by LWP::Protocol::https on https requests, and provides the
37necessary SSL glue for that module to work.
38
39
40%prep
41%setup -q -n %{origname}-%{version}
42%patch1 -p1 -b .cryptdef
43%patch2 -p1
44%patch3 -p1 -b .make
45
46# Filter unwanted Provides:
47cat << EOF > %{name}-prov
48#!/bin/sh
49%{__perl_provides} $* |\
50  sed -e '/perl(DB)/d'
51EOF
52
53%define __perl_provides %{_builddir}/Crypt-SSLeay-%{version}/%{name}-prov
54chmod +x %{__perl_provides}
55
56
57%build
58if pkg-config openssl ; then
59  export INC="$CFLAGS `pkg-config --cflags-only-I openssl`"
60  export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
61fi
62
63%{__perl} Makefile.PL --default --no-live-tests INC="$INC" \
64          LDFLAGS="$LDFLAGS" INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
65make %{?_smp_mflags}
66
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71
72%install
73rm -rf $RPM_BUILD_ROOT
74make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
75find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
76find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
77find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
78chmod -R u+w $RPM_BUILD_ROOT/*
79chmod -R 644 eg/*
80chmod -R 644 certs/*
81
82#%check
83#make test
84
85
86%files
87%defattr(-,root,root,-)
88%doc README Changes eg/* certs/*
89%{perl_vendorarch}/auto/Crypt/
90%{perl_vendorarch}/Crypt/
91%{perl_vendorarch}/Net/
92%{_mandir}/man3/*.3*
93
94
95%changelog
96* Wed Apr  7 2010 IWAI, Masaharu <iwai@alib.jp> 0.57-1
97- initial build for Vine Linux
98
99* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.57-16
100- rebuild against perl 5.10.1
101
102* Wed Nov 25 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.57-14
103- change Makefile for openssl 1.0, which couldn't be found properly before
104
105* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-13
106- rebuilt with new openssl
107
108* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-12
109- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
110
111* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-11
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
113
114* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-10
115- rebuild with new openssl
116
117* Mon Oct  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-9
118- add examples into doc
119
120* Wed Sep 24 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-8
121- fix patches for fuzz
122
123* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.57-7
124- rebuild for new perl
125
126* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.57-6
127- Autorebuild for GCC 4.3
128
129* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.57-5
130 - Rebuild for deps
131
132* Wed Dec  5 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-4
133- Rebuild for new openssl
134
135* Sat Oct 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-3
136- Remove unnecessary BR: pkgconfig
137
138* Fri Oct 26 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-2
139- Fix buildroot per package review
140- Resolves: bz#226248
141
142* Thu Oct 25 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-1
143- Update to latest upstream version.
144- Remove old patch (patch applied to upstream)
145- Several fixes for package review:
146- Fixed BuildRequires (added Test::Pod and LWP::UserAgent)
147- Apply patch to avoid prompting for input when building Makefile
148- Fix defattr line
149- Resolves: bz#226248
150
151* Mon Aug 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-2
152- perl(ExtUtils::MakeMaker::Coverage) is now available
153
154* Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-1
155- 0.56 is the latest CPAN version, not 0.55
156
157* Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.55-2
158- Update to latest version from CPAN: 0.55
159- Remove two old patches, update lib64 patch for Makefile.PL changes.
160
161* Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.53-1
162- New version: 0.53
163
164* Mon Nov 27 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-12
165- Resolves: bug#217138
166- fix a segfault on x86_64
167
168* Tue Oct 17 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-10
169- Filter out Provides perl(DB)
170- bug #205562
171
172* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2.1
173- rebuild
174
175* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2
176- bump again for double-long bug on ppc(64)
177
178* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.1
179- rebuilt for new gcc4.1 snapshot and glibc changes
180
181* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.51-9.2
182- rebuild for new perl-5.8.8 / gcc / glibc
183
184* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
185- rebuilt for new gcc
186
187* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
188- rebuilt for new gcj
189
190* Thu Nov 10 2005 Tomas Mraz <tmraz@redhat.com> 0.51-9
191- rebuilt against new openssl
192- added missing SSL_library_init()
193
194* Sat Sep 24 2005 Ville Skyttä <ville.skytta at iki.fi> 0.51-8
195- Own more installed dirs (#73908).
196- Enable rpmbuild's internal dependency generator, drop unneeded dependencies.
197- Require perl(:MODULE_COMPAT_*).
198- Run tests in the %%check section.
199- Fix License, Source0, URL, and Group tags.
200
201* Wed Mar 30 2005 Warren Togami <wtogami@redhat.com> 0.51-7
202- remove brp-compress
203
204* Tue Mar  8 2005 Joe Orton <jorton@redhat.com> 0.51-6
205- rebuild
206
207* Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-5
208- build for FC3
209
210* Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-4
211- build for RHEL3 U4
212
213* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
214- rebuilt
215
216* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
217- rebuilt
218
219* Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 0.51-1
220- update to upstream 0.51
221
222* Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
223- rebuilt
224
225* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com>
226- pass openssl includes to make as INC and ldflags in as LDFLAGS
227
228* Thu Nov 21 2002 Chip Turner <cturner@redhat.com>
229- patch to support /usr/lib64 before /usr/lib
230
231* Wed Nov 20 2002 Chip Turner <cturner@redhat.com>
232- rebuild
233
234* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
235- automated release bump and build
236
237* Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
238- description update
239
240* Tue Jun 25 2002 Chip Turner <cturner@redhat.com>
241- move to 0.39
242
243* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
244- automated rebuild
245
246* Fri Dec 7 2001 root <root@redhat.com>
247- Spec file was autogenerated.
248
Note: See TracBrowser for help on using the repository browser.