source: projects/specs/trunk/p/perl-Crypt-SSLeay/perl-Crypt-SSLeay-vl.spec @ 10262

Revision 10262, 7.6 KB checked in by tomop, 8 years ago (diff)

perl-Crypt-SSLeay-0.72-1

Line 
1# -*- coding: utf-8 -*-
2# Disable network tests by default
3%bcond_with network_tests
4
5%define origname Crypt-SSLeay
6
7Name:           perl-Crypt-SSLeay
8Summary:        OpenSSL glue that provides LWP https support
9Version:        0.72
10Release:        1%{?_dist_release}
11
12License:        GPL or Artistic
13Group:          Development/Libraries
14URL:            http://search.cpan.org/dist/Crypt-SSLeay/
15
16Source0:        http://www.cpan.org/authors/id/D/DL/DLAND/%{origname}-%{version}.tar.gz
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires:  openssl-devel
20BuildRequires:  perl(ExtUtils::MakeMaker)
21BuildRequires:  perl(Path::Class)
22BuildRequires:  perl(Test::Pod::Coverage)
23BuildRequires:  perl(Try::Tiny)
24BuildRequires:  perl(URI)
25BuildRequires:  perl-libwww-perl
26Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
27Requires:       openssl
28
29Distribution: Vine Linux
30Vendor: Project Vine
31Packager: iwaim
32
33%description
34This perl module provides support for the https protocol under LWP, so
35that a LWP::UserAgent can make https GET & HEAD & POST
36requests. Please see perldoc LWP for more information on POST
37requests.
38
39The Crypt::SSLeay package contains Net::SSL, which is automatically
40loaded by LWP::Protocol::https on https requests, and provides the
41necessary SSL glue for that module to work.
42
43
44%prep
45%setup -q -n %{origname}-%{version}
46
47# Filter unwanted Provides:
48cat << EOF > %{name}-prov
49#!/bin/sh
50%{__perl_provides} $* |\
51  sed -e '/perl(DB)/d'
52EOF
53
54%define __perl_provides %{_builddir}/Crypt-SSLeay-%{version}/%{name}-prov
55chmod +x %{__perl_provides}
56
57
58%build
59if pkg-config openssl ; then
60  export INC="$CFLAGS `pkg-config --cflags-only-I openssl`"
61  export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
62fi
63
64%{__perl} Makefile.PL --%{!?with_network_tests:no-}live-tests \
65    INC="$INC" LDFLAGS="$LDFLAGS" INSTALLDIRS=vendor OPTIMIZE="%{optflags}" \
66    </dev/null
67make %{?_smp_mflags}
68
69
70%clean
71rm -rf $RPM_BUILD_ROOT
72
73
74%install
75rm -rf $RPM_BUILD_ROOT
76make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
77find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
78find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
79find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
80chmod -R u+w $RPM_BUILD_ROOT/*
81chmod -R 644 eg/*
82chmod -R 644 certs/*
83
84%check
85make test
86
87
88%files
89%defattr(-,root,root,-)
90%doc Changes eg/* certs/*
91%{perl_vendorarch}/auto/Crypt/
92%{perl_vendorarch}/Crypt/
93%{perl_vendorarch}/Net/
94%{_mandir}/man3/*.3*
95
96
97%changelog
98* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.72-1
99- new upstream release.
100- removed all patches (fixed in upstream).
101- added BR:perl(Path::Class) and BR:perl(Try::Tiny).
102
103* Sun Dec 21 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.57-3
104- rebuilt with perl 5.16.3
105
106* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 0.57-2vl6
107- build with perl 5.12.3
108
109* Wed Apr  7 2010 IWAI, Masaharu <iwai@alib.jp> 0.57-1
110- initial build for Vine Linux
111
112* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.57-16
113- rebuild against perl 5.10.1
114
115* Wed Nov 25 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.57-14
116- change Makefile for openssl 1.0, which couldn't be found properly before
117
118* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-13
119- rebuilt with new openssl
120
121* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-12
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
123
124* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-11
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
126
127* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-10
128- rebuild with new openssl
129
130* Mon Oct  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-9
131- add examples into doc
132
133* Wed Sep 24 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-8
134- fix patches for fuzz
135
136* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.57-7
137- rebuild for new perl
138
139* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.57-6
140- Autorebuild for GCC 4.3
141
142* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.57-5
143 - Rebuild for deps
144
145* Wed Dec  5 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-4
146- Rebuild for new openssl
147
148* Sat Oct 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-3
149- Remove unnecessary BR: pkgconfig
150
151* Fri Oct 26 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-2
152- Fix buildroot per package review
153- Resolves: bz#226248
154
155* Thu Oct 25 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-1
156- Update to latest upstream version.
157- Remove old patch (patch applied to upstream)
158- Several fixes for package review:
159- Fixed BuildRequires (added Test::Pod and LWP::UserAgent)
160- Apply patch to avoid prompting for input when building Makefile
161- Fix defattr line
162- Resolves: bz#226248
163
164* Mon Aug 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-2
165- perl(ExtUtils::MakeMaker::Coverage) is now available
166
167* Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-1
168- 0.56 is the latest CPAN version, not 0.55
169
170* Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.55-2
171- Update to latest version from CPAN: 0.55
172- Remove two old patches, update lib64 patch for Makefile.PL changes.
173
174* Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.53-1
175- New version: 0.53
176
177* Mon Nov 27 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-12
178- Resolves: bug#217138
179- fix a segfault on x86_64
180
181* Tue Oct 17 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-10
182- Filter out Provides perl(DB)
183- bug #205562
184
185* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2.1
186- rebuild
187
188* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2
189- bump again for double-long bug on ppc(64)
190
191* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.1
192- rebuilt for new gcc4.1 snapshot and glibc changes
193
194* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.51-9.2
195- rebuild for new perl-5.8.8 / gcc / glibc
196
197* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
198- rebuilt for new gcc
199
200* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
201- rebuilt for new gcj
202
203* Thu Nov 10 2005 Tomas Mraz <tmraz@redhat.com> 0.51-9
204- rebuilt against new openssl
205- added missing SSL_library_init()
206
207* Sat Sep 24 2005 Ville Skyttä <ville.skytta at iki.fi> 0.51-8
208- Own more installed dirs (#73908).
209- Enable rpmbuild's internal dependency generator, drop unneeded dependencies.
210- Require perl(:MODULE_COMPAT_*).
211- Run tests in the %%check section.
212- Fix License, Source0, URL, and Group tags.
213
214* Wed Mar 30 2005 Warren Togami <wtogami@redhat.com> 0.51-7
215- remove brp-compress
216
217* Tue Mar  8 2005 Joe Orton <jorton@redhat.com> 0.51-6
218- rebuild
219
220* Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-5
221- build for FC3
222
223* Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-4
224- build for RHEL3 U4
225
226* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
227- rebuilt
228
229* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
230- rebuilt
231
232* Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 0.51-1
233- update to upstream 0.51
234
235* Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
236- rebuilt
237
238* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com>
239- pass openssl includes to make as INC and ldflags in as LDFLAGS
240
241* Thu Nov 21 2002 Chip Turner <cturner@redhat.com>
242- patch to support /usr/lib64 before /usr/lib
243
244* Wed Nov 20 2002 Chip Turner <cturner@redhat.com>
245- rebuild
246
247* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
248- automated release bump and build
249
250* Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
251- description update
252
253* Tue Jun 25 2002 Chip Turner <cturner@redhat.com>
254- move to 0.39
255
256* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
257- automated rebuild
258
259* Fri Dec 7 2001 root <root@redhat.com>
260- Spec file was autogenerated.
261
Note: See TracBrowser for help on using the repository browser.