source: projects/specs/trunk/p/perl-Crypt-SSLeay/perl-Crypt-SSLeay-vl.spec @ 11912

Revision 11912, 8.0 KB checked in by tomop, 5 years ago (diff)

perl-Crypt-SSLeay-0.72-2

RevLine 
[777]1# -*- coding: utf-8 -*-
[10262]2# Disable network tests by default
3%bcond_with network_tests
4
[777]5%define origname Crypt-SSLeay
6
7Name:           perl-Crypt-SSLeay
[9176]8Summary:        OpenSSL glue that provides LWP https support
[10262]9Version:        0.72
[11912]10Release:        2%{?_dist_release}
[9176]11
12License:        GPL or Artistic
[777]13Group:          Development/Libraries
[9176]14URL:            http://search.cpan.org/dist/Crypt-SSLeay/
15
[777]16Source0:        http://www.cpan.org/authors/id/D/DL/DLAND/%{origname}-%{version}.tar.gz
[9176]17
[11912]18# Adapt to OpenSSL 1.1.0, bug #1383756, CPAN RT#118343
19Patch0:         Crypt-SSLeay-0.72-Do-not-use-SSLv2_client_method-with-OpenSSL-1.1.0.patch
20Patch1:         Crypt-SSLeay-0.72-Fix-building-on-Perl-without-dot-in-INC.patch
21
[777]22BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
23BuildRequires:  openssl-devel
[9176]24BuildRequires:  perl(ExtUtils::MakeMaker)
[10262]25BuildRequires:  perl(Path::Class)
26BuildRequires:  perl(Test::Pod::Coverage)
27BuildRequires:  perl(Try::Tiny)
[9176]28BuildRequires:  perl(URI)
[777]29BuildRequires:  perl-libwww-perl
30Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
31Requires:       openssl
32
33Distribution: Vine Linux
34Vendor: Project Vine
35Packager: iwaim
36
37%description
38This perl module provides support for the https protocol under LWP, so
39that a LWP::UserAgent can make https GET & HEAD & POST
40requests. Please see perldoc LWP for more information on POST
41requests.
42
43The Crypt::SSLeay package contains Net::SSL, which is automatically
44loaded by LWP::Protocol::https on https requests, and provides the
45necessary SSL glue for that module to work.
46
47
48%prep
49%setup -q -n %{origname}-%{version}
[11912]50%patch0 -p1
51%patch1 -p1
[777]52
[11912]53# Placate rpmlint
54chmod -c -x lib/Net/SSL.pm
55
[777]56# Filter unwanted Provides:
57cat << EOF > %{name}-prov
58#!/bin/sh
59%{__perl_provides} $* |\
60  sed -e '/perl(DB)/d'
61EOF
62
63%define __perl_provides %{_builddir}/Crypt-SSLeay-%{version}/%{name}-prov
64chmod +x %{__perl_provides}
65
66
67%build
68if pkg-config openssl ; then
69  export INC="$CFLAGS `pkg-config --cflags-only-I openssl`"
70  export LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"
71fi
72
[10262]73%{__perl} Makefile.PL --%{!?with_network_tests:no-}live-tests \
74    INC="$INC" LDFLAGS="$LDFLAGS" INSTALLDIRS=vendor OPTIMIZE="%{optflags}" \
75    </dev/null
[777]76make %{?_smp_mflags}
77
78
79%clean
80rm -rf $RPM_BUILD_ROOT
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
86find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
87find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
88find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
89chmod -R u+w $RPM_BUILD_ROOT/*
90chmod -R 644 eg/*
91chmod -R 644 certs/*
92
[9176]93%check
94make test
[777]95
96
97%files
98%defattr(-,root,root,-)
[10262]99%doc Changes eg/* certs/*
[777]100%{perl_vendorarch}/auto/Crypt/
101%{perl_vendorarch}/Crypt/
102%{perl_vendorarch}/Net/
103%{_mandir}/man3/*.3*
104
105
106%changelog
[11912]107* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.72-2
108- rebuilt with openssl-1.1.1.
109- imported Patch0-1 from rawhide.
110
[10262]111* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.72-1
112- new upstream release.
113- removed all patches (fixed in upstream).
114- added BR:perl(Path::Class) and BR:perl(Try::Tiny).
115
[9176]116* Sun Dec 21 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.57-3
117- rebuilt with perl 5.16.3
118
[3264]119* Sun Apr  3 2011 IWAI, Masaharu <iwai@alib.jp> 0.57-2vl6
120- build with perl 5.12.3
121
[777]122* Wed Apr  7 2010 IWAI, Masaharu <iwai@alib.jp> 0.57-1
123- initial build for Vine Linux
124
125* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.57-16
126- rebuild against perl 5.10.1
127
128* Wed Nov 25 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.57-14
129- change Makefile for openssl 1.0, which couldn't be found properly before
130
131* Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-13
132- rebuilt with new openssl
133
134* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-12
135- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
136
137* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.57-11
138- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
139
140* Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.57-10
141- rebuild with new openssl
142
143* Mon Oct  6 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-9
144- add examples into doc
145
146* Wed Sep 24 2008 Marcela Maslanova <mmaslano@redhat.com> - 0.57-8
147- fix patches for fuzz
148
149* Wed Mar  5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.57-7
150- rebuild for new perl
151
152* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.57-6
153- Autorebuild for GCC 4.3
154
155* Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.57-5
156 - Rebuild for deps
157
158* Wed Dec  5 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-4
159- Rebuild for new openssl
160
161* Sat Oct 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-3
162- Remove unnecessary BR: pkgconfig
163
164* Fri Oct 26 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-2
165- Fix buildroot per package review
166- Resolves: bz#226248
167
168* Thu Oct 25 2007 Robin Norwood <rnorwood@redhat.com> - 0.57-1
169- Update to latest upstream version.
170- Remove old patch (patch applied to upstream)
171- Several fixes for package review:
172- Fixed BuildRequires (added Test::Pod and LWP::UserAgent)
173- Apply patch to avoid prompting for input when building Makefile
174- Fix defattr line
175- Resolves: bz#226248
176
177* Mon Aug 27 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-2
178- perl(ExtUtils::MakeMaker::Coverage) is now available
179
180* Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.56-1
181- 0.56 is the latest CPAN version, not 0.55
182
183* Mon Aug 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.55-2
184- Update to latest version from CPAN: 0.55
185- Remove two old patches, update lib64 patch for Makefile.PL changes.
186
187* Tue Feb 13 2007 Robin Norwood <rnorwood@redhat.com> - 0.53-1
188- New version: 0.53
189
190* Mon Nov 27 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-12
191- Resolves: bug#217138
192- fix a segfault on x86_64
193
194* Tue Oct 17 2006 Robin Norwood <rnorwood@redhat.com> - 0.51-10
195- Filter out Provides perl(DB)
196- bug #205562
197
198* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2.1
199- rebuild
200
201* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.2
202- bump again for double-long bug on ppc(64)
203
204* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.51-9.2.1
205- rebuilt for new gcc4.1 snapshot and glibc changes
206
207* Fri Feb 03 2006 Jason Vas Dias <jvdias@redhat.com> - 0.51-9.2
208- rebuild for new perl-5.8.8 / gcc / glibc
209
210* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
211- rebuilt for new gcc
212
213* Fri Dec 16 2005 Jesse Keating <jkeating@redhat.com>
214- rebuilt for new gcj
215
216* Thu Nov 10 2005 Tomas Mraz <tmraz@redhat.com> 0.51-9
217- rebuilt against new openssl
218- added missing SSL_library_init()
219
220* Sat Sep 24 2005 Ville Skyttä <ville.skytta at iki.fi> 0.51-8
221- Own more installed dirs (#73908).
222- Enable rpmbuild's internal dependency generator, drop unneeded dependencies.
223- Require perl(:MODULE_COMPAT_*).
224- Run tests in the %%check section.
225- Fix License, Source0, URL, and Group tags.
226
227* Wed Mar 30 2005 Warren Togami <wtogami@redhat.com> 0.51-7
228- remove brp-compress
229
230* Tue Mar  8 2005 Joe Orton <jorton@redhat.com> 0.51-6
231- rebuild
232
233* Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-5
234- build for FC3
235
236* Tue Aug 31 2004 Chip Turner <cturner@redhat.com> 0.51-4
237- build for RHEL3 U4
238
239* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
240- rebuilt
241
242* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
243- rebuilt
244
245* Fri Feb 13 2004 Chip Turner <cturner@redhat.com> 0.51-1
246- update to upstream 0.51
247
248* Thu Jun 05 2003 Elliot Lee <sopwith@redhat.com>
249- rebuilt
250
251* Tue Jan  7 2003 Nalin Dahyabhai <nalin@redhat.com>
252- pass openssl includes to make as INC and ldflags in as LDFLAGS
253
254* Thu Nov 21 2002 Chip Turner <cturner@redhat.com>
255- patch to support /usr/lib64 before /usr/lib
256
257* Wed Nov 20 2002 Chip Turner <cturner@redhat.com>
258- rebuild
259
260* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
261- automated release bump and build
262
263* Thu Jun 27 2002 Chip Turner <cturner@redhat.com>
264- description update
265
266* Tue Jun 25 2002 Chip Turner <cturner@redhat.com>
267- move to 0.39
268
269* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
270- automated rebuild
271
272* Fri Dec 7 2001 root <root@redhat.com>
273- Spec file was autogenerated.
274
Note: See TracBrowser for help on using the repository browser.