source: projects/specs/trunk/p/perl-Crypt-OpenSSL-RSA/perl-Crypt-OpenSSL-RSA-vl.spec @ 11914

Revision 11914, 2.5 KB checked in by tomop, 5 years ago (diff)

perl-Crypt-OpenSSL-RSA-0.31-1

  • Property svn:executable set to *
Line 
1Summary: Crypt-OpenSSL-RSA Perl module
2Name: perl-Crypt-OpenSSL-RSA
3Version: 0.31
4Release: 1%{?_dist_release}
5License: GPL or Artistic
6Group: Development/Libraries
7URL: http://search.cpan.org/dist/Crypt-OpenSSL-RSA/
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
9BuildRequires: openssl-devel
10BuildRequires: perl-Crypt-OpenSSL-Guess
11Requires: perl-Crypt-OpenSSL-Random
12Source0: Crypt-OpenSSL-RSA-%{version}.tar.gz
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: tomop
16
17%description
18Crypt::OpenSSL::RSA is an XS perl module designed to provide basic RSA
19functionality.  It does this by providing a glue to the RSA functions
20in the OpenSSL library.
21
22%prep
23%setup -q -n Crypt-OpenSSL-RSA-%{version}
24
25%build
26CFLAGS="$RPM_OPT_FLAGS" %{__perl} Makefile.PL INSTALLDIRS="vendor"
27make %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS"
28
29%install
30rm -rf $RPM_BUILD_ROOT
31
32make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
33
34find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
35  -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
36find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
37chmod -R u+w $RPM_BUILD_ROOT/*
38
39for brp in %{_prefix}/lib/rpm/%{_build_vendor}/brp-compress \
40  %{_prefix}/lib/rpm/brp-compress
41do
42  [ -x $brp ] && $brp && break
43done
44
45
46find $RPM_BUILD_ROOT -type f \
47| sed "s@^$RPM_BUILD_ROOT@@g" \
48> %{name}-%{version}-%{release}-filelist
49
50eval `%{__perl} -V:archname -V:installsitelib -V:installvendorlib -V:installprivlib`
51for d in $installsitelib $installvendorlib $installprivlib; do
52  [ -z "$d" -o "$d" = "UNKNOWN" -o ! -d "$RPM_BUILD_ROOT$d" ] && continue
53  find $RPM_BUILD_ROOT$d/* -type d \
54  | grep -v "/$archname\(/auto\)\?$" \
55  | sed "s@^$RPM_BUILD_ROOT@%dir @g" \
56  >> %{name}-%{version}-%{release}-filelist
57done
58
59if [ "$(cat %{name}-%{version}-%{release}-filelist)X" = "X" ] ; then
60    echo "ERROR: EMPTY FILE LIST"
61    exit 1
62fi
63
64%clean
65rm -rf $RPM_BUILD_ROOT
66
67%files -f %{name}-%{version}-%{release}-filelist
68%defattr(-,root,root,-)
69%doc Changes LICENSE README
70
71%changelog
72* Sun Nov 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.31-1
73- new upstream release.
74
75* Mon May  9 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.28-3
76- rebuilt with openssl-1.0.2.
77
78* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.28-2
79- rebuilt with perl-5.16.3.
80
81* Thu Mar 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.28-1
82- new upstream release.
83
84* Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.25-1
85- initial build.
86
Note: See TracBrowser for help on using the repository browser.