source: projects/specs/trunk/p/perl-Crypt-OpenSSL-RSA/perl-Crypt-OpenSSL-RSA-vl.spec @ 8699

Revision 8699, 2.2 KB checked in by tomop, 10 years ago (diff)

spamassassin-3.4.0

  • Property svn:executable set to *
Line 
1Summary: Crypt-OpenSSL-RSA Perl module
2Name: perl-Crypt-OpenSSL-RSA
3Version: 0.28
4Release: 2%{?_dist_release}
5License: GPL or Artistic
6Group: Development/Libraries
7URL: http://search.cpan.org/dist/Crypt-OpenSSL-RSA/
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
9BuildRequires: openssl-devel
10Requires: perl-Crypt-OpenSSL-Random
11Source0: Crypt-OpenSSL-RSA-%{version}.tar.gz
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: tomop
15
16%description
17Crypt::OpenSSL::RSA is an XS perl module designed to provide basic RSA
18functionality.  It does this by providing a glue to the RSA functions
19in the OpenSSL library.
20
21%prep
22%setup -q -n Crypt-OpenSSL-RSA-%{version}
23
24%build
25CFLAGS="$RPM_OPT_FLAGS" %{__perl} Makefile.PL INSTALLDIRS="vendor"
26make %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS"
27
28%install
29rm -rf $RPM_BUILD_ROOT
30
31make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
32
33find $RPM_BUILD_ROOT -type f -a \( -name perllocal.pod -o -name .packlist \
34  -o \( -name '*.bs' -a -empty \) \) -exec rm -f {} ';'
35find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
36chmod -R u+w $RPM_BUILD_ROOT/*
37
38for brp in %{_prefix}/lib/rpm/%{_build_vendor}/brp-compress \
39  %{_prefix}/lib/rpm/brp-compress
40do
41  [ -x $brp ] && $brp && break
42done
43
44
45find $RPM_BUILD_ROOT -type f \
46| sed "s@^$RPM_BUILD_ROOT@@g" \
47> %{name}-%{version}-%{release}-filelist
48
49eval `%{__perl} -V:archname -V:installsitelib -V:installvendorlib -V:installprivlib`
50for d in $installsitelib $installvendorlib $installprivlib; do
51  [ -z "$d" -o "$d" = "UNKNOWN" -o ! -d "$RPM_BUILD_ROOT$d" ] && continue
52  find $RPM_BUILD_ROOT$d/* -type d \
53  | grep -v "/$archname\(/auto\)\?$" \
54  | sed "s@^$RPM_BUILD_ROOT@%dir @g" \
55  >> %{name}-%{version}-%{release}-filelist
56done
57
58if [ "$(cat %{name}-%{version}-%{release}-filelist)X" = "X" ] ; then
59    echo "ERROR: EMPTY FILE LIST"
60    exit 1
61fi
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%files -f %{name}-%{version}-%{release}-filelist
67%defattr(-,root,root,-)
68%doc Changes LICENSE README
69
70%changelog
71* Mon Jun 30 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.28-2
72- rebuilt with perl-5.16.3.
73
74* Thu Mar 27 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.28-1
75- new upstream release.
76
77* Tue Apr 29 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 0.25-1
78- initial build.
79
Note: See TracBrowser for help on using the repository browser.