source: projects/specs/trunk/p/perl-Crypt-DSA/perl-Crypt-DSA-vl.spec @ 5888

Revision 5888, 3.1 KB checked in by shaolin, 12 years ago (diff)
  • perl-Crypt-DSA: update to 1.17
  • perl-Math-BigInt?-GMP: new package
Line 
1%define module  Crypt-DSA
2%define name    perl-%{module}
3%define version 1.17
4%define release 1%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        DSA Signatures and Key Generation
10Group:          Development/Languages
11License:        GPL or Artistic
12Url:            http://search.cpan.org/dist/%{module}/
13Source:         http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
14BuildArch:      noarch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16BuildRequires:  perl-Digest-SHA1, perl(Math::BigInt)
17BuildRequires:  perl(Carp)
18BuildRequires:  perl(Convert::PEM)
19BuildRequires:  perl(Crypt::DES_EDE3)
20BuildRequires:  perl(Data::Buffer) >= 0.01
21BuildRequires:  perl(Digest::SHA1)
22BuildRequires:  perl(ExtUtils::MakeMaker)
23BuildRequires:  perl(File::Spec)
24BuildRequires:  perl(File::Which) >= 0.05
25BuildRequires:  perl(IPC::Open3)
26BuildRequires:  perl(Math::BigInt) >= 1.78
27BuildRequires:  perl(Math::BigInt::GMP)
28BuildRequires:  perl(Perl::MinimumVersion) >= 1.20
29BuildRequires:  perl(Test::CPAN::Meta) >= 0.12
30BuildRequires:  perl(Test::More) >= 0.42
31BuildRequires:  perl(Test::MinimumVersion) >= 0.008
32BuildRequires:  perl(Test::Pod) >= 1.26
33BuildRequires:  openssl
34Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
35# Crypt::DSA::Keychain calls openssl for DSA parameter generation
36Requires:       openssl
37# Some operations are really slow without GMP (or Pari, but we test with GMP)
38Requires:       perl(Math::BigInt::GMP)
39
40Vendor:         Project Vine
41Distribution:   Vine Linux
42
43%description
44Crypt::DSA is an implementation of the DSA (Digital Signature Algorithm)
45signature verification system. The implementation itself is pure Perl,
46although the heavy-duty mathematics underneath are provided by
47the Math::Pari library.
48
49This package provides DSA signing, signature verification,
50and key generation.
51
52%prep
53%setup -q -n %{module}-%{version}
54
55%build
56CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor"
57%{__make}
58
59%check
60echo -e "\n\nWill take several minutes for the tests. Please wait.\n\n"
61## WARNING: you'll need many hardware input / network traffic
62## to keep the 'entropy pool' filled with random bits -
63## otherwise the test will take enormous amount of time (shaolin)
64%{__make} test
65%{__make} test AUTOMATED_TESTING=1 TEST_FILES="xt/*.t"
66
67%install
68make pure_install DESTDIR=%{buildroot}
69find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
70find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
71%{_fixperms} %{buildroot}
72
73%clean
74rm -rf %{buildroot}
75
76%files
77%defattr(-,root,root)
78%doc README Changes
79%{_mandir}/man3*/*
80%{perl_vendorlib}/Crypt/*
81
82%changelog
83* Mon Mar 12 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.17-1
84- updated to 1.17
85
86* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-1vl5
87- rebuild with perl 5.10
88- new versioning policy
89
90* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl1
91- built for VineSeed
92
93* Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl0.43
94- add Requires: perl-Convert-PEM/perl-Data-Buffer
95
96* Sun Mar 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.14-0vl0.42
97- built for Vine 4.2 (testing)
98- 1st build for Vine
99
100
Note: See TracBrowser for help on using the repository browser.