source: projects/specs/trunk/p/perl-Crypt-DES_EDE3/perl-Crypt-DES_EDE3-vl.spec @ 9062

Revision 9062, 2.6 KB checked in by inagaki, 9 years ago (diff)

2014-11-05 Ryoichi INAGAKI <ryo1@…>

  • perl-Crypt-DES: updated
  • perl-Crypt-DES_EDE3: changed Group
  • perl-Crypt-PasswdMD5, perl-Parse-Yapp, perl-XML-Encoding, perl-libxml-perl: rebuilt


Line 
1%define module  Crypt-DES_EDE3
2%define name    perl-%{module}
3%define version 0.01
4%define release 3%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        Triple-DES EDE encryption/decryption
10Group:          Development/Libraries
11License:        GPL or Artistic
12Url:            http://search.cpan.org/dist/%{module}/
13Source:         http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
14
15BuildArch:      noarch
16BuildRoot:      %{_tmppath}/%{name}-%{version}
17Buildrequires:  perl(Crypt::DES)
18BuildRequires:  perl(ExtUtils::MakeMaker)
19Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
20
21Vendor:         Project Vine
22Distribution:   Vine Linux
23
24%description
25Crypt::DES_EDE3 implements DES-EDE3 encryption.
26This is triple-DES encryption where an encrypt operation is
27encrypt-decrypt-encrypt, and decrypt is decrypt-encrypt-decrypt.
28This implementation uses Crypt::DES to do its dirty DES work,
29and simply provides a wrapper around that module: setting up
30the individual DES ciphers, initializing the keys, and performing
31the encryption/decryption steps.
32
33DES-EDE3 encryption requires a key size of 24 bytes.
34
35You're probably best off not using this module directly,
36as the encrypt and decrypt methods expect 8-octet blocks.
37You might want to use the module in conjunction with Crypt::CBC,
38for example. This would be DES-EDE3-CBC, or triple-DES in outer CBC mode.
39
40#'
41%prep
42%setup -q -n %{module}-%{version}
43
44%build
45CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{_prefix}"
46%{__make}
47
48# %check
49# %{__make} test
50
51%install
52rm -rf $RPM_BUILD_ROOT
53make install DESTDIR=$RPM_BUILD_ROOT
54
55# rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
56# rm -rf %{buildroot}%{perl_vendorarch}
57find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files
63%defattr(-,root,root)
64%doc README Changes
65%{_mandir}/man3*/*
66%{perl_vendorlib}/Crypt/*
67
68
69%changelog
70* Wed Nov  5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.01-3
71- rebuilt with perl 5.16.3
72- moved to Development/Libraries Group
73
74* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.01-2
75- rebuild with perl-5.12.3
76
77* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-1vl5
78- rebuild with perl 5.10
79- new versioning policy
80
81* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl1
82- built for VineSeed
83
84* Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl0.43
85- add Requires: and Buildrequires: perl-Crypt-DES
86
87* Tue Mar 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.01-0vl0.42
88- built for Vine 4.2 (testing)
89
Note: See TracBrowser for help on using the repository browser.