source: projects/specs/trunk/p/perl-Crypt-DES/perl-Crypt-DES-vl.spec @ 12120

Revision 12120, 2.1 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define module  Crypt-DES
2%define name    perl-%{module}
3%define version 2.07
4%define release 2%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        Perl DES encryption module
10Group:          Development/Libraries
11License:        GPL or Artistic
12URL:            http://search.cpan.org/dist/%{module}/
13Source:         http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}
16BuildRequires:  libxcrypt-devel
17BuildRequires:  perl(ExtUtils::MakeMaker)
18Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
19
20Vendor:         Project Vine
21Distribution:   Vine Linux
22
23%description
24The module implements the Crypt::CBC interface.
25
26%prep
27%setup -q -n %{module}-%{version}
28
29%build
30CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{_prefix}"
31%{__make}
32
33%install
34rm -rf $RPM_BUILD_ROOT
35make install DESTDIR=$RPM_BUILD_ROOT
36
37# rm -f %{buildroot}%{perl_archlib}/perllocal.pod
38# rm -rf %{buildroot}%{perl_vendorarch}/auto/*/*/.packlist
39find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
40
41%clean
42rm -rf $RPM_BUILD_ROOT
43
44%files
45%defattr(-,root,root)
46%doc README
47%{_mandir}/man3*/*
48%{perl_vendorarch}/Crypt/*
49%{perl_vendorarch}/auto/*
50
51
52%changelog
53* Thu May 16 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.07-2
54- rebuilt with perl-5.26.
55- added BR:libxcrypt-devel.
56
57* Wed Nov  5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.07-1
58- updated to 2.07
59- moved to Development/Libraries Group
60
61* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 2.05-3
62- build with Perl 5.16
63- add Requires MODULE_COMPAT_*
64
65* Fri Mar 25 2011 IWAI, Masaharu <iwai@alib.jp> 2.05-2vl6
66- build with perl 5.12.3
67
68* Thu May  1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.05-1
69- rebuilt with perl-5.10.0.
70
71* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.05-0vl1
72- rebuilt for VineSeed
73
74* Sun Mar 09 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.05-0vl0.43
75- rebuilt to release for VinePlus 4.2
76
77* Tue Mar 04 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.05-0vl0.42
78- built for Vine 4.2 (testing)
79
Note: See TracBrowser for help on using the repository browser.