source: projects/specs/trunk/p/perl-Convert-PEM/perl-Convert-PEM-vl.spec @ 9022

Revision 9022, 2.2 KB checked in by inagaki, 10 years ago (diff)

2014-10-25 Ryoichi INAGAKI <ryo1@…>

  • perl modules: rebuilt and update


Line 
1%define module  Convert-PEM
2%define name    perl-%{module}
3%define version 0.08
4%define release 1%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        Read/write encrypted ASN.1 PEM files
10
11Group:          Development/Libraries
12License:        GPL or Artistic
13URL:            http://search.cpan.org/dist/%{module}/
14
15Source:         http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
16
17BuildArch:      noarch
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19BuildRequires:  perl-Class-ErrorHandler
20BuildRequires:  perl-Convert-ASN1
21BuildRequires:  perl-Crypt-DES_EDE3
22
23Requires:       perl-Class-ErrorHandler
24Requires:       perl-Convert-ASN1
25Requires:       perl-Crypt-DES_EDE3
26Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
27
28Vendor:         Project Vine
29Distribution:   Vine Linux
30
31%description
32Convert::PEM reads and writes PEM files containing ASN.1-encoded objects.
33The files can optionally be encrypted using a symmetric cipher algorithm,
34such as 3DES.
35
36%prep
37%setup -q -n %{module}-%{version}
38
39%build
40%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
41make %{?_smp_mflags} OPTIMIZE="%{optflags}"
42
43%install
44rm -rf $RPM_BUILD_ROOT
45make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
46rm -f $RPM_BUILD_ROOT%{perl_archlib}/perllocal.pod
47rm -rf $RPM_BUILD_ROOT%{perl_vendorarch}
48
49%check
50make test
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55
56%files
57%defattr(-,root,root)
58%doc README Changes
59%{_mandir}/*/*
60%{perl_vendorlib}/*
61
62%changelog
63* Wed Oct 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.08-1
64- updated to 0.08
65- rebuild with perl-5.16.3
66- moved to Development/Libraries Group
67
68* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.07-2
69- rebuild with perl-5.12.3
70
71* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.07-1vl5
72- rebuild with perl 5.10
73- new versioning policy
74
75* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.07-0vl1
76- built for VineSeed
77
78* Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.07-0vl0.43
79- add Requires: perl-Convert-ASN1/perl-Crypt-DES_EDE3/perl-Class-ErrorHandler
80
81* Mon Mar 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.07-0vl0.42
82- built for Vine 4.2 (testing)
83- 1st build for Vine
84
85
Note: See TracBrowser for help on using the repository browser.