source: projects/specs/trunk/p/perl-Convert-PEM/perl-Convert-PEM-vl.spec @ 521

Revision 521, 1.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define module  Convert-PEM
2%define name    perl-%{module}
3%define version 0.07
4%define release 1%{_dist_release}
5
6Name:           %{name}
7Version:        %{version}
8Release:        %{release}
9Summary:        Read/write encrypted ASN.1 PEM files
10Group:          Development/Languages
11License:        GPL or Artistic
12Url:            http://search.cpan.org/dist/%{module}/
13Source:         http://search.cpan.org/CPAN/authors/id/B/BT/BTROTT/%{module}-%{version}.tar.gz
14Requires:       perl-Convert-ASN1
15Requires:       perl-Crypt-DES_EDE3
16Requires:       perl-Class-ErrorHandler
17
18BuildRequires:  perl-Class-ErrorHandler
19BuildRequires:  perl-Convert-ASN1
20BuildRequires:  perl-Crypt-DES_EDE3
21
22BuildArch:      noarch
23BuildRoot:      %{_tmppath}/%{name}-%{version}
24
25Vendor:         Project Vine
26Distribution:   Vine Linux
27
28%description
29Convert::PEM reads and writes PEM files containing ASN.1-encoded objects.
30The files can optionally be encrypted using a symmetric cipher algorithm,
31such as 3DES.
32
33%prep
34%setup -q -n %{module}-%{version}
35
36%build
37CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor" PREFIX="%{buildroot}%{_prefix}"
38%{__make}
39
40%check
41%{__make} test
42
43%install
44rm -rf %{buildroot}
45%makeinstall
46rm -f %{buildroot}%{perl_archlib}/perllocal.pod
47rm -rf %{buildroot}%{perl_vendorarch}
48
49%clean
50rm -rf %{buildroot}
51
52%files
53%defattr(-,root,root)
54%doc README Changes
55%{_mandir}/*/*
56%{perl_vendorlib}/*
57
58%changelog
59* Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.07-1vl5
60- rebuild with perl 5.10
61- new versioning policy
62
63* Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.07-0vl1
64- built for VineSeed
65
66* Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.07-0vl0.43
67- add Requires: perl-Convert-ASN1/perl-Crypt-DES_EDE3/perl-Class-ErrorHandler
68
69* Mon Mar 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.07-0vl0.42
70- built for Vine 4.2 (testing)
71- 1st build for Vine
72
73
Note: See TracBrowser for help on using the repository browser.