source: projects/specs/trunk/p/perl-Config-IniFiles/perl-Config-IniFiles-vl.spec @ 9142

Revision 9142, 2.4 KB checked in by inagaki, 9 years ago (diff)

2014-12-09 Ryoichi INAGAKI <ryo1@…>

  • perl-Config-{Any, General, IniFiles?}, perl-Log-Dispatch-{Config, Configurator-Any}, perl-Log-Dump, perl-Path-Extended, perl-Sort-Naturally perl-Test-{Output, Spelling}: updated
  • perl-ExtUtils?-MakeMaker?-CPANfile, perl-IO-Capture, perl-Module-CPANfile: NEW


Line 
1%define pkgname Config-IniFiles
2
3Summary:        A perl module for reading .ini-style configuration files.
4Name:           perl-%{pkgname}
5Version:        2.83
6Release:        1%{?_dist_release}
7Group:          Development/Libraries
8License:        GPL+ or Artistic
9URL:            http://config-inifiles.sourceforge.net/
10
11Source0:        %{pkgname}-%{version}.tar.gz
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-root
14BuildArch:      noarch
15BuildRequires:  perl(Module::Build::Compat)
16BuildRequires:  perl(ExtUtils::MakeMaker)
17BuildRequires:  perl(File::Basename)
18BuildRequires:  perl(File::Temp)
19BuildRequires:  perl(List::MoreUtils) >= 0.33
20BuildRequires:  perl(Test::More)
21BuildArch:      noarch
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24%description
25Config::IniFiles provides a way to have readable configuration files
26outside your Perl script. Configurations can be imported (inherited,
27stacked,...), sections can be grouped, and settings can be accessed
28from a tied hash.
29
30%prep
31%setup -q -n %{pkgname}-%{version}
32
33%build
34CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
35make %{?_smp_mflags}
36
37%install
38rm -rf %{buildroot}
39make pure_install PERL_INSTALL_ROOT=%{buildroot}
40find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
41find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
42chmod -R u+w %{buildroot}/*
43
44[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
45
46find %{buildroot}%{_prefix} -type f -print | \
47        sed "s@^%{buildroot}@@g" | \
48        grep -v perllocal.pod | \
49        grep -v "\.packlist" > %{pkgname}-%{version}-filelist
50if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
51    echo "ERROR: EMPTY FILE LIST"
52    exit -1
53fi
54
55%check
56make test
57
58
59%clean
60rm -rf %{buildroot}
61
62
63%files -f %{pkgname}-%{version}-filelist
64%defattr(-,root,root)
65%doc README MANIFEST
66
67
68%changelog
69* Sun Dec  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.83-1
70- new upstream release
71- added BR: perl(List::MoreUtils)
72- built with perl 5.16.3
73
74* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.68-1
75- updated to 2.68
76
77* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.39-2
78- rebuild with perl-5.12.3
79
80* Tue Jan 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.39-1
81- apply new versioning policy
82
83* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.39-0vl1
84- new upstream release
85
86* Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.38-0vl1
87- initial build for Vine Linux
88
Note: See TracBrowser for help on using the repository browser.