source: projects/specs/trunk/p/perl-Config-IniFiles/perl-Config-IniFiles-vl.spec @ 5792

Revision 5792, 2.1 KB checked in by shaolin, 12 years ago (diff)

new packages:

  • perl-IPTables-ChainMgr?
  • perl-IPTables-Parse
  • perl-NetPacket?
  • perl-Net-Telnet
  • perl-Regexp-Common
  • perl-Text-CSV
  • perl-Try-Tiny
Line 
1%define pkgname Config-IniFiles
2
3Summary:        A perl module for reading .ini-style configuration files.
4Name:           perl-%{pkgname}
5Version:        2.68
6Release:        1%{?_dist_release}
7Group:          Development/Libraries
8License:        GPL+ or Artistic
9URL:            http://config-inifiles.sourceforge.net/
10Source0:        %{pkgname}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12BuildArch:      noarch
13
14BuildRequires:  perl(Module::Build::Compat)
15BuildRequires:  perl(ExtUtils::MakeMaker)
16BuildRequires:  perl(Test::More)
17BuildArch:      noarch
18Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
19
20%description
21Config::IniFiles provides a way to have readable configuration files
22outside your Perl script. Configurations can be imported (inherited,
23stacked,...), sections can be grouped, and settings can be accessed
24from a tied hash.
25
26%prep
27%setup -q -n %{pkgname}-%{version}
28
29%build
30CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
31make %{?_smp_mflags}
32
33%install
34rm -rf %{buildroot}
35make pure_install PERL_INSTALL_ROOT=%{buildroot}
36find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
37find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
38chmod -R u+w %{buildroot}/*
39
40[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
41
42find %{buildroot}%{_prefix} -type f -print | \
43        sed "s@^%{buildroot}@@g" | \
44        grep -v perllocal.pod | \
45        grep -v "\.packlist" > %{pkgname}-%{version}-filelist
46if [ "$(cat %{pkgname}-%{version}-filelist)X" = "X" ] ; then
47    echo "ERROR: EMPTY FILE LIST"
48    exit -1
49fi
50
51%check
52make test
53
54
55%clean
56rm -rf %{buildroot}
57
58
59%files -f %{pkgname}-%{version}-filelist
60%defattr(-,root,root)
61%doc README MANIFEST
62
63
64%changelog
65* Thu Mar 01 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.68-1
66- updated to 2.68
67
68* Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.39-2
69- rebuild with perl-5.12.3
70
71* Tue Jan 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 2.39-1
72- apply new versioning policy
73
74* Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.39-0vl1
75- new upstream release
76
77* Sun Oct 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.38-0vl1
78- initial build for Vine Linux
79
Note: See TracBrowser for help on using the repository browser.