source: projects/specs/trunk/p/perl-Config-General/perl-Config-General-vl.spec @ 9142

Revision 9142, 5.5 KB checked in by inagaki, 9 years ago (diff)

2014-12-09 Ryoichi INAGAKI <ryo1@…>

  • perl-Config-{Any, General, IniFiles?}, perl-Log-Dispatch-{Config, Configurator-Any}, perl-Log-Dump, perl-Path-Extended, perl-Sort-Naturally perl-Test-{Output, Spelling}: updated
  • perl-ExtUtils?-MakeMaker?-CPANfile, perl-IO-Capture, perl-Module-CPANfile: NEW


Line 
1Name:           perl-Config-General
2Version:        2.56
3Release:        1%{?_dist_release}
4Summary:        Generic configuration module for Perl
5
6Group:          Development/Libraries
7License:        GPL+ or Artistic
8URL:            http://search.cpan.org/dist/Config-General/
9Source0:        http://www.cpan.org/authors/id/T/TL/TLINDEN/Config-General-%{version}.tar.gz
10Patch0:         %{name}-2.50-system-ixhash.patch
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildArch:      noarch
14BuildRequires:  perl(Carp)
15BuildRequires:  perl(Carp::Heavy)
16BuildRequires:  perl(ExtUtils::MakeMaker)
17BuildRequires:  perl(Test::More)
18BuildRequires:  perl(Tie::IxHash)
19Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
20
21%description
22This module opens a config file and parses its contents for
23you. After parsing the module returns a hash structure which contains
24the representation of the config file.
25The format of config files supported by Config::General is inspired by
26the well known Apache config format, in fact, this module is 100%
27read-compatible with Apache configs, but you can also just use simple
28name/value pairs in your config files.
29In addition to the capabilities of an Apache config file it supports
30some enhancements such as here-documents, C-style comments or
31multiline options. It is also possible to save the config back to
32disk, which makes the module a perfect backend for configuration
33interfaces.
34It is possible to use variables in config files and there exists also
35support for object oriented access to the configuration.
36
37
38%prep
39%setup -q -n Config-General-%{version}
40%patch0 -p1
41rm -r t/Tie # see patch0
42f=Changelog ; iconv -f iso-8859-1 -t utf-8 -o $f.utf8 $f ; mv $f.utf8 $f
43
44%build
45%{__perl} Makefile.PL INSTALLDIRS=vendor
46make %{?_smp_mflags}
47
48%install
49rm -rf %{buildroot}
50make pure_install DESTDIR=%{buildroot}
51find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
52find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null ';'
53%{_fixperms} %{buildroot}/*
54
55%check
56make test
57
58%clean
59rm -rf %{buildroot}
60
61
62%files
63%defattr(-,root,root,-)
64%doc Changelog README example.cfg
65%{perl_vendorlib}/Config/
66%{_mandir}/man3/Config::*.3*
67
68%changelog
69* Sun Dec  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.56-1
70- new upstream release
71- built with perl 5.16.3
72
73* Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.50-1
74- initial build for Vine Linux
75
76* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.50-6
77- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
78
79* Tue Sep 13 2011 Petr Pisar <ppisar@redhat.com> - 2.50-5
80- Build-require Carp because Carp dual-lives now (bug #736768)
81
82* Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 2.50-4
83- Perl mass rebuild
84
85* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.50-3
86- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
87
88* Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.50-2
89- 661697 rebuild for fixing problems with vendorach/lib
90
91* Thu Dec  2 2010 Ville Skyttä <ville.skytta@iki.fi> - 2.50-1
92- Update to 2.50, fixes #658945, #659046.
93
94* Tue Jun 29 2010 Ville Skyttä <ville.skytta@iki.fi> - 2.49-2
95- Rebuild.
96
97* Tue Jun  8 2010 Ville Skyttä <ville.skytta@iki.fi> - 2.49-1
98- Update to 2.49 (#601611).
99
100* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.48-2
101- Mass rebuild with perl-5.12.0
102
103* Fri Apr 23 2010 Ville Skyttä <ville.skytta@iki.fi> - 2.48-1
104- Update to 2.48.
105- Sync with current rpmdevtools Perl spec template.
106
107* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 2.44-2
108- rebuild against perl 5.10.1
109
110* Tue Sep  8 2009 Ville Skyttä <ville.skytta@iki.fi> - 2.44-1
111- Update to 2.44 (#521756).
112- Prune pre-2005 %%changelog entries.
113
114* Sun Jul 26 2009 Ville Skyttä <ville.skytta@iki.fi> - 2.43-1
115- Update to 2.43 (#513796).
116
117* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.42-3
118- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
119
120* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.42-2
121- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
122
123* Sun Jan  4 2009 Ville Skyttä <ville.skytta@iki.fi> - 2.42-1
124- 2.42.
125- Patch test suite to use system installed Tie::IxHash.
126- Fix some spelling errors in %%description.
127- Use Source0: instead of Source:.
128
129* Sat Jun 21 2008 Ville Skyttä <ville.skytta@iki.fi> - 2.40-1
130- 2.40.
131
132* Tue Jun 17 2008 Ville Skyttä <ville.skytta@iki.fi> - 2.39-1
133- 2.39.
134
135* Tue Mar  4 2008 Ville Skyttä <ville.skytta@iki.fi> - 2.38-1
136- 2.38.
137
138* Fri Feb  8 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.37-2
139- rebuild for new perl
140
141* Tue Nov 27 2007 Ville Skyttä <ville.skytta@iki.fi> - 2.37-1
142- 2.37 (#398801).
143- Convert docs to UTF-8.
144
145* Tue Aug  7 2007 Ville Skyttä <ville.skytta@iki.fi> - 2.33-2
146- License: GPL+ or Artistic
147
148* Wed Apr 18 2007 Ville Skyttä <ville.skytta@iki.fi> - 2.33-1
149- 2.33.
150- BuildRequire perl(ExtUtils::MakeMaker) and perl(Test::More).
151
152* Sat Feb 24 2007 Ville Skyttä <ville.skytta@iki.fi> - 2.32-1
153- 2.32.
154
155* Tue Aug 29 2006 Ville Skyttä <ville.skytta@iki.fi> - 2.31-2
156- Fix order of arguments to find(1).
157- Drop version from perl build dependency.
158
159* Thu Jan 12 2006 Ville Skyttä <ville.skytta@iki.fi> - 2.31-1
160- 2.31.
161
162* Fri Sep 16 2005 Ville Skyttä <ville.skytta@iki.fi> - 2.30-1
163- 2.30.
164
165* Wed May 18 2005 Ville Skyttä <ville.skytta@iki.fi> - 2.28-2
166- 2.28.
167
168* Fri Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 2.27-2
169- rebuilt
Note: See TracBrowser for help on using the repository browser.