source: projects/specs/trunk/p/perl-Clone/perl-Clone-vl.spec @ 9512

Revision 9512, 4.6 KB checked in by inagaki, 9 years ago (diff)

2015-04-16 Ryoichi INAGAKI <ryo1@…>

  • perl-{Cairo, Clone, Curses, Event, Guard, IO-AIO,

IO-Socket-SSL, IPC-Run, Tk, URI}: updated


Line 
1Name:           perl-Clone
2Version:        0.38
3Release:        1%{?_dist_release}
4Summary:        Recursively copy perl datatypes
5Group:          Development/Libraries
6License:        GPL+ or Artistic
7URL:            http://search.cpan.org/dist/Clone
8Source0:        http://search.cpan.org/CPAN/authors/id/R/RD/RDF/Clone-%{version}.tar.gz
9
10BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
11BuildRequires:  perl(ExtUtils::ParseXS)
12BuildRequires:  perl(Taint::Runtime)
13BuildRequires:  perl(Test::More)
14Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
15
16# don't "provide" private Perl libs
17%global _use_internal_dependency_generator 0
18%global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u
19%global __find_provides /bin/sh -c "%{__grep} -v '%_docdir' | %{__grep} -v '%{perl_vendorarch}/.*\\.so$' | %{__deploop P}"
20%global __find_requires /bin/sh -c "%{__grep} -v '%_docdir' | %{__deploop R}"
21
22Vendor:         Project Vine
23Distribution:   Vine Linux
24Packager:       shaolin
25
26%description
27This module provides a clone() method which makes recursive
28copies of nested hash, array, scalar and reference types,
29including tied variables and objects.
30
31clone() takes a scalar argument and an optional parameter that
32can be used to limit the depth of the copy. To duplicate lists,
33arrays or hashes, pass them in by reference.
34
35%prep
36%setup -q -n Clone-%{version}
37find . -type f -exec chmod -c -x {} ';'
38
39%build
40%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
41make %{?_smp_mflags}
42
43%install
44rm -rf $RPM_BUILD_ROOT
45make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
46find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
47find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
48find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
49chmod -R u+w $RPM_BUILD_ROOT/*
50
51%check
52make test
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files
58%defattr(-,root,root,-)
59%doc Changes
60%{perl_vendorarch}/auto/Clone/
61%{perl_vendorarch}/Clone.pm
62%{_mandir}/man3/*.3*
63
64
65%changelog
66* Thu Apr 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.38-1
67- new upstream release
68
69* Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.31-2
70- build with Perl 5.16
71
72* Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.31-1
73- initial build for Vine Linux
74
75* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-9
76- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
77
78* Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.31-8
79- Perl mass rebuild
80
81* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-7
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
83
84* Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-6
85- 661697 rebuild for fixing problems with vendorach/lib
86
87* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-5
88- Mass rebuild with perl-5.12.0
89
90* Fri Dec  4 2009 Stepan Kasal <skasal@redhat.com> - 0.31-4
91- rebuild against perl 5.10.1
92
93* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-3
94- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
95
96* Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.31-2
97- filter private Perl solibs from provides
98- remove some executable bits -- keep rpmlint happy
99
100* Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.31-1
101- update to 0.31
102
103* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28-5
104- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
105
106* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.28-4
107- Rebuild for perl 5.10 (again)
108
109* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.28-3
110- Autorebuild for GCC 4.3
111
112* Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-2
113- rebuild for new perl
114
115* Wed Nov 28 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-1
116- bump to 0.28
117
118* Fri Aug 24 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-2
119- license fix
120
121* Fri Jul 27 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-1
122- bump to 0.27
123
124* Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.22-1
125- bump to 0.22
126
127* Fri Sep 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-2
128- bump for fc6
129
130* Fri Mar 31 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-1
131- bump to 0.20
132- new BR: perl-Taint-Runtime
133
134* Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-3
135- bump for FC-5
136
137* Fri Jan  6 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-2
138- don't pass optflags twice
139- remove .bs files
140
141* Thu Jan  5 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-1
142- Initial package for Fedora Extras
Note: See TracBrowser for help on using the repository browser.