source: projects/specs/trunk/p/perl-Class-Singleton/perl-Class-Singleton-vl.spec @ 5480

Revision 5480, 3.0 KB checked in by yasumichi, 12 years ago (diff)

rebuild with perl-5.12.3

Line 
1Name:           perl-Class-Singleton
2Version:        1.4
3Release:        7%{?_dist_release}
4Summary:        Implementation of a "Singleton" class
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Class-Singleton/
8Source0:        http://www.cpan.org/authors/id/A/AB/ABW/Class-Singleton-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-root
10BuildArch:      noarch
11BuildRequires:  perl(ExtUtils::MakeMaker)
12BuildRequires:  perl(Test::More)
13Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
14
15Vendor:         Project Vine
16Distribution:   Vine Linux
17Packager:       yasumichi, inagaki
18
19%description
20This is the Class::Singleton module. A Singleton describes an object class
21that can have only one instance in any system. An example of a Singleton
22might be a print spooler or system registry. This module implements a
23Singleton class from which other classes can be derived. By itself, the
24Class::Singleton module does very little other than manage the
25instantiation of a single object. In deriving a class from
26Class::Singleton, your module will inherit the Singleton instantiation
27method and can implement whatever specific functionality is required.
28
29%prep
30%setup -q -n Class-Singleton-%{version}
31
32%build
33%{__perl} Makefile.PL INSTALLDIRS=vendor
34make %{?_smp_mflags}
35
36%install
37rm -rf $RPM_BUILD_ROOT
38
39make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
40
41find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
42find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
43
44%{_fixperms} $RPM_BUILD_ROOT/*
45
46%check
47make test
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52%files
53%defattr(-,root,root,-)
54%doc Changes README
55%{perl_vendorlib}/*
56%{_mandir}/man3/*
57
58%changelog
59* Wed Jan 25 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4-7
60- rebuild with perl-5.12.3
61
62* Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4-6
63- initial build for Vine Linux
64
65* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-5
66- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
67
68* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-4
69- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
70
71* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.4-3
72- Rebuild for perl 5.10 (again)
73
74* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4-2
75- rebuild for new perl
76
77* Mon Oct 15 2007 Steven Pritchard <steve@kspei.com> 1.4-1
78- Update to 1.4.
79- Update License tag.
80- Drop our copy of the license text.
81- Improve Summary.
82- Make description match cpanspec output.
83- BR Test::More.
84
85* Tue Apr 17 2007 Steven Pritchard <steve@kspei.com> 1.03-4
86- Use fixperms macro instead of our own chmod incantation.
87- BR ExtUtils::MakeMaker.
88
89* Sat Sep 16 2006 Steven Pritchard <steve@kspei.com> 1.03-3
90- Canonicalize Source0 URL.
91- Fix find option order.
92
93* Thu Sep 08 2005 Steven Pritchard <steve@kspei.com> 1.03-2
94- Fix permissions on Singleton.pm.
95
96* Wed Aug 31 2005 Steven Pritchard <steve@kspei.com> 1.03-1
97- Specfile autogenerated.
Note: See TracBrowser for help on using the repository browser.