source: projects/specs/trunk/p/perl-Class-Singleton/perl-Class-Singleton-vl.spec @ 9151

Revision 9151, 3.1 KB checked in by inagaki, 9 years ago (diff)

2014-12-13 Ryoichi INAGAKI <ryo1@…>

  • perl-Class-Autouse, perl-Image-Xbm, perl-Test-Harness-Straps: rebuilt
  • perl-Class-Autouse, perl-Image-{ExifTool?, Info, Xpm}, perl-Test-{EOL, Inline}: updated


Line 
1Name:           perl-Class-Singleton
2Version:        1.5
3Release:        1%{?_dist_release}
4Summary:        Implementation of a "Singleton" class
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Class-Singleton/
8Source0:        http://www.cpan.org/authors/id/A/AB/ABW/Class-Singleton-%{version}.tar.gz
9BuildRoot:      %{_tmppath}/%{name}-%{version}-root
10BuildArch:      noarch
11BuildRequires:  perl(ExtUtils::MakeMaker)
12BuildRequires:  perl(Test::More)
13Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
14
15Vendor:         Project Vine
16Distribution:   Vine Linux
17Packager:       yasumichi, inagaki
18
19%description
20This is the Class::Singleton module. A Singleton describes an object class
21that can have only one instance in any system. An example of a Singleton
22might be a print spooler or system registry. This module implements a
23Singleton class from which other classes can be derived. By itself, the
24Class::Singleton module does very little other than manage the
25instantiation of a single object. In deriving a class from
26Class::Singleton, your module will inherit the Singleton instantiation
27method and can implement whatever specific functionality is required.
28
29%prep
30%setup -q -n Class-Singleton-%{version}
31
32%build
33%{__perl} Makefile.PL INSTALLDIRS=vendor
34make %{?_smp_mflags}
35
36%install
37rm -rf $RPM_BUILD_ROOT
38
39make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
40
41find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} \;
42find $RPM_BUILD_ROOT -depth -type d -exec rmdir {} 2>/dev/null \;
43
44%{_fixperms} $RPM_BUILD_ROOT/*
45
46%check
47make test
48
49%clean
50rm -rf $RPM_BUILD_ROOT
51
52%files
53%defattr(-,root,root,-)
54%doc Changes README
55%{perl_vendorlib}/*
56%{_mandir}/man3/*
57
58%changelog
59* Sat Dec 13 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.5-1
60- new upstream release
61- built with perl 5.16.3
62
63* Wed Jan 25 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4-7
64- rebuild with perl-5.12.3
65
66* Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.4-6
67- initial build for Vine Linux
68
69* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-5
70- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
71
72* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-4
73- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
74
75* Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.4-3
76- Rebuild for perl 5.10 (again)
77
78* Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.4-2
79- rebuild for new perl
80
81* Mon Oct 15 2007 Steven Pritchard <steve@kspei.com> 1.4-1
82- Update to 1.4.
83- Update License tag.
84- Drop our copy of the license text.
85- Improve Summary.
86- Make description match cpanspec output.
87- BR Test::More.
88
89* Tue Apr 17 2007 Steven Pritchard <steve@kspei.com> 1.03-4
90- Use fixperms macro instead of our own chmod incantation.
91- BR ExtUtils::MakeMaker.
92
93* Sat Sep 16 2006 Steven Pritchard <steve@kspei.com> 1.03-3
94- Canonicalize Source0 URL.
95- Fix find option order.
96
97* Thu Sep 08 2005 Steven Pritchard <steve@kspei.com> 1.03-2
98- Fix permissions on Singleton.pm.
99
100* Wed Aug 31 2005 Steven Pritchard <steve@kspei.com> 1.03-1
101- Specfile autogenerated.
Note: See TracBrowser for help on using the repository browser.