source: projects/specs/trunk/p/perl-Class-Load/perl-Class-Load-vl.spec @ 8708

Revision 8708, 6.6 KB checked in by daisuke, 10 years ago (diff)

perl-*: rebuild with perl 5.16

  • update: Data-OptList?, Log-Dispatch,Log-Log4perl,

Package-Stash, Package-Stash-XS, Sub-Install

Line 
1%define perl_bootstrap 1
2
3Name:           perl-Class-Load
4Version:        0.18
5Release:        2%{?_dist_release}
6Summary:        A working (require "Class::Name") and more
7Group:          Development/Libraries
8License:        GPL+ or Artistic
9URL:            http://search.cpan.org/dist/Class-Load/
10Source0:        http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Class-Load-%{version}.tar.gz
11BuildArch:      noarch
12
13# ===================================================================
14# Module build requirements
15# ===================================================================
16BuildRequires:  perl(ExtUtils::MakeMaker)
17
18# ===================================================================
19# Module requirements
20# ===================================================================
21#BuildRequires: perl(base)
22#BuildRequires: perl(Carp)
23#BuildRequires: perl(Data::OptList)
24#BuildRequires: perl(Module::Implementation) >= 0.04
25#BuildRequires: perl(Module::Runtime) >= 0.012
26#BuildRequires: perl(Package::Stash) >= 0.14
27#BuildRequires: perl(strict)
28#BuildRequires: perl(Try::Tiny)
29#BuildRequires: perl(warnings)
30
31# ===================================================================
32# Runtime requirements
33# ===================================================================
34Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
35# Also requires core module perl(Exporter) via a "use base" construct
36
37%description
38require EXPR only accepts Class/Name.pm style module names, not Class::Name.
39How frustrating! For that, we provide load_class 'Class::Name'.
40
41It's often useful to test whether a module can be loaded, instead of throwing
42an error when it's not available. For that, we provide
43try_load_class 'Class::Name'.
44
45Finally, sometimes we need to know whether a particular class has been loaded.
46Asking %%INC is an option, but that will miss inner packages and any class for
47which the filename does not correspond to the package name. For that, we
48provide is_class_loaded 'Class::Name'.
49
50%prep
51%setup -q -n Class-Load-%{version}
52
53%build
54perl Makefile.PL INSTALLDIRS=vendor
55make %{?_smp_mflags}
56
57%install
58make pure_install DESTDIR=%{buildroot}
59find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
60find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
61%{_fixperms} %{buildroot}
62
63%check
64#make test %{!?perl_bootstrap:RELEASE_TESTING=1}
65
66%files
67%doc Changes LICENSE README
68%{perl_vendorlib}/Class/
69%{_mandir}/man3/Class::Load.3pm*
70
71%changelog
72* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.18-2
73- rebuild with perl-5.16
74
75* Sat Feb 18 2012 Paul Howarth <paul@city-fan.org> - 0.18-1
76- Update to 0.18:
77  - Require Package::Stash ≥ 0.14 (CPAN RT#75095)
78
79* Sun Feb 12 2012 Paul Howarth <paul@city-fan.org> - 0.17-1
80- Update to 0.17:
81  - Require Module::Runtime 0.012, which has a number of useful bug fixes
82  - A bug in Class::Load caused test failures when Module::Runtime 0.012 was
83    used with Perl 5.8.x (CPAN RT#74897)
84
85* Thu Feb  9 2012 Paul Howarth <paul@city-fan.org> - 0.15-1
86- Update to 0.15:
87  - Small test changes to accomodate latest version of Module::Implementation
88- BR: at least version 0.04 of perl(Module::Implementation)
89
90* Tue Feb  7 2012 Paul Howarth <paul@city-fan.org> - 0.14-1
91- Update to 0.14:
92  - Use Module::Implementation to handle loading the XS or PP versions of the
93    code; using this module fixes a few bugs
94  - Under taint mode, setting an implementation in the
95    CLASS_LOAD_IMPLEMENTATION env var caused a taint error
96  - An invalid value in the CLASS_LOAD_IMPLEMENTATION env var is now detected
97    and reported immediately; no attempt is made to load an invalid
98    implementation
99- BR: perl(Module::Implementation)
100- BR: perl(base), perl(Carp), perl(strict) and perl(warnings) for completeness
101- Drop version requirement for perl(Package::Stash), no longer present upstream
102- Drop explicit runtime dependencies, no longer needed
103- Don't BR: perl(Class::Load::XS) or perl(Pod::Coverage::Moose) if we're
104  bootstrapping
105- Don't run the release tests when bootstrapping as the Pod coverage test will
106  fail in the absence of Pod::Coverage::Moose
107
108* Tue Jan 10 2012 Paul Howarth <paul@city-fan.org> - 0.13-2
109- Fedora 17 mass rebuild
110
111* Thu Dec 22 2011 Paul Howarth <paul@city-fan.org> - 0.13-1
112- Update to 0.13:
113  - Fix some bugs with our use of Try::Tiny, which could cause warnings on some
114    systems where Class::Load::XS wasn't installed (CPAN RT#72345)
115- BR: perl(Test::Without::Module)
116
117* Tue Oct 25 2011 Paul Howarth <paul@city-fan.org> - 0.12-1
118- Update to 0.12:
119  - Require Module::Runtime ≥ 0.011, which fixes problems with Catalyst under
120    Perl 5.8 and 5.10
121- Add versioned runtime dependencies for Module::Runtime and Package::Stash
122
123* Wed Oct  5 2011 Paul Howarth <paul@city-fan.org> - 0.11-1
124- Update to 0.11:
125  - Don't accept package names that start with a digit
126  - Rewrite some of the guts to use Module::Runtime rather than reimplementing
127    its functionality
128- BR: perl(Module::Runtime) ≥ 0.009
129- Drop all support for older distributions as required module
130  Module::Runtime ≥ 0.009 will not be available prior to F-16
131
132* Tue Sep  6 2011 Paul Howarth <paul@city-fan.org> - 0.10-1
133- Update to 0.10:
134  - Fix is_class_loaded to ignore $ISA (but still look for @ISA) when trying to
135    determine whether a class is loaded
136  - Lots of internals cleanup
137- BR: perl(Package::Stash) ≥ 0.32 and perl(Try::Tiny)
138- Update patches to apply cleanly
139
140* Tue Aug 16 2011 Paul Howarth <paul@city-fan.org> - 0.08-1
141- Update to 0.08:
142  - The previous version was missing a prereq declaration for Data::OptList
143    (CPAN RT#70285)
144- This release by DROLSKY -> update source URL
145- Package new documentation: LICENSE and README
146- Add build requirements for new release tests and run them:
147  - perl(Pod::Coverage::Moose)
148  - perl(Test::CPAN::Changes)
149  - perl(Test::EOL)
150  - perl(Test::NoTabs)
151  - perl(Test::Pod)
152  - perl(Test::Pod::Coverage)
153  - perl(Test::Requires)
154  - perl(Test::Spelling) and aspell-en
155- Add patch for building with ExtUtils::MakeMaker < 6.30
156- Add patch for building with Test::More < 0.88
157- Add patch for building without Test::Requires
158- Add patch for fixing spell checker word list
159- Don't try to run the POD Coverage test if we don't have Pod::Coverage::Moose
160
161* Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-5
162- Perl mass rebuild
163
164* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-4
165- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
166
167* Tue Dec 21 2010 Paul Howarth <paul@city-fan.org> - 0.06-3
168- Drop explicit dependency on core module perl(Exporter) (#656408)
169
170* Tue Nov 23 2010 Paul Howarth <paul@city-fan.org> - 0.06-2
171- Sanitize spec for Fedora submission
172
173* Mon Nov 22 2010 Paul Howarth <paul@city-fan.org> - 0.06-1
174- Initial RPM version
Note: See TracBrowser for help on using the repository browser.