source: projects/specs/trunk/p/perl-Class-Load/perl-Class-Load-vl.spec @ 9176

Revision 9176, 7.0 KB checked in by inagaki, 9 years ago (diff)

2014-12-21 Ryoichi INAGAKI <ryo1@…>

  • perl-Class-{Load, Load-XS}, perl-Try-Tiny: updated
  • perl-Crypt-SSLeay: rebuit


Line 
1%define perl_bootstrap 1
2
3Name:           perl-Class-Load
4Version:        0.20
5Release:        1%{?_dist_release}
6Summary:        A working (require "Class::Name") and more
7Group:          Development/Libraries
8License:        GPL+ or Artistic
9URL:            http://search.cpan.org/dist/Class-Load/
10Source0:        http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/Class-Load-%{version}.tar.gz
11BuildArch:      noarch
12
13# ===================================================================
14# Module build requirements
15# ===================================================================
16BuildRequires:  perl(ExtUtils::MakeMaker)
17
18# ===================================================================
19# Module requirements
20# ===================================================================
21BuildRequires:  perl(base)
22BuildRequires:  perl(Carp)
23BuildRequires:  perl(Data::OptList)
24BuildRequires:  perl(Module::Implementation) >= 0.04
25BuildRequires:  perl(Module::Runtime) >= 0.012
26BuildRequires:  perl(Package::Stash) >= 0.14
27BuildRequires:  perl(strict)
28BuildRequires:  perl(Try::Tiny)
29BuildRequires:  perl(warnings)
30
31# ===================================================================
32# Test requirements
33# ===================================================================
34BuildRequires:  perl(Test::Fatal)
35BuildRequires:  perl(Test::More)
36BuildRequires:  perl(Test::Requires)
37
38# ===================================================================
39# Runtime requirements
40# ===================================================================
41Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
42# Also requires core module perl(Exporter) via a "use base" construct
43
44%description
45require EXPR only accepts Class/Name.pm style module names, not Class::Name.
46How frustrating! For that, we provide load_class 'Class::Name'.
47
48It's often useful to test whether a module can be loaded, instead of throwing
49an error when it's not available. For that, we provide
50try_load_class 'Class::Name'.
51
52Finally, sometimes we need to know whether a particular class has been loaded.
53Asking %%INC is an option, but that will miss inner packages and any class for
54which the filename does not correspond to the package name. For that, we
55provide is_class_loaded 'Class::Name'.
56
57%prep
58%setup -q -n Class-Load-%{version}
59
60%build
61perl Makefile.PL INSTALLDIRS=vendor
62make %{?_smp_mflags}
63
64%install
65rm -rf %{buildroot}
66make pure_install DESTDIR=%{buildroot}
67find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
68find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
69%{_fixperms} %{buildroot}
70
71%check
72make test %{!?perl_bootstrap:RELEASE_TESTING=1}
73
74%clean
75rm -rf %{buildroot}
76
77%files
78%doc Changes LICENSE README
79%{perl_vendorlib}/Class/
80%{_mandir}/man3/Class::Load.3pm*
81
82%changelog
83* Sun Dec 21 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.20-1
84- new upstream release
85
86* Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.18-2
87- rebuild with perl-5.16
88
89* Sat Feb 18 2012 Paul Howarth <paul@city-fan.org> - 0.18-1
90- Update to 0.18:
91  - Require Package::Stash ≥ 0.14 (CPAN RT#75095)
92
93* Sun Feb 12 2012 Paul Howarth <paul@city-fan.org> - 0.17-1
94- Update to 0.17:
95  - Require Module::Runtime 0.012, which has a number of useful bug fixes
96  - A bug in Class::Load caused test failures when Module::Runtime 0.012 was
97    used with Perl 5.8.x (CPAN RT#74897)
98
99* Thu Feb  9 2012 Paul Howarth <paul@city-fan.org> - 0.15-1
100- Update to 0.15:
101  - Small test changes to accomodate latest version of Module::Implementation
102- BR: at least version 0.04 of perl(Module::Implementation)
103
104* Tue Feb  7 2012 Paul Howarth <paul@city-fan.org> - 0.14-1
105- Update to 0.14:
106  - Use Module::Implementation to handle loading the XS or PP versions of the
107    code; using this module fixes a few bugs
108  - Under taint mode, setting an implementation in the
109    CLASS_LOAD_IMPLEMENTATION env var caused a taint error
110  - An invalid value in the CLASS_LOAD_IMPLEMENTATION env var is now detected
111    and reported immediately; no attempt is made to load an invalid
112    implementation
113- BR: perl(Module::Implementation)
114- BR: perl(base), perl(Carp), perl(strict) and perl(warnings) for completeness
115- Drop version requirement for perl(Package::Stash), no longer present upstream
116- Drop explicit runtime dependencies, no longer needed
117- Don't BR: perl(Class::Load::XS) or perl(Pod::Coverage::Moose) if we're
118  bootstrapping
119- Don't run the release tests when bootstrapping as the Pod coverage test will
120  fail in the absence of Pod::Coverage::Moose
121
122* Tue Jan 10 2012 Paul Howarth <paul@city-fan.org> - 0.13-2
123- Fedora 17 mass rebuild
124
125* Thu Dec 22 2011 Paul Howarth <paul@city-fan.org> - 0.13-1
126- Update to 0.13:
127  - Fix some bugs with our use of Try::Tiny, which could cause warnings on some
128    systems where Class::Load::XS wasn't installed (CPAN RT#72345)
129- BR: perl(Test::Without::Module)
130
131* Tue Oct 25 2011 Paul Howarth <paul@city-fan.org> - 0.12-1
132- Update to 0.12:
133  - Require Module::Runtime ≥ 0.011, which fixes problems with Catalyst under
134    Perl 5.8 and 5.10
135- Add versioned runtime dependencies for Module::Runtime and Package::Stash
136
137* Wed Oct  5 2011 Paul Howarth <paul@city-fan.org> - 0.11-1
138- Update to 0.11:
139  - Don't accept package names that start with a digit
140  - Rewrite some of the guts to use Module::Runtime rather than reimplementing
141    its functionality
142- BR: perl(Module::Runtime) ≥ 0.009
143- Drop all support for older distributions as required module
144  Module::Runtime ≥ 0.009 will not be available prior to F-16
145
146* Tue Sep  6 2011 Paul Howarth <paul@city-fan.org> - 0.10-1
147- Update to 0.10:
148  - Fix is_class_loaded to ignore $ISA (but still look for @ISA) when trying to
149    determine whether a class is loaded
150  - Lots of internals cleanup
151- BR: perl(Package::Stash) ≥ 0.32 and perl(Try::Tiny)
152- Update patches to apply cleanly
153
154* Tue Aug 16 2011 Paul Howarth <paul@city-fan.org> - 0.08-1
155- Update to 0.08:
156  - The previous version was missing a prereq declaration for Data::OptList
157    (CPAN RT#70285)
158- This release by DROLSKY -> update source URL
159- Package new documentation: LICENSE and README
160- Add build requirements for new release tests and run them:
161  - perl(Pod::Coverage::Moose)
162  - perl(Test::CPAN::Changes)
163  - perl(Test::EOL)
164  - perl(Test::NoTabs)
165  - perl(Test::Pod)
166  - perl(Test::Pod::Coverage)
167  - perl(Test::Requires)
168  - perl(Test::Spelling) and aspell-en
169- Add patch for building with ExtUtils::MakeMaker < 6.30
170- Add patch for building with Test::More < 0.88
171- Add patch for building without Test::Requires
172- Add patch for fixing spell checker word list
173- Don't try to run the POD Coverage test if we don't have Pod::Coverage::Moose
174
175* Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-5
176- Perl mass rebuild
177
178* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-4
179- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
180
181* Tue Dec 21 2010 Paul Howarth <paul@city-fan.org> - 0.06-3
182- Drop explicit dependency on core module perl(Exporter) (#656408)
183
184* Tue Nov 23 2010 Paul Howarth <paul@city-fan.org> - 0.06-2
185- Sanitize spec for Fedora submission
186
187* Mon Nov 22 2010 Paul Howarth <paul@city-fan.org> - 0.06-1
188- Initial RPM version
Note: See TracBrowser for help on using the repository browser.