source: projects/specs/trunk/p/perl-Class-Inspector/perl-Class-Inspector-vl.spec @ 4915

Revision 4915, 2.0 KB checked in by yasumichi, 13 years ago (diff)

Import spec file.

Line 
1%define pkgname Class-Inspector
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        1.25
6Release:        1%{?_dist_release}
7# License は、COPYING などのファイルを参考に適切なものに変更してください。
8License:        Artistic or GPL
9Group:          Development/Libraries
10Source0:        http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/%{pkgname}-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        Get information about a class and its structure
18Summary(ja):    クラスおよびその構造について情報を得る
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25
26%description
27Class::Inspector allows you to get information about a loaded class. Most or
28all of this information can be found in other ways, but they aren't always
29very friendly, and usually involve a relatively high level of Perl wizardry,
30or strange and unusual looking code. Class::Inspector attempts to provide an
31easier, more friendly interface to this information.
32
33#%%description -l ja
34#ここに日本語で詳細を記述してください。
35
36%prep
37%setup -q -n Class-Inspector-1.25
38
39%build
40perl Makefile.PL
41%{__make}
42
43%install
44%{__rm} -rf ${RPM_BUILD_ROOT}
45%{__make} install DESTDIR=${RPM_BUILD_ROOT}
46
47find $RPM_BUILD_ROOT%{_prefix} -type f -print |
48        sed "s@^$RPM_BUILD_ROOT@@g" |
49        grep -v ^%{_mandir} |
50        grep -v perllocal.pod |
51        grep -v "\.packlist" > %{name}.files
52if [ "$(cat %{name}.files)X" = "X" ] ; then
53        echo "ERROR: EMPTY FILE LIST"
54        exit -1
55fi
56
57# remove unnecessary files.
58%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
59%{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Class/Inspector/.packlist
60
61
62%clean
63%{__rm} -rf ${RPM_BUILD_ROOT}
64
65
66%files -f %{name}.files
67%defattr(-,root,root)
68%doc Changes LICENSE README
69%dir %{perl_sitelib}/Class/Inspector
70%{_mandir}/*/*
71
72
73%changelog
74* Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.25-1
75- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.