source: projects/specs/trunk/p/perl-Class-Data-Inheritable/perl-Class-Data-Inheritable-vl.spec @ 4914

Revision 4914, 1.8 KB checked in by yasumichi, 13 years ago (diff)

Import spec file.

Line 
1%define pkgname Class-Data-Inheritable
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        0.08
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/T/TM/TMTM/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11
12Vendor:         Project Vine
13Distribution:   Vine Linux
14Packager:       yasumichi
15
16Summary:        Inheritable, overridable class data
17Summary(ja):    クラスデータを継承可能、オーバーライド可能にする
18
19# Dependency
20Requires:       perl
21Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22
23BuildRequires:  perl
24
25%description
26Class::Data::Inheritable is for creating accessor/mutators to class data.
27That is, if you want to store something about your class as a whole (instead
28of about a single object). This data is then inherited by your subclasses
29and can be overriden.
30
31#%%description -l ja
32#ここに日本語で詳細を記述してください。
33
34%prep
35%setup -q -n Class-Data-Inheritable-0.08
36
37%build
38perl Makefile.PL
39%{__make}
40
41%install
42%{__rm} -rf ${RPM_BUILD_ROOT}
43%{__make} install DESTDIR=${RPM_BUILD_ROOT}
44
45find $RPM_BUILD_ROOT%{_prefix} -type f -print |
46        sed "s@^$RPM_BUILD_ROOT@@g" |
47        grep -v ^%{_mandir} |
48        grep -v perllocal.pod |
49        grep -v "\.packlist" > %{name}.files
50if [ "$(cat %{name}.files)X" = "X" ] ; then
51        echo "ERROR: EMPTY FILE LIST"
52        exit -1
53fi
54
55# remove unnecessary files.
56%{__rm} ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
57%{__rm} ${RPM_BUILD_ROOT}%{perl_sitearch}/auto/Class/Data/Inheritable/.packlist
58
59
60%clean
61%{__rm} -rf ${RPM_BUILD_ROOT}
62
63
64%files -f %{name}.files
65%defattr(-,root,root)
66%doc Changes README
67%{_mandir}/*/*
68
69%changelog
70* Mon Oct 10 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.08-1
71- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.