source: projects/specs/trunk/p/perl-Class-Autouse/perl-Class-Autouse-vl.spec @ 5859

Revision 5859, 4.7 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1Name:           perl-Class-Autouse
2Version:        2.01
3Release:        1%{?_dist_release}
4Summary:        Run-time class loading on first method call
5License:        GPL+ or Artistic
6Group:          Development/Libraries
7URL:            http://search.cpan.org/dist/Class-Autouse/
8Source0:        http://search.cpan.org/CPAN/authors/id/A/AD/ADAMK/Class-Autouse-%{version}.tar.gz
9
10# Upstream does its very best to prevent us from running them.
11%bcond_with     xt_tests
12
13Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
14BuildArch:      noarch
15
16BuildRequires:  perl(Carp)
17BuildRequires:  perl(File::Spec) >= 0.80
18BuildRequires:  perl(File::Temp) >= 0.17
19BuildRequires:  perl(prefork)
20BuildRequires:  perl(List::Util) >= 1.18
21BuildRequires:  perl(Test::More) >= 0.47
22
23# for xt tests
24%if %{with xt_tests}
25BuildRequires:  perl(Perl::MinimumVersion) >= 1.27
26BuildRequires:  perl(Pod::Simple) >= 3.14
27BuildRequires:  perl(Test::Pod) >= 1.44
28BuildRequires:  perl(Test::MinimumVersion) >= 0.101080
29BuildRequires:  perl(Test::CPAN::Meta) >= 0.17
30%endif
31
32%description
33Class::Autouse allows you to specify a class the will only load when a
34method of that class is called. For large classes that might not be used
35during the running of a program, such as Date::Manip, this can save you
36large amounts of memory, and decrease the script load time.
37
38%prep
39%setup -q -n Class-Autouse-%{version}
40
41%build
42AUTOMATED_TESTING=1 %{__perl} Makefile.PL INSTALLDIRS=vendor
43make %{?_smp_mflags}
44
45%install
46make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
47find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
48find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
49chmod -R u+w $RPM_BUILD_ROOT/*
50
51%check
52make test
53%if %{with xt_tests}
54# Manually invoke xt-tests
55AUTOMATED_TESTING=1 PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_harness(0, 'inc', 'blib/lib', 'blib/arch')" xt/*.t
56%endif
57
58%files
59%defattr(-,root,root,-)
60%doc Changes LICENSE
61%{perl_vendorlib}/Class
62%{_mandir}/man3/*
63
64%changelog
65* Thu Mar 08 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.01-1
66- initial build for Vine Linux
67
68* Sun Feb 05 2012 Ralf Corsépius <corsepiu@fedoraproject.org> - 2.01-1
69- Upstream update.
70- Adjust BR:'s.
71- Modernize spec.
72
73* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.00-4
74- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
75
76* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 2.00-3
77- Perl mass rebuild
78
79* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.00-2
80- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
81
82* Fri Jan 21 2011 Ralf Corsépius <corsepiu@fedoraproject.org> - 2.00-1
83- Upstream update.
84- Adjust BR:'s.
85- Add %%bcond_with xt_tests.
86
87* Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.29-10
88- 661697 rebuild for fixing problems with vendorach/lib
89
90* Tue Jul 20 2010 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.29-9
91- Reenable pmv test.
92
93* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.29-8
94- Mass rebuild with perl-5.12.0
95
96* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 1.29-7
97- rebuild against perl 5.10.1
98
99* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29-6
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
101
102* Fri Feb 27 2009 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.29-5
103- Adjust minimum perl version in META.yml (Add Class-Autouse-1.29.diff).
104- BR: perl(List::Util) >= 1.19.
105
106* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.29-4
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
108
109* Tue Mar  4 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.29-3
110- rebuild for new perl
111
112* Sun Nov 25 2007 Ralf Corsépius <rc040203@freenet.de> - 1.29-2
113- Add BR: perl(Test-MinimumVersion).
114
115* Tue Nov 20 2007 Ralf Corsépius <rc040203@freenet.de> - 1.29-1
116- Upstream update.
117
118* Wed Sep 05 2007 Ralf Corsépius <rc040203@freenet.de> - 1.28-1
119- Upstream update.
120- Update license.
121
122* Tue Sep 05 2006 Ralf Corsépius <rc040203@freenet.de> - 1.27-1
123- Upstream update.
124
125* Tue Sep 05 2006 Ralf Corsépius <rc040203@freenet.de> - 1.26-2
126- Mass rebuild.
127
128* Thu Apr 20 2006 Ralf Corsépius <rc040203@freenet.de> - 1.26-1
129- Upstream update.
130
131* Wed Mar 01 2006 Ralf Corsépius <rc040203@freenet.de> - 1.21-3
132- Rebuild for perl-5.8.8.
133
134* Wed Feb 01 2006 Ralf Corsepius <rc040203@freenet.de> - 1.21-2
135- Revert to 1.21 (List::Util in Perl is too old).
136
137* Sat Jan 14 2006 Ralf Corsepius <rc040203@freenet.de> - 1.24-1
138- Upstream update.
139
140* Wed Sep 28 2005 Ralf Corsepius <rc040203@freenet.de> - 1.21-1
141- Upstream update.
142- Fix bogus dep on perl(Carp).
143
144* Thu Sep 15 2005 Ralf Corsepius <rc040203@freenet.de> - 1.20-2
145- Spec cleanup.
146
147* Tue Sep 13 2005 Ralf Corsepius <rc040203@freenet.de> - 1.20-1
148- Spec cleanup.
149- FE submission.
Note: See TracBrowser for help on using the repository browser.