source: projects/specs/trunk/p/perl-Carp-Clan/perl-Carp-Clan-vl.spec @ 521

Revision 521, 2.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define perl_sitelib    %(eval "`perl -V:installsitelib`"; echo $installsitelib)
2
3Summary: Report errors from perspective of caller of a "clan" of modules for Perl
4Name: perl-Carp-Clan
5Version: 6.00
6Release: 1%{?_dist_release}
7License: distributable
8Group: Development/Libraries
9Source0: http://search.cpan.org/CPAN/authors/id/S/ST/STBEY/Carp-Clan-%{version}.tar.gz
10URL: http://search.cpan.org/~stbey/Carp-Clan/
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: perl >= 5
15BuildRequires: perl-Test-Exception
16Requires: perl >= 5
17Conflicts: perl-Bit-Vector <= 6.3
18
19%description
20This module reports errors from the perspective of the caller of a
21"clan" of modules, similar to "Carp.pm" itself. But instead of giving
22it a number of levels to skip on the calling stack, you give it a
23pattern to characterize the package names of the "clan" of modules
24which shall never be blamed for any error. :-)
25
26So these modules stick together like a "clan" and any error which
27occurs will be blamed on the "outsider" script or modules not belonging
28to this "clan".
29
30# Provide perl-specific find-{provides,requires}.
31%define __find_provides /usr/lib/rpm/find-provides.perl
32%define __find_requires /usr/lib/rpm/find-requires.perl
33
34%prep
35%setup -q -n Carp-Clan-%{version}
36
37%build
38CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
39make
40
41%install
42rm -rf %{buildroot}
43make DESTDIR=%{buildroot} pure_install
44
45[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
46
47find %{buildroot}%{_prefix} -type f -print |
48        sed "s@^%{buildroot}@@g" |
49        grep -v perllocal.pod |
50        grep -v %{_mandir}    |
51        grep -v "\.packlist" > %{name}-filelist
52if [ "$(cat %{name}-filelist)X" = "X" ] ; then
53    echo "ERROR: EMPTY FILE LIST"
54    exit -1
55fi
56
57%check
58make test
59
60%clean
61rm -rf %{buildroot}
62
63%files -f %{name}-filelist
64%defattr(-,root,root)
65%doc Changes Artistic.txt GNU_GPL.txt README
66%dir %{perl_vendorlib}/Carp
67%{_mandir}/man3/Carp::Clan.3pm*
68
69%changelog
70* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.00-1vl5
71- new upstream release
72- addede BuildRequires: perl-Test-Exception
73
74* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 5.3-1vl5
75- applied new versioning policy
76- built with perl-5.10.0
77
78* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 5.3-0vl1
79- initial release
80
Note: See TracBrowser for help on using the repository browser.