source: projects/specs/trunk/p/perl-Carp-Clan/perl-Carp-Clan-vl.spec @ 8742

Revision 8742, 2.5 KB checked in by iwaim, 10 years ago (diff)

perl-Carp-Clan 6.04-3

Line 
1%define perl_sitelib    %(eval "`perl -V:installsitelib`"; echo $installsitelib)
2
3Summary: Report errors from perspective of caller of a "clan" of modules for Perl
4Name: perl-Carp-Clan
5Version: 6.04
6Release: 3%{?_dist_release}
7License: distributable
8Group: Development/Libraries
9Source0: http://search.cpan.org/CPAN/authors/id/S/ST/STBEY/Carp-Clan-%{version}.tar.gz
10URL: http://search.cpan.org/~stbey/Carp-Clan/
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: perl >= 5
15BuildRequires: perl(Test::Exception)
16Requires: perl >= 5
17Conflicts: perl-Bit-Vector <= 6.3
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23This module reports errors from the perspective of the caller of a
24"clan" of modules, similar to "Carp.pm" itself. But instead of giving
25it a number of levels to skip on the calling stack, you give it a
26pattern to characterize the package names of the "clan" of modules
27which shall never be blamed for any error. :-)
28
29So these modules stick together like a "clan" and any error which
30occurs will be blamed on the "outsider" script or modules not belonging
31to this "clan".
32
33%prep
34%setup -q -n Carp-Clan-%{version}
35
36%build
37CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
38make
39
40%install
41rm -rf %{buildroot}
42make DESTDIR=%{buildroot} pure_install
43
44[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
45
46find %{buildroot}%{_prefix} -type f -print |
47        sed "s@^%{buildroot}@@g" |
48        grep -v perllocal.pod |
49        grep -v %{_mandir}    |
50        grep -v "\.packlist" > %{name}-filelist
51if [ "$(cat %{name}-filelist)X" = "X" ] ; then
52    echo "ERROR: EMPTY FILE LIST"
53    exit -1
54fi
55
56%check
57make test
58
59%clean
60rm -rf %{buildroot}
61
62%files -f %{name}-filelist
63%defattr(-,root,root)
64%doc Changes license/Artistic.txt license/GNU_GPL.txt README
65%dir %{perl_vendorlib}/Carp
66%{_mandir}/man3/Carp::Clan.3pm*
67
68%changelog
69* Sun Jul  6 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 6.04-3
70- fix Conflicts
71
72* Tue Jul  1 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 6.04-2
73- build with Perl 5.16
74- drop defining %%__find_provides and %%__find_requires
75- update BuildRequires and Conflicts
76
77* Mon Mar 28 2011 IWAI, Masaharu <iwai@alib.jp> 6.04-1
78- new upstrem release
79- add Vendor and Distribution tags
80- update files in doc
81
82* Sat Nov  8 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.00-1vl5
83- new upstream release
84- addede BuildRequires: perl-Test-Exception
85
86* Sat Sep 20 2008 Shu KONNO <owa@bg.wakwak.com> 5.3-1vl5
87- applied new versioning policy
88- built with perl-5.10.0
89
90* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 5.3-0vl1
91- initial release
92
Note: See TracBrowser for help on using the repository browser.