source: projects/specs/trunk/p/perl-Capture-Tiny/perl-Capture-Tiny-vl.spec @ 12120

Revision 12120, 6.1 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1%define perl_bootstrap 1
2
3Name:           perl-Capture-Tiny
4Version:        0.48
5Release:        1%{?_dist_release}
6Summary:        Capture STDOUT and STDERR from Perl, XS or external programs
7License:        ASL 2.0
8Group:          Development/Libraries
9URL:            http://search.cpan.org/dist/Capture-Tiny/
10Source0:        http://www.cpan.org/authors/id/D/DA/DAGOLDEN/Capture-Tiny-%{version}.tar.gz
11
12BuildRoot:      %{_tmppath}/%{name}-%{version}-root
13
14Vendor:        Project Vine
15Distribution:  Vine Linux
16
17BuildArch:      noarch
18BuildRequires:  perl >= 2:5.26.2
19BuildRequires:  perl(ExtUtils::MakeMaker)
20BuildRequires:  perl(strict)
21BuildRequires:  perl(warnings)
22# Run-time:
23BuildRequires:  perl(Carp)
24BuildRequires:  perl(Exporter)
25BuildRequires:  perl(Fcntl)
26BuildRequires:  perl(File::Spec)
27BuildRequires:  perl(File::Temp)
28BuildRequires:  perl(IO::Handle)
29# PerlIO is optional
30BuildRequires:  perl(Scalar::Util)
31# Tests only:
32BuildRequires:  perl(Config)
33BuildRequires:  perl(File::Spec::Functions)
34BuildRequires:  perl(lib)
35BuildRequires:  perl(IO::File)
36BuildRequires:  perl(List::Util)
37BuildRequires:  perl(Test::More)
38BuildRequires:  perl(version)
39# Optional tests:
40%if !%{defined perl_bootstrap}
41BuildRequires:  perl(Inline)
42BuildRequires:  perl(Inline::C)
43BuildRequires:  perl(Parse::RecDescent)
44%endif
45Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
46
47%description
48Capture::Tiny provides a simple, portable way to capture anything sent to
49STDOUT or STDERR, regardless of whether it comes from Perl, from XS code or
50from an external program. Optionally, output can be teed so that it is
51captured while being passed through to the original handles. Yes, it even
52works on Windows. Stop guessing which of a dozen capturing modules to use
53in any particular situation and just use this one.
54
55%prep
56%setup -q -n Capture-Tiny-%{version}
57
58%build
59perl Makefile.PL INSTALLDIRS=perl
60make %{?_smp_mflags}
61
62%install
63make pure_install DESTDIR=%{buildroot}
64find %{buildroot} -type f -name .packlist -exec rm -f {} +
65%{_fixperms} %{buildroot}/*
66
67%check
68make test
69
70%files
71%doc Changes examples LICENSE README Todo
72%{perl_privlib}/*
73%{_mandir}/man3/*
74
75%changelog
76* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.48-1
77- new upstream release.
78- rebuilt with perl-5.26.
79
80* Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.27-2
81- Initial package for Vine Linux
82
83* Wed Nov 12 2014 Petr Šabata <contyk@redhat.com> - 0.27-1
84- 0.27 bump
85- META changes only
86
87* Tue Nov 04 2014 Petr Šabata <contyk@redhat.com> - 0.26-1
88- 0.26 bump
89- Test suite enhancements only
90
91* Sun Sep 07 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.25-3
92- Perl 5.20 re-rebuild of bootstrapped packages
93
94* Wed Aug 27 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.25-2
95- Perl 5.20 rebuild
96
97* Mon Aug 18 2014 Petr Šabata <contyk@redhat.com> - 0.25-1
98- 0.25 bump
99
100* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24-2
101- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
102
103* Mon Feb 10 2014 Petr Šabata <contyk@redhat.com> - 0.24-1
104- 0.24 bump, fix CVE-2014-1875
105
106* Thu Oct 24 2013 Petr Šabata <contyk@redhat.com> - 0.23-1
107- 0.23 bump
108
109* Thu Sep 05 2013 Petr Šabata <contyk@redhat.com> - 0.22-4
110- Avoid circular dependencies when bootstrapping (#1004376)
111
112* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.22-3
113- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
114
115* Tue Jul 23 2013 Petr Pisar <ppisar@redhat.com> - 0.22-2
116- Perl 5.18 rebuild
117
118* Thu Mar 28 2013 Petr Pisar <ppisar@redhat.com> - 0.22-1
119- 0.22 bump
120
121* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.21-2
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
123
124* Fri Nov 16 2012 Petr Pisar <ppisar@redhat.com> - 0.21-1
125- 0.21 bump
126
127* Thu Oct 04 2012 Petr Šabata <contyk@redhat.com> - 0.20-1
128- 0.20 bump
129
130* Wed Aug 08 2012 Jitka Plesnikova <jplesnik@redhat.com> - 0.19-1
131- 0.19 bump
132
133* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.18-3
134- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
135
136* Sat Jun 16 2012 Petr Pisar <ppisar@redhat.com> - 0.18-2
137- Perl 5.16 rebuild
138
139* Mon May 07 2012 Petr Šabata <contyk@redhat.com> - 0.18-1
140- 0.18 bump
141
142* Thu Feb 23 2012 Petr Šabata <contyk@redhat.com> - 0.17-1
143- 0.17 bump
144
145* Mon Feb 13 2012 Petr Šabata <contyk@redhat.com> - 0.16-1
146- 0.16 bump
147
148* Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.15-2
149- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
150
151* Mon Jan 02 2012 Petr Šabata <contyk@redhat.com> - 0.15-1
152- 0.15 bump
153
154* Mon Dec 05 2011 Petr Šabata <contyk@redhat.com> - 0.13-1
155- 0.13 bump
156
157* Fri Dec 02 2011 Petr Pisar <ppisar@redhat.com> - 0.12-1
158- 0.12 bump
159
160* Wed Jun 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.11-2
161- Perl mass rebuild
162
163* Fri May 20 2011 Petr Sabata <psabata@redhat.com> - 0.11-1
164- 0.11 bump
165- Removing defattr
166
167* Wed Feb 09 2011 Petr Pisar <ppisar@redhat.com> - 0.10-1
168- 0.10 bump
169
170* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.09-2
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
172
173* Fri Jan 28 2011 Petr Pisar <ppisar@redhat.com> - 0.09-1
174- 0.09 bump
175- Remove BuildRoot stuff
176- Migrate from Module::Build to ExtUtils::MakeMaker
177- Install into perl core directory
178
179* Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.08-2
180- 661697 rebuild for fixing problems with vendorach/lib
181
182* Mon Jun 21 2010 Petr Pisar <ppisar@redhat.com> - 0.08-1
183- 0.08 bump (bug #606277)
184
185* Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.07-2
186- Mass rebuild with perl-5.12.0
187
188* Wed Jan 27 2010 Marcela Mašláňová <mmaslano@redhat.com> - 0.07-1
189- update
190
191* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.06-2
192- rebuild against perl 5.10.1
193
194* Tue Aug 11 2009 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-1
195- update
196
197* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.05-2
198- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
199
200* Mon Apr 27 2009 Marcela Mašláňová <mmaslano@redhat.com> 0.05-1
201- Specfile autogenerated by cpanspec 1.78.
Note: See TracBrowser for help on using the repository browser.