source: projects/specs/trunk/p/perl-CPAN-Meta-YAML/perl-CPAN-Meta-YAML-vl.spec @ 5740

Revision 5740, 3.8 KB checked in by shaolin, 12 years ago (diff)
  • perl-CPAN-Meta: new package
  • perl-CPAN-Meta-YAML: new package
  • perl-Config-Tiny: new package
  • perl-JSON-PP: new package
  • perl-Parse-CPAN-Meta: new package
  • perl-Test-CPAN-Meta: new package
  • perl-Tie-IxHash?: new package
Line 
1# We don't really need ExtUtils::MakeMaker ≥ 6.30
2%global old_eumm %(perl -MExtUtils::MakeMaker -e 'print (($ExtUtils::MakeMaker::VERSION < 6.30) ? 1 : 0);' 2>/dev/null || echo 0)
3
4# We need to patch the test suite if we have Test::More < 0.88
5%global old_test_more %(perl -MTest::More -e 'print (($Test::More::VERSION < 0.88) ? 1 : 0);' 2>/dev/null || echo 0)
6
7Name:           perl-CPAN-Meta-YAML
8Version:        0.005
9Release:        1%{?_dist_release}
10Summary:        Read and write a subset of YAML for CPAN Meta files
11License:        GPL+ or Artistic
12Group:          Development/Libraries
13URL:            http://search.cpan.org/dist/CPAN-Meta-YAML/
14Source0:        http://search.cpan.org/CPAN/authors/id/D/DA/DAGOLDEN/CPAN-Meta-YAML-%{version}.tar.gz
15Patch0:         CPAN-Meta-YAML-0.004-old-EU::MM.patch
16Patch1:         CPAN-Meta-YAML-0.004-old-Test::More.patch
17Patch2:         CPAN-Meta-YAML-0.004-old-Scalar::Util.patch
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(id -nu)
19BuildArch:      noarch
20BuildRequires:  perl(ExtUtils::MakeMaker)
21BuildRequires:  perl(File::Spec)
22BuildRequires:  perl(Test::CPAN::Meta)
23BuildRequires:  perl(Test::More)
24BuildRequires:  perl(Test::Pod)
25# RHEL <= 6 doesn't have a recent enough perl(version) for perl(Test::Version)
26%if 0%{?fedora} || 0%{?rhel} > 6
27BuildRequires:  perl(Test::Version)
28%endif
29BuildRequires:  perl(YAML)
30Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
31
32Vendor:         Project Vine
33Distribution:   Vine Linux
34Packager:       shaolin
35
36%description
37This module implements a subset of the YAML specification for use in reading
38and writing CPAN metadata files like META.yml and MYMETA.yml. It should not be
39used for any other general YAML parsing or generation task.
40
41%prep
42%setup -q -n CPAN-Meta-YAML-%{version}
43
44# We don't really need ExtUtils::MakeMaker ≥ 6.30
45%if %{old_eumm}
46%patch0 -p1
47%endif
48
49# We need to patch the test suite if we have Test::More < 0.88
50%if %{old_test_more}
51%patch1 -p1
52%endif
53
54# Fix operation with Scalar::Util < 1.18 properly (CPAN RT#53490)
55%patch2 -p1
56
57%build
58perl Makefile.PL
59make %{?_smp_mflags}
60
61%install
62rm -rf %{buildroot}
63make pure_install DESTDIR=%{buildroot}
64find %{buildroot} -type f -name .packlist -exec rm -f {} \;
65find %{buildroot} -depth -type d -exec rmdir {} \; 2>/dev/null
66%{_fixperms} %{buildroot}
67
68%check
69make test TEST_FILES="t/*.t xt/*/*.t"
70
71%clean
72rm -rf %{buildroot}
73
74%files
75%defattr(-,root,root,-)
76%doc Changes LICENSE README
77%{perl_sitelib}/CPAN/
78%{_mandir}/man3/CPAN::Meta::YAML.3pm*
79
80%changelog
81* Tue Feb 21 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.005-1
82- initial package for Vine Linux
83
84* Tue Jan 10 2012 Paul Howarth <paul@city-fan.org> - 0.005-2
85- Fedora 17 mass rebuild
86
87* Tue Dec 13 2011 Paul Howarth <paul@city-fan.org> - 0.005-1
88- Update to 0.005:
89  - Fix documentation to clarify that users are responsible for UTF-8
90    encoding/decoding
91
92* Wed Sep  7 2011 Paul Howarth <paul@city-fan.org> - 0.004-1
93- Update to 0.004:
94  - Generated from ADAMK/YAML-Tiny-1.50.tar.gz
95- BR: perl(Test::Version) for additional test coverage
96- Update patch for building with ExtUtils::MakeMaker < 6.30
97- Add patch to support building with Test::More < 0.88
98- Add patch to fix operation with Scalar::Util < 1.18
99
100* Tue Aug 16 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.003-7
101- Install to vendor perl directories to avoid potential debuginfo conflicts
102  with the main perl package if this module ever becomes arch-specific
103
104* Wed Jun 29 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.003-6
105- Perl mass rebuild
106
107* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.003-4
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
109
110* Thu Jan 27 2011 Paul Howarth <paul@city-fan.org> - 0.003-3
111- Trim %%description (#672807)
112
113* Wed Jan 26 2011 Paul Howarth <paul@city-fan.org> - 0.003-2
114- Sanitize for Fedora submission
115
116* Tue Jan 25 2011 Paul Howarth <paul@city-fan.org> - 0.003-1
117- Initial RPM version
Note: See TracBrowser for help on using the repository browser.