source: projects/specs/trunk/p/perl-CGI-Session/perl-CGI-Session-vl.spec @ 9023

Revision 9023, 2.4 KB checked in by inagaki, 10 years ago (diff)

2014-10-25 Ryoichi INAGAKI <ryo1@…>

  • perl-CGI-{Application, Session, Simple}: updated
  • perl-Class-ISA: new
  • perl-HTML-SimpleParse?: rebuilt


Line 
1Summary: persistent session data in CGI applications with Perl
2Name: perl-CGI-Session
3Version: 4.48
4Release: 1%{?_dist_release}
5License: Artistic
6Group: Development/Libraries
7Source0: http://search.cpan.org/CPAN/authors/id/S/SH/SHERZODR/CGI-Session-%{version}.tar.gz
8URL: http://search.cpan.org/~sherzodr/CGI-Session/
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildArch: noarch
12BuildRequires: perl >= 5.8.2
13# for test
14BuildRequires: perl-FreezeThaw
15BuildRequires: perl-CGI-Simple
16
17Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
18
19Vendor: Project Vine
20Distribution: Vine Linux
21
22%description
23CGI-Session is a Perl5 library that provides an easy, reliable and
24modular session management system across HTTP requests. Persistency is a
25key feature for such applications as shopping carts,
26login/authentication routines, and application that need to carry data
27accross HTTP requests. CGI::Session does that and many more
28
29%prep
30%setup -q -n CGI-Session-%{version}
31
32%build
33CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS="vendor"
34make
35
36%install
37rm -rf $RPM_BUILD_ROOT
38mkdir -p $RPM_BUILD_ROOT%{_prefix}
39make DESTDIR=$RPM_BUILD_ROOT install
40
41find $RPM_BUILD_ROOT%{_prefix} -type f -print |
42        sed "s@^$RPM_BUILD_ROOT@@g" |
43        grep -v ^%{_mandir} |
44        grep -v perllocal.pod |
45        grep -v "\.packlist" > %{name}.files
46if [ "$(cat %{name}.files)X" = "X" ] ; then
47    echo "ERROR: EMPTY FILE LIST"
48    exit -1
49fi
50
51%check
52make test
53
54%clean
55rm -rf $RPM_BUILD_ROOT
56
57%files -f %{name}.files
58%defattr(-,root,root)
59%doc README Changes
60%{_mandir}/*/*
61%dir %{perl_vendorlib}/CGI
62%dir %{perl_vendorlib}/CGI/Session
63%dir %{perl_vendorlib}/CGI/Session/ID
64%dir %{perl_vendorlib}/CGI/Session/Driver
65%dir %{perl_vendorlib}/CGI/Session/Serialize
66%dir %{perl_vendorlib}/CGI/Session/Test
67
68%changelog
69* Sat Oct 25 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.48-1
70- new upstream release
71- built with perl 5.16.3
72
73* Sun May 22 2011 IWAI, Masaharu <iwai@alib.jp> 4.43-1
74- new upstream release
75
76* Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.42-1
77- new upstream release
78- applied new versioning policy
79
80* Wed Jan 02 2008 Shu KONNO <owa@bg.wakwak.com> 4.14-0vl3
81- rebuilt
82
83* Thu Nov 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.14-0vl1
84- updated to 4.14
85- changed Group to Development/Libraries
86
87* Fri Sep  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.02-0vl1
88- updated to 4.02
89- use vendor_perl dir
90
91* Mon Apr 28 2003 IWAI Masaharu <iwai@alib.jp> 3.93-0vl1
92- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.