source: projects/specs/trunk/p/perl-CGI-FormBuilder/perl-CGI-FormBuilder-vl.spec @ 6882

Revision 6882, 2.0 KB checked in by yasumichi, 12 years ago (diff)

first import

Line 
1%define pkgname CGI-FormBuilder
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        3.08
6Release:        1%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/N/NW/NWIGER/%{pkgname}-%{version}.tgz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        CGI::FormBuilder - Easily generate and process stateful forms
18Summary(ja):    CGI::FormBuilder - 状態をもつフォームを容易に作成および処理する
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25
26%description
27The goal of CGI::FormBuilder (FormBuilder) is to provide an easy way for you
28to generate and process entire CGI form-based applications.
29
30%description -l ja
31CGI::FormBuilder (FormBuilder) の目標は、完全な CGI フォームベースのアプリケ
32ーションを作成および処理するための簡単な方法を提供することです。
33
34%prep
35%setup -q -n CGI-FormBuilder-3.08
36
37%build
38%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
39%{__make} %{?_smp_mflags}
40
41%install
42%{__rm} -rf ${RPM_BUILD_ROOT}
43%{__make} pure_install DESTDIR=${RPM_BUILD_ROOT}
44
45# remove unnecessary files.
46find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -exec %{__rm} -f {} ';'
47find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
48find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
49find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
50
51# generate file list
52find $RPM_BUILD_ROOT%{_prefix} -type f -print |
53        sed "s@^$RPM_BUILD_ROOT@@g" > %{name}.files
54
55if [ "$(cat %{name}.files)X" = "X" ] ; then
56        echo "ERROR: EMPTY FILE LIST"
57        exit -1
58fi
59
60
61%clean
62%{__rm} -rf ${RPM_BUILD_ROOT}
63
64
65%files -f %{name}.files
66%defattr(-,root,root)
67%doc Changes README
68
69%changelog
70* Thu Oct 04 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.08-1
71- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.