source: projects/specs/trunk/p/perl-CGI-FormBuilder/perl-CGI-FormBuilder-vl.spec @ 9187

Revision 9187, 2.4 KB checked in by inagaki, 9 years ago (diff)

2014-12-23 Ryoichi INAGAKI <ryo1@…>

  • perl-CGI-FormBuilder?, perl-Devel-{EnforceEncapsulation?, GlobalDestruction?}, perl-Moose, perl-Net-{Pcap, Radius, Telnet, Write}, perl-Template-Toolkit, perl-Text-Unidecode, perl-XML-RSS: updated
  • perl-CGI-SSI, perl-Geography-Countries, perl-MIME-Lite-TT, perl-MP3-Info, perl-Text-Glob: rebuilt
  • perl-Sub-Exporter-Progressive: new


Line 
1%define pkgname CGI-FormBuilder
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        3.09
6Release:        1%{?_dist_release}
7Summary:        CGI::FormBuilder - Easily generate and process stateful forms
8Summary(ja):    CGI::FormBuilder - 状態をもつフォームを容易に作成および処理する
9
10License:        Artistic or GPL
11Group:          Development/Libraries
12URL:            http://search.cpan.org/~nwiger/CGI-FormBuilder/
13
14Source0:        http://search.cpan.org/CPAN/authors/id/N/NW/NWIGER/%{pkgname}-%{version}.tgz
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17BuildArch:      noarch
18# Dependency
19BuildRequires:  perl(HTML::Template) >= 2.06
20BuildRequires:  perl(Text::Template) >= 1.43
21BuildRequires:  perl(Template) >= 2.08
22BuildRequires:  perl(CGI::FastTemplate) >= 1.09
23BuildRequires:  perl(CGI::SSI) >= 0.92
24BuildRequires:  perl(CGI::Session) >= 3.95
25Requires:       perl
26Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
27
28Vendor:         Project Vine
29Distribution:   Vine Linux
30Packager:       yasumichi
31
32%description
33The goal of CGI::FormBuilder (FormBuilder) is to provide an easy way for you
34to generate and process entire CGI form-based applications.
35
36%description -l ja
37CGI::FormBuilder (FormBuilder) の目標は、完全な CGI フォームベースのアプリケ
38ーションを作成および処理するための簡単な方法を提供することです。
39
40%prep
41%setup -q -n %{pkgname}-%{version}
42
43%build
44%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
45%{__make} %{?_smp_mflags}
46
47%install
48%{__rm} -rf ${RPM_BUILD_ROOT}
49%{__make} pure_install DESTDIR=${RPM_BUILD_ROOT}
50
51# remove unnecessary files.
52find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -exec %{__rm} -f {} ';'
53find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
54find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
55find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
56
57# generate file list
58find $RPM_BUILD_ROOT%{_prefix} -type f -print |
59        sed "s@^$RPM_BUILD_ROOT@@g" > %{name}.files
60
61if [ "$(cat %{name}.files)X" = "X" ] ; then
62        echo "ERROR: EMPTY FILE LIST"
63        exit -1
64fi
65
66%check
67make test
68
69%clean
70%{__rm} -rf ${RPM_BUILD_ROOT}
71
72
73%files -f %{name}.files
74%defattr(-,root,root)
75%doc Changes README
76
77%changelog
78* Tue Dec 23 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.09-1
79- updated to 3.09
80- built with perl 5.16.3
81
82* Thu Oct 04 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 3.08-1
83- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.