source: projects/specs/trunk/p/perl-CGI-FastTemplate/perl-CGI-FastTemplate-vl.spec @ 8834

Revision 8834, 2.0 KB checked in by yasumichi, 10 years ago (diff)

rebuild with perl-5.16.3

Line 
1%define pkgname CGI-FastTemplate
2
3# Basic Information
4Name:           perl-%{pkgname}
5Version:        1.09
6Release:        2%{?_dist_release}
7License:        Artistic or GPL
8Group:          Development/Libraries
9Source0:        http://search.cpan.org/CPAN/authors/id/J/JM/JMOORE/%{pkgname}-%{version}.tar.gz
10BuildRoot:      %{_tmppath}/%{name}-%{version}-root
11BuildArch:      noarch
12
13Vendor:         Project Vine
14Distribution:   Vine Linux
15Packager:       yasumichi
16
17Summary:        CGI::FastTemplate - Perl extension for managing templates, and performing variable interpolation.
18Summary(ja):    CGI::FastTemplate - テンプレートの管理および可変的な書き込み実行のための Perl 拡張
19
20# Dependency
21Requires:       perl
22Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
23
24BuildRequires:  perl
25
26%description
27CGI::FastTemplate - Perl extension for managing templates, and performing variable interpolation.
28
29%description -l ja
30CGI::FastTemplate - テンプレートの管理および可変的な書き込み実行のための Perl 拡張
31
32%prep
33%setup -q -n CGI-FastTemplate-1.09
34
35%build
36%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
37%{__make} %{?_smp_mflags}
38
39%install
40%{__rm} -rf ${RPM_BUILD_ROOT}
41%{__make} pure_install DESTDIR=${RPM_BUILD_ROOT}
42
43# remove unnecessary files.
44find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -exec %{__rm} -f {} ';'
45find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
46find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
47find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
48
49# generate file list
50find $RPM_BUILD_ROOT%{_prefix} -type f -print |
51        sed "s@^$RPM_BUILD_ROOT@@g" > %{name}.files
52
53if [ "$(cat %{name}.files)X" = "X" ] ; then
54        echo "ERROR: EMPTY FILE LIST"
55        exit -1
56fi
57
58
59%clean
60%{__rm} -rf ${RPM_BUILD_ROOT}
61
62
63%files -f %{name}.files
64%defattr(-,root,root)
65%doc README
66
67%changelog
68* Thu Jul 17 2014 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.09-2
69- rebuild with perl-5.16.3
70
71* Thu Oct 04 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.09-1
72- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.