source: projects/specs/trunk/p/perl-CGI-Application/perl-CGI-Application-vl.spec @ 9023

Revision 9023, 2.5 KB checked in by inagaki, 10 years ago (diff)

2014-10-25 Ryoichi INAGAKI <ryo1@…>

  • perl-CGI-{Application, Session, Simple}: updated
  • perl-Class-ISA: new
  • perl-HTML-SimpleParse?: rebuilt


Line 
1Summary: Framework for building reusable web-applications
2Name: perl-CGI-Application
3Version: 4.50
4Release: 1%{?_dist_release}
5Group: Development/Libraries
6License: GPL or Artistic
7URL: http://search.cpan.org/~markstos/CGI-Application/
8Source0: http://search.cpan.org/CPAN/authors/id/M/MA/MARKSTOS/CGI-Application-%{version}.tar.gz
9
10BuildRoot: %{_tmppath}/%{name}-%{version}-root
11BuildArch: noarch
12BuildRequires: perl-HTML-Template
13BuildRequires: perl-Class-ISA
14Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
15
16Vendor: Project Vine
17Distribution: Vine Linux
18
19%description
20CGI::Application is intended to make it easier to create sophisticated,
21reusable web-based applications. This module implements a methodology which,
22if followed, will make your web software easier to design, easier to
23document, easier to write, and easier to evolve.
24
25%prep
26%setup -q -n CGI-Application-%{version}
27perldoc -t perlartistic > Artistic
28perldoc -t perlgpl > COPYING
29
30%build
31%{__perl} Makefile.PL INSTALLDIRS=vendor
32make
33
34%install
35rm -rf $RPM_BUILD_ROOT
36mkdir -p $RPM_BUILD_ROOT%{_prefix}
37make DESTDIR=$RPM_BUILD_ROOT install
38
39find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
40find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
41
42find $RPM_BUILD_ROOT%{_prefix} -type f -print |
43        sed "s@^$RPM_BUILD_ROOT@@g" |
44        grep -v ^%{_mandir} |
45        grep -v perllocal.pod |
46        grep -v "\.packlist" > %{name}.files
47if [ "$(cat %{name}.files)X" = "X" ] ; then
48    echo "ERROR: EMPTY FILE LIST"
49    exit -1
50fi
51
52perllocalfile=`find %{buildroot} -name perllocal.pod`
53echo "mv $perllocalfile ."
54mv $perllocalfile .
55
56%check
57make test
58
59%clean
60rm -rf $RPM_BUILD_ROOT
61
62%files -f %{name}.files
63%defattr(-,root,root,-)
64%doc Artistic COPYING Changes README perllocal.pod
65%dir %{perl_vendorlib}/CGI
66%dir %{perl_vendorlib}/CGI/Application
67%{_mandir}/man3/*.3*
68
69%changelog
70* Sat Oct 25 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.50-1
71- updated to 4.50
72- built with perl-5.16.3
73- added BR: perl-Class-ISA
74
75* Sun May 22 2011 IWAI, Masaharu <iwai@alib.jp> 4.31-2
76- build with perl 5.12.3
77- add Vendor and Distribution tags
78
79* Thu Nov 12 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.31-1
80- new upstream release
81
82* Mon Apr 28 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 4.06-1
83- rebuild with perl-5.10.0-1
84
85* Fri Feb 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.06-0vl1
86- updated to 4.06
87- changed Group to Development/Libraries
88
89* Fri Sep  9 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.03-0vl1
90- Initial package for Vine Linux (VineSeed Plus)
Note: See TracBrowser for help on using the repository browser.