source: projects/specs/trunk/p/perl-Authen-Krb5-Simple/perl-Authen-Krb5-Simple-vl.spec @ 5878

Revision 5878, 2.0 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1%define real_name Authen-Krb5-Simple
2
3Summary:        Basic user authentication using Kerberos 5
4Name:           perl-%{real_name}
5Version:        0.43
6Release:        1%{?_dist_release}
7License:        Artistic or GPL+
8Group:          Development/Libraries
9URL:            http://search.cpan.org/dist/Authen-Krb5-Simple/
10
11Source:         http://search.cpan.org/CPAN/authors/id/D/DS/DSTUART/Authen-Krb5-Simple-%{version}.tar.gz
12BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
13
14BuildRequires:  perl
15BuildRequires:  perl(ExtUtils::MakeMaker)
16BuildRequires:  perl(Test::More)
17Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
18
19
20%description
21The Authen::Krb5::Simple module provides a means to authenticate a
22user/password using Kerberos 5 protocol. The module's authenticate function
23takes a username (or user@kerberos_realm) and a password, and authenticates
24that user using the local Kerberos 5 installation. It was initially created to
25allow perl scripts to perform authentication against a Microsoft Active
26Directory (AD) server configured to accept Kerberos client requests.
27
28It is important to note: This module only performs simple authentication. It
29does not get, grant, use, or retain any kerberos tickets. It will check user
30credentials against the Kerberos server (as configured on the local system)
31each time the authenticate method is called.
32
33%prep
34%setup -q -n %{real_name}-%{version}
35
36%build
37perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
38make %{?_smp_mflags}
39
40%install
41rm -rf %{buildroot}
42make pure_install DESTDIR=%{buildroot}
43find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
44find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
45%{_fixperms} %{buildroot}
46
47%check
48make test
49
50%clean
51rm -rf %{buildroot}
52
53%files
54%defattr(-, root, root, -)
55%doc Changes MANIFEST README
56%{perl_vendorarch}/*
57%{_mandir}/man3/*
58
59%changelog
60* Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.43-1
61- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.