source: projects/specs/trunk/p/perl-Apache-ParseLog/perl-Apache-ParseLog-vl.spec @ 521

Revision 521, 1.8 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

RevLine 
[521]1Summary: Object-oriented Perl extension for parsing Apache log files
2Name: perl-Apache-ParseLog
3Version: 1.02
4Release: 1%{?_dist_release}
5License: distributable
6Group: Development/Libraries
7Source0: http://www.cpan.org/authors/id/A/AK/AKIRA/Apache-ParseLog-%{version}.tar.gz
8URL: http://search.cpan.org/search?dist=Apache-ParseLog
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10BuildRequires: perl >= 5.004
11Requires: perl >= 5.004
12BuildArch: noarch
13
14%description
15Apache::ParseLog provides an easy way to parse the Apache log files,
16using an object-oriented constructs. The data obtained using this
17module are generic enough that it is flexible to use the data for
18your own applications, such as CGI, simple text-only report generater,
19feeding RDBMS, data for Perl/Tk-based GUI application, etc.
20
21%prep
22%setup -q -n Apache-ParseLog-%{version}
23
24%build
25CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
26make
27
28%clean
29rm -rf $RPM_BUILD_ROOT
30
31%install
32rm -rf $RPM_BUILD_ROOT
33make DESTDIR=$RPM_BUILD_ROOT pure_install
34
35find $RPM_BUILD_ROOT%{_prefix} -type f -print |
36        sed "s@^$RPM_BUILD_ROOT@@g" |
37        grep -v ^%{_mandir} |
38        grep -v perllocal.pod |
39        grep -v "\.packlist" > %{name}.files
40if [ "$(cat %{name}.files)X" = "X" ] ; then
41    echo "ERROR: EMPTY FILE LIST"
42    exit -1
43fi
44
45#%check
46#make test
47
48%files -f %{name}.files
49%defattr(-,root,root)
50%doc README Changes HTTPStatusCodes.txt ISO3166CountryCodes.txt t
51%{_mandir}/*/*
52
53%changelog
54* Sun Nov 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.02-1
55- applied new versioning policy
56- rebuilt with perl-5.10.0
57
58* Thu Feb 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.02-0vl2
59- s/Copyright/License/
60- changed Group to Development/Libraries
61
62* Tue Apr 30 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.02-0vl1
63- first build for Vine Linux
Note: See TracBrowser for help on using the repository browser.