source: projects/specs/trunk/p/pdns-recursor/pdns-recursor-vl.spec @ 10918

Revision 10918, 5.2 KB checked in by ara_t, 7 years ago (diff)

pdns-recursor: rebuild with gcc-5.4.0

Line 
1Summary:                Modern, advanced and high performance recursing/non authoritative nameserver
2Summary(ja):            Modern, advanced and high performance recursing/non authoritative nameserver
3Name:                   pdns-recursor
4Version:                3.3
5Release:                2%{?_dist_release}
6Group:                  System Environment/Daemons
7License:                GPLv2
8URL:                    http://powerdns.com
9Source0:                http://downloads.powerdns.com/releases/%{name}-%{version}.tar.bz2
10Source1:                pdns-recursor.init     
11
12Patch0:                 pdns-recursor-fixmakefile.patch
13Patch1:                 pdns-recursor-fixsysconfdir.patch
14
15Provides:               powerdns-recursor = %{version}-%{release}
16BuildRequires:          libboost-devel, lua-devel
17Requires(pre):          shadow-utils
18Requires(post):         chkconfig
19Requires(preun):        chkconfig, initscripts
20
21%description
22PowerDNS Recursor is a non authoritative/recursing DNS server. Use this
23package if you need a dns cache for your network.
24
25%prep
26%setup -q
27%patch0 -p1 -b .fixmakefile
28%patch1 -p1 -b .fixsysconfdir
29
30%build
31LUA=1 LUA_CPPFLAGS_CONFIG= LUA_LIBS_CONFIG=-llua OPTFLAGS="%{optflags}" make %{?_smp_mflags}
32
33
34%install
35%{__rm} -rf %{buildroot}
36make install DESTDIR=%{buildroot} CONFIGDIR="%{_sysconfdir}/%{name}"
37%{__install} -D -p %{SOURCE1} %{buildroot}%{_initrddir}/pdns-recursor
38
39%{__mv} %{buildroot}%{_sysconfdir}/%{name}/recursor.conf{-dist,}
40
41# add pdns user and group to top of configfile
42sed -i '1i\setuid=pdns-recursor' %{buildroot}%{_sysconfdir}/%{name}/recursor.conf
43sed -i '2i\setgid=pdns-recursor' %{buildroot}%{_sysconfdir}/%{name}/recursor.conf
44
45%pre
46getent group pdns-recursor > /dev/null || groupadd -r pdns-recursor
47getent passwd pdns-recursor > /dev/null || \
48    useradd -r -g pdns-recursor -d / -s /sbin/nologin \
49    -c "PwerDNS Recursor user" pdns-recursor
50exit 0
51
52%post
53chkconfig --add %{name}
54
55%preun
56if [ $1 -eq 0 ]; then
57    service %{name} stop >/dev/null 2>&1 || :
58    chkconfig --del %{name}
59fi
60
61%postun
62if [ $1 -ge 1 ]; then
63    service %{name} condrestart >/dev/null 2>&1 || :
64fi
65
66%clean
67%{__rm} -rf %{buildroot}
68
69%files
70%defattr(-,root,root,-)
71%{_bindir}/rec_control
72%{_sbindir}/pdns_recursor
73%{_mandir}/man1/pdns_recursor.1.gz
74%{_mandir}/man1/rec_control.1.gz
75%{_initrddir}/pdns-recursor
76%dir %{_sysconfdir}/%{name}
77%config(noreplace) %{_sysconfdir}/%{name}/recursor.conf
78%doc COPYING README
79
80
81%changelog
82* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 3.3-2
83- rebuild with gcc-5.4.0
84
85* Wed Apr 11 2012 Daisuke SUZUKI <daisuke@linux.or.jp>          3.3-1
86- initial build for Vine Linux
87
88* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3-3
89- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
90
91* Wed Sep 29 2010 jkeating - 3.3-2
92- Rebuilt for gcc bug 634757
93
94* Sat Sep 25 2010 Ruben Kerkhof <ruben@rubenkerkhof.com> 3.3-1
95- Upstream released new version: http://doc.powerdns.com/changelog.html
96
97* Thu May 13 2010 Ruben Kerkhof <ruben@rubenkerkhof.com> 3.2-2
98- Correct group name (bz #591214)
99
100* Sun Mar 14 2010 Ruben Kerkhof <ruben@rubenkerkhof.com> 3.2-1
101- Upstream released new version
102- Adjust scriptlets to packaging guidelines
103
104* Mon Mar 01 2010 Ruben Kerkhof <ruben@rubenkerkhof.com> 3.2-0.1.rc2
105- Upstream released new version
106
107* Wed Jan 06 2010 Ruben Kerkhof <ruben@rubenkerkhof.com> 3.1.7.2-1
108- Upstream released new version
109- Fixes CVE-2009-4009 and CVE-2009-4010
110
111* Tue Nov 24 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> 3.1.7.1-3
112- Start recursor earlier in the boot process (#540428)
113
114* Mon Aug 10 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> - 3.1.7.1-2
115- Re-add accidently dropped patch (#516562)
116
117* Mon Aug 03 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> - 3.1.7.1-1
118- Upstream released new version
119- Drop patches included upstream
120
121* Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.7-5
122- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
123
124* Fri Feb 27 2009 Ruben Kerkhof <ruben@rubenkerkhof.com> - 3.1.7-4
125- Fix errors with newer Boost
126- Fix build with gcc4.4
127
128* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.7-3
129- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
130
131* Thu Jul 24 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 3.1.7-2
132- Use OPTFLAGS because CXXFLAGS overrides the defaults
133
134* Thu Jul 24 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 3.1.7-1
135- Upstream released new version, now with Lua support
136
137* Sun May 11 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 3.1.6
138- Upstream released new version
139
140* Wed Apr 02 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 3.1.5
141- Upstream released new version
142
143* Sat Feb 16 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 3.1.5-0.1.snapshot4
144- Snapshot 4
145- Drop gcc 4.3 patch, fixed upstream
146
147* Sat Feb 09 2008 Ruben Kerkhof <ruben@rubenkerkhof.com> - 3.1.5-0.1.snapshot3
148- Sync with upstream
149- Compile fixes for gcc43
150
151* Sun Jan 27 2007 <ruben@rubenkerkhof.com> 3.1.4-4
152- Now really fix the description in init script
153* Sat Jan 27 2007 <ruben@rubenkerkhof.com> 3.1.4-3
154- Fixed Description in init script
155* Wed Jan 24 2007 <ruben@rubenkerkhof.com> 3.1.4-2
156- Fixes per bz review 221188:
157- Changed user to pdns-recursor
158- Patched the Makefile to not strip debugsymbols
159- Skipped the configure step, it didn't do much
160- Added a more Fedora-centric initscript
161- Use condrestart instead of restart in %%postun
162* Sun Dec 31 2006 <ruben@rubenkerkhof.com> 3.1.4-1
163- Initial import
164
Note: See TracBrowser for help on using the repository browser.