source: projects/specs/trunk/p/pdksh/pdksh-vl.spec @ 521

Revision 521, 4.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:     A public domain clone of the Korn shell (ksh).
2Summary(ja): Korn shell (ksh) のパブリックドメイン版クローン
3Name: pdksh
4Version: 5.2.14
5Release: 24%{?_dist_release}
6License: Public Domain
7Group: System Environment/Shells
8Patch0: pdksh-5.2.14-manloc.patch
9Patch1: pdksh-5.2.14-patches1.patch
10Patch2: pdksh-5.2.14-alignia64.patch
11Patch3: pdksh-5.2.14-patches2.patch
12Patch4: pdksh-5.2.14-coreutils-posix-fix.patch
13Source: ftp://ftp.cs.mun.ca/pub/pdksh/pdksh-%{version}.tar.gz
14URL: http://www.cs.mun.ca/~michael/pdksh/
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16PreReq: grep, fileutils
17
18%description
19The pdksh package contains PD-ksh, a clone of the Korn shell (ksh).
20The ksh shell is a command interpreter intended for both interactive
21and shell script use.  Ksh's command language is a superset of the sh
22shell language.
23
24Install the pdksh package if you want to use a version of the ksh
25shell.
26
27%description -l ja
28pdksh パッケージには Korn シェル (ksh) のクローンである PD-ksh が
29収められています.ksh のシェルは対話的な使用とシェルスクリプトの使用の
30両方を念頭に置いて作成されたコマンドインタプリタです.ksh のコマンド文法は
31sh シェル言語の上位互換となっています.
32
33ksh シェルを使いたい場合は pdksh パッケージをインストールして下さい.
34
35
36%prep
37%setup -q
38%patch0 -p1
39%patch1 -p1
40%patch2 -p1
41%patch3 -p1
42%patch4 -p1 -b .coreutils-posix-fix
43
44%build
45
46export CFLAGS="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
47%configure --bindir=/bin
48make
49
50
51%install
52rm -rf $RPM_BUILD_ROOT
53
54%makeinstall bindir=$RPM_BUILD_ROOT/bin
55
56mkdir -p $RPM_BUILD_ROOT%{_bindir}
57ln -sf ../../bin/ksh $RPM_BUILD_ROOT%{_bindir}/ksh
58ln -sf ../../bin/ksh $RPM_BUILD_ROOT%{_bindir}/pdksh
59ln -sf ksh.1 $RPM_BUILD_ROOT/%{_mandir}/man1/pdksh.1
60
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65%post
66if [ ! -f /etc/shells ]; then
67        echo "/bin/ksh" > /etc/shells
68else
69        if ! grep -q '^/bin/ksh$' /etc/shells ; then
70                echo "/bin/ksh" >> /etc/shells
71        fi
72fi
73
74%postun
75if [ ! -f /bin/ksh ]; then
76        grep -v /bin/ksh /etc/shells > /etc/shells.new
77        mv /etc/shells.new /etc/shells
78fi
79
80%verifyscript
81
82echo -n "Looking for ksh in /etc/shells... "
83if ! grep '^/bin/ksh$' /etc/shells > /dev/null; then
84    echo "missing"
85    echo "ksh missing from /etc/shells" >&2
86else
87    echo "found"
88fi
89
90
91%files
92%defattr(-,root,root)
93%doc README NOTES PROJECTS NEWS BUG-REPORTS
94/bin/ksh
95%{_bindir}/ksh
96%{_bindir}/pdksh
97%{_mandir}/*/*
98
99
100%changelog
101* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 5.2.14-24vl5
102- added pdksh-5.2.14-coreutils-posix-fix.patch from gentoo
103- applied new versioning policy, spec in utf-8
104
105* Sun Jul 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2.14-23vl1
106- based on 5.2.14-23 from Rawhide
107  - Tue Jun 03 2003 Karsten Hopp <karsten@redhat.de> 5.2.14-22
108  - rebuild for AS to support large files (#76307, #87937)
109
110  - Fri Jun 28 2002 Trond Eivind Glomsrφd <teg@redhat.com> 5.2.14-19
111  - Make it handle large files by adding compiler flags (#67662)
112
113  - Tue Jan 23 2001 Trond Eivind Glomsrφd <teg@redhat.com>
114  - add fileutils and grep to PreReq: (#24720)
115
116  - Mon Jan 08 2001 Trond Eivind Glomsrφd <teg@redhat.com>
117  - add patch to fix alignment problems on IA64 (#23351)
118
119- rebuild with new toolchains
120
121* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
122- 5.2.14-9vl1
123- based on 5.2.14-9 from Rawhide
124- use better macros (%%{_bindir})
125- added Japanese summary and description
126
127* Tue Nov 28 2000 Trond Eivind Glomsr <teg@redhat.com>
128- redid some patches, which should fix #19517
129
130* Mon Aug 14 2000 Trond Eivind Glomsr <teg@redhat.com>
131- use relative symlinks (#16127)
132
133* Sat Jul 29 2000 Trond Eivind Glomsr <teg@redhat.com>
134- added patch to handle readonly variables correctly
135
136* Mon Jul 24 2000 Trond Eivind Glomsr <teg@redhat.com>
137- add patch from author to fix "-x" problem (#10758)
138- add another author patch (some fixes wrt. job handling)
139
140* Fri Jul 21 2000 Trond Eivind Glomsr <teg@redhat.com>
141- add URL
142- use %%makeinstall and add a patch to make it work
143
144* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
145- automatic rebuild
146
147* Tue Jun 13 2000 Trond Eivind Glomsr <teg@redhat.com>
148- use %%{_mandir}, %%configure and %{_tmpdir}
149
150* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
151- compress man pages.
152
153* Tue Jul 20 1999 Jeff Johnson <jbj@redhat.com>
154- update to 5.2.14.
155
156* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
157- auto rebuild in the new build environment (release 3)
158
159* Wed Mar 17 1999 Jeff Johnson <jbj@redhat.com>
160- glibc 2.1 doesn't init sys_siglist for 32 <= i < NSIG (#1473)
161
162* Fri Mar 12 1999 Jeff Johnson <jbj@redhat.com>
163- upgrade to 5.2.13.
164
165* Sun Aug 16 1998 Jeff Johnson <jbj@redhat.com>
166- build root
167
168* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
169- translations modified for de, fr, tr
170
171* Wed Oct 21 1997 Cristian Gafton <gafton@redhat.com>
172- fixed the spec file
173
174* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
175- built against glibc
Note: See TracBrowser for help on using the repository browser.