source: projects/specs/trunk/p/pdftk/pdftk-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:          pdftk - the pdf tool kit
2Summary(ja):      PDF 操作ツールキット
3Name:             pdftk
4Version:          1.41
5Release:          1%{?_dist_release}
6License:          GPL
7URL:              http://www.accesspdf.com/pdftk/
8Source0:          %{name}-%{version}.tar.bz2
9Group:            Applications/Publishing
10Vendor:           Project Vine
11Distribution:     Vine Linux
12Packager:         Susumu Tanimura <stanimura-ngs@umin.ac.jp>
13BuildRoot:        %{_tmppath}/%{name}-%{version}-root
14Requires:         libgcj
15BuildRequires:    gcc-java libgcj-devel
16
17%description
18If PDF is electronic paper, then pdftk is an electronic staple-remover,
19hole-punch, binder, secret-decoder-ring, and X-Ray-glasses. Pdftk is a simple
20tool for doing everyday things with PDF documents. Keep one in the top drawer
21of your desktop and use it to:
22
23    * Merge PDF Documents
24    * Split PDF Pages into a New Document
25    * Decrypt Input as Necessary (Password Required)
26    * Encrypt Output as Desired
27    * Burst a PDF Document into Single Pages
28    * Report on PDF Metrics, including Metadata and Bookmarks
29    * Uncompress and Re-Compress Page Streams
30    * Repair Corrupted PDF (Where Possible)
31
32Pdftk is also an example of how to use a library of Java classes in a
33stand-alone C++ program. Specifically, it demonstrates how GCJ and CNI allow
34C++ code to use iText's (itext-paulo) Java classes.
35
36
37%description -l ja
38pdftk は PDF 文書を扱うツールであり、PDF文書の結合、分割、暗号化、復号
39化、ページ分解、文書情報表示、圧縮展開機能を有し、壊れたPDF文書を可能
40な限り修復する機能もある。
41
42%prep
43%setup -q
44
45%build
46cd pdftk
47## don't use smp_mflags
48%{__make} -f Makefile.RedHat
49cd -
50
51%install
52if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
53%{__install} -d $RPM_BUILD_ROOT/%{_bindir}
54%{__install} -d $RPM_BUILD_ROOT/%{_mandir}/man1
55%{__install} -m 0755 pdftk/pdftk $RPM_BUILD_ROOT/%{_bindir}/
56%{__install} -m 0644 debian/pdftk.1 $RPM_BUILD_ROOT/%{_mandir}/man1/
57
58%clean
59if [ -d $RPM_BUILD_ROOT ]; then rm -rf $RPM_BUILD_ROOT; fi
60
61%files
62%defattr(-,root,root)
63%doc pdftk.1.html  pdftk.1.notes  pdftk.1.txt
64%{_bindir}/*
65%{_mandir}/man1/*
66
67%changelog
68* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.41-1vl5
69- applied new versioning policy, spec in utf-8
70
71* Fri Feb 29 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.41-0vl2
72- updated release number
73
74* Sun Sep  2 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.41-0vl1
75- new upstream release
76- rebuilt with new toolchain and environment
77
78* Thu Aug 17 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com>
79- rebuilt for VineSeed (4.0)
80
81* Mon Jun  6 2005 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
82- Inital package for VineLinux3.1
83
Note: See TracBrowser for help on using the repository browser.