source: projects/specs/trunk/p/pdflib-lite/pdflib-lite-vl.spec @ 9076

Revision 9076, 5.7 KB checked in by inagaki, 9 years ago (diff)

2014-11-10 Ryoichi INAGAKI <ryo1@…>

  • kross-interpreters: NEW
  • mecab-perl, xfconf: rebuilt
  • pdflib-lite: updated


Line 
1%define binding_langs perl python
2
3Summary: Portable C library for dynamically generating PDF files
4Summary(ja): PDF ファイルを動的に生成できる取扱い易い C 言語ライブラリ
5Name: pdflib-lite
6Version: 7.0.5
7Release: 3%{?_dist_release}
8License: Distributable
9Group: System Environment/Libraries
10URL: http://www.pdflib.com/
11
12Source: http://www.pdflib.com/binaries/PDFlib/705/PDFlib-Lite-%{version}p3.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: perl
16BuildRequires: python-devel
17
18Vendor: Project Vine
19Distribution: Vine Linux
20Conflicts: pdflib <= 4
21
22%description
23PDFlib is a development tool for PDF-enabling your software,
24or generating PDF on your server. PDFlib offers a simple-to-use API
25for programmatically creating PDF files from within your own server-
26or client-side software. PDFlib doesn't make use of third-party software
27for generating PDF, nor does it require any other tools.
28
29%package devel
30Summary: Development files for pdflib
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33
34%description devel
35PDFlib is a development tool for PDF-enabling your software,
36or generating PDF on your server. PDFlib offers a simple-to-use API
37for programmatically creating PDF files from within your own server-
38or client-side software. PDFlib doesn't make use of third-party software
39for generating PDF, nor does it require any other tools.
40
41This package contains the files needed for compiling programs that will use
42the PDFlib library.
43
44%package python
45Summary: Python shared library for pdflib
46Group: System Environment/Libraries
47Requires: %{name} = %{version}-%{release}
48Provides: python-pdflib = %{version}-%{release}
49
50%description python
51PDFlib is a development tool for PDF-enabling your software,
52or generating PDF on your server. PDFlib offers a simple-to-use API
53for programmatically creating PDF files from within your own server-
54or client-side software. PDFlib doesn't make use of third-party software
55for generating PDF, nor does it require any other tools.
56
57This package contains the library needed for python programs
58that will use the PDFlib library.
59
60%package perl
61Summary: Perl library for pdflib
62Group: Development/Libraries
63Requires: %{name} = %{version}-%{release}
64Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
65Provides: perl-pdflib = %{version}-%{release}
66
67%description perl
68PDFlib is a development tool for PDF-enabling your software,
69or generating PDF on your server. PDFlib offers a simple-to-use API
70for programmatically creating PDF files from within your own server-
71or client-side software. PDFlib doesn't make use of third-party software
72for generating PDF, nor does it require any other tools.
73
74This package contains the library needed for perl programs
75that will use the PDFlib library.
76
77
78%prep
79%setup -q -n PDFlib-Lite-%{version}p3
80sed -i -e "s|^PYTHONLIBDIR.*|PYTHONLIBDIR = %{python_sitearch}|" config/mkcommon.inc.in
81sed -i -e "s|^PERLLIBDIR.*|PERLLIBDIR = %{perl_vendorarch}|" config/mkcommon.inc.in
82
83
84%build
85# java, ruby and tcl disabled.
86# File a bug with RFE and patch if you need it (by fedora12).
87%configure \
88        --enable-large_files \
89        --enable-tiffwrite \
90        --disable-static \
91        --with-pyincl=%{_includedir}/python%{pyver} \
92        --with-py=yes \
93        --with-java=no \
94        --with-ruby=no \
95        --with-tcl=no \
96        --with-openssl \
97%ifarch x86_64
98        --enable-64bit \
99%endif
100        ;
101
102%{__make} %{?_smp_mflags}
103for lang in %{binding_langs}; do
104        %{__make} -C bind/pdflib/$lang
105done
106
107
108%install
109rm -rf %{buildroot}
110mkdir -p %{buildroot}%{python_sitearch}
111mkdir -p %{buildroot}%{perl_vendorarch}
112make install DESTDIR=%{buildroot}
113for lang in %{binding_langs} ; do
114        make -C bind/pdflib/$lang install DESTDIR=%{buildroot}
115done
116
117install -p -m 0644 bind/pdflib/cpp/pdflib.hpp %{buildroot}%{_includedir}/pdflib.hpp
118chmod +x %{buildroot}%{_libdir}/libpdf*
119chmod +x %{buildroot}%{python_sitearch}/pdflib_py.so*
120chmod +x %{buildroot}%{perl_vendorarch}/pdflib_pl.so*
121
122rm -rf examples
123mkdir -p examples/{c,cpp,perl,php,python}
124cp -r bind/pdflib/data examples/data
125cp bind/pdflib/c/*.c bind/pdflib/c/Makefile bind/pdflib/c/readme.txt \
126        examples/c
127cp bind/pdflib/cpp/*.cpp bind/pdflib/cpp/Makefile bind/pdflib/cpp/readme.txt \
128        examples/cpp
129cp bind/pdflib/perl/*.pl bind/pdflib/perl/Makefile bind/pdflib/perl/readme.txt \
130        examples/perl
131cp bind/pdflib/python/*.py bind/pdflib/python/Makefile bind/pdflib/python/readme.txt \
132        examples/python
133cp bind/pdflib/php/*.php bind/pdflib/php/readme.txt \
134        examples/php
135cp bind/pdflib/php/examples.php5/*.php \
136        examples/php
137
138
139%post -p /sbin/ldconfig
140%postun -p /sbin/ldconfig
141
142%clean
143rm -rf %{buildroot}
144
145
146%files
147%defattr(-, root, root)
148%doc readme.txt
149%doc doc/pdflib/PDFlib-Lite-license.pdf
150%{_bindir}/pdfimage
151%{_bindir}/pdflib-config
152%{_bindir}/text2pdf
153%{_libdir}/libpdf.so.*
154
155%files devel
156%defattr(-, root, root)
157%doc doc/pdflib/PDFlib-Lite-license.pdf
158%doc doc/pdflib/changes.txt doc/pdflib/compatibility.txt
159%doc doc/pdflib/PDFlib-API-reference.pdf
160%doc doc/pdflib/PDFlib-tutorial.pdf
161%doc doc/pdflib/readme-source-unix.txt
162%doc examples
163%{_bindir}/pdflib-config
164%{_includedir}/pdflib.h
165%{_includedir}/pdflib.hpp
166%{_libdir}/libpdf.so
167%exclude %{_libdir}/*.la
168
169%files python
170%defattr(-, root, root)
171%doc doc/pdflib/PDFlib-Lite-license.pdf
172%{python_sitearch}/pdflib_py.so*
173%exclude %{python_sitearch}/*.la
174
175%files perl
176%defattr(-, root, root)
177%doc doc/pdflib/PDFlib-Lite-license.pdf
178%{perl_vendorarch}/pdflib_pl.*
179
180
181%changelog
182* Mon Nov 10 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 7.0.5-3
183- updated to 7.0.5p3
184- built with perl 5.16.3
185- moved pdflib-lite to System Environment/Libraries Group
186
187* Tue Jul 30 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.0.5-2
188- rebuild with current Vine6 environment
189
190* Mon Dec 20 2010 Shu KONNO <owa@bg.wakwak.com> 7.0.5-1
191- initial build for VineSeed
192
Note: See TracBrowser for help on using the repository browser.