source: projects/specs/trunk/p/pcre2/pcre2-vl.spec @ 12503

Revision 12503, 8.8 KB checked in by tomop, 3 years ago (diff)

updated 5 packages

mariadb-10.5.6-1

nsd-4.3.3-1

pcre2-10.35-1

rspamd-2.6-2

unbound-1.12.0-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Summary: Perl-compatible regular expression library
4Summary(ja): Perl 互換の正規表現ライブラリ
5Name: pcre2
6Version: 10.35
7Release: 1%{?_dist_release}
8Group: system
9Vendor: Project Vine
10Distribution: Vine Linux
11Packager: inagaki
12
13License: BSD
14URL: https://www.pcre.org/
15Source0: https://ftp.pcre.org/pub/pcre/%{name}-%{version}.tar.bz2
16# Upstream thinks RPATH is good idea.
17Patch0: pcre2-10.31-multilib.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: zlib-devel
21BuildRequires: bzip2-devel
22BuildRequires: libedit-devel
23# New libtool to get rid of rpath
24BuildRequires: autoconf, automake, libtool
25
26%description
27Perl-compatible regular expression library.
28PCRE has its own native API, but a set of "wrapper" functions that are based on
29the POSIX API are also supplied in the library libpcreposix. Note that this
30just provides a POSIX calling interface to PCRE: the regular expressions
31themselves still follow Perl syntax and semantics. The header file
32for the POSIX-style functions is called pcreposix.h.
33
34
35%package devel
36Summary: Development files for %{name}
37Summary(ja): %{name} の開発用ファイル
38Group: programming
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42Development files (Headers, libraries for static linking, etc) for %{name}.
43
44
45%package -n compat32-%{name}
46Summary: Perl-compatible regular expression library
47Summary(ja): Perl 互換の正規表現ライブラリ
48Group: system
49
50%description -n compat32-%{name}
51Perl-compatible regular expression library.
52PCRE has its own native API, but a set of "wrapper" functions that are based on
53the POSIX API are also supplied in the library libpcreposix. Note that this
54just provides a POSIX calling interface to PCRE: the regular expressions
55themselves still follow Perl syntax and semantics. The header file
56for the POSIX-style functions is called pcreposix.h.
57
58
59%package -n compat32-%{name}-devel
60Summary: Development files for %{name}
61Summary(ja): %{name} の開発用ファイル
62Group: programming
63Requires: compat32-%{name} = %{version}-%{release}
64
65%description -n compat32-%{name}-devel
66Development files (Headers, libraries for static linking, etc) for %{name}.
67
68
69%debug_package
70
71
72%prep
73%setup -q
74# Get rid of rpath
75%patch0 -p1 -b .multilib
76# Because of rpath patch
77libtoolize --copy --force && autoreconf -vif
78# One contributor's name is non-UTF-8
79for F in ChangeLog; do
80    iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
81    touch --reference "$F" "${F}.utf8"
82    mv "${F}.utf8" "$F"
83done
84
85
86%build
87%configure \
88    --enable-jit \
89    --disable-static \
90    --enable-utf8 \
91    --enable-unicode-properties \
92    --enable-pcregrep-libz \
93    --enable-pcregrep-libbz2 \
94    --enable-pcretest-libedit \
95    --enable-pcre2-8 \
96    --enable-pcre2-16 \
97    --enable-pcre2-32
98
99make %{?_smp_mflags}
100
101
102%install
103rm -rf $RPM_BUILD_ROOT
104make install DESTDIR=$RPM_BUILD_ROOT
105
106rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
107rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
108
109
110%check
111%ifarch s390 s390x ppc
112# larger stack is needed on s390, ppc
113ulimit -s 10240
114%endif
115make %{?_smp_mflags} check VERBOSE=yes
116
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121
122%post -p /sbin/ldconfig
123%postun -p /sbin/ldconfig
124
125%post -n compat32-%{name} -p /sbin/ldconfig
126%postun -n compat32-%{name} -p /sbin/ldconfig
127
128
129%files
130%defattr(-,root,root)
131%license COPYING LICENCE
132%doc AUTHORS ChangeLog NEWS README
133%{_bindir}/pcre2grep
134%{_libdir}/*.so.*
135%{_mandir}/man1/pcre2grep.*
136
137%files devel
138%defattr(-,root,root)
139%doc doc/html/*
140%{_bindir}/pcre2-config
141%{_bindir}/pcre2test
142%{_includedir}/*
143%{_libdir}/*.so
144%{_libdir}/pkgconfig/*.pc
145%{_mandir}/man1/pcre2-config.*
146%{_mandir}/man1/pcre2test.*
147%{_mandir}/man3/*
148
149%if %{build_compat32}
150%files -n compat32-%{name}
151%defattr(-, root, root)
152%{_libdir}/*.so.*
153
154%files -n compat32-%{name}-devel
155%defattr(-, root, root)
156%{_libdir}/*.so
157%endif
158
159
160%changelog
161* Thu Oct 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.35-1
162- new upstream release.
163
164* Sun Mar 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.34-1
165- new upstream release.
166
167* Sun May 20 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 10.31-1
168- new: pcre2 package
169- update multilib patch (Patch0)
170- drop unnecessary patch (Patch1)
171
172* Fri Jul 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.39-2
173- create comapt32 packages
174
175* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
176- new upstream release.
177- dropped Patch1000,1001: fixed in upstream.
178
179* Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
180- new upstream release.
181- removed Patch2,Patch3 (no longer needed).
182- added Patch1000 to fix CVE-2016-1283.
183
184* Sun Apr  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
185- new upstream release
186- added patches including security fix from Fedora (CVE-2014-8964)
187* Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
188  - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
189    (bug #1165626)
190  * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
191  - Reset non-matched groups within capturing group up to forced match
192    (bug #1161587)
193  * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
194  - Fix typos in manual pages (bugs #675476, #675477)
195
196* Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
197- new upstream release
198- add --enable-pcre32 and --enable-pcretest-libedit
199
200* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
201- new upstream release
202- add --enable-pcre16 --enable-pcre8 --enable-jit
203- API change
204- change includedir to /usr/include
205
206* Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
207- new upstream release
208
209* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
210- new upstream release
211
212* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
213- rebuilt with rpm-4.8.1 for pkg-config
214
215* Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
216- new upstream release
217
218* Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
219- new upstream release with security fix
220
221* Sat Feb  6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
222- new upstream release
223
224* Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
225- new upstream release
226
227* Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
228- add --enable-unicode-properties to configure option
229
230* Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
231- new upstream release
232- added BR: zlib-devel, bzip2-devel
233- removed static libraries from devel package
234- added Packager tag
235
236* Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
237- new upstream release
238- spec in UTF-8
239
240* Sun Jul  6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
241- new upstream release
242
243* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
244- use macro for Release
245
246* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
247- apply new virsioning policy.
248- remove *.la
249
250* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
251- new upstream release
252
253* Wed Nov  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
254- new upstream release
255
256* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
257- new upstream release
258
259* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
260- rebuild with new environment/toolchain
261
262* Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
263- new upstream release
264
265* Mon Sep  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
266- added --enable-utf8 option
267
268* Sun Sep  4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
269- new upstream release
270
271* Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
272- new upstream release
273- added Japanese summary
274
275* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
276- new upstream release
277
278* Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
279- new upstream release
280
281* Mon May  5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
282- skip 'make check' on alpha
283
284* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
285- change install section
286- change files section
287
288* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
289- update to 4.1
290- add %{_bindir}/pcretest
291- add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
292
293* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
294- rebuild with new toolchains
295
296* Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
297- Update to 3.9
298
299* Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
300- Update to 3.7
301
302* Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
303- Update to 3.5
304
305* Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
306- Build for VineSeed
307
308* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
309- Move libpcre to /lib, grep uses it these days (#41104)
310
311* Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
312- Move this to a separate package, used to be in kdesupport, but it's
313  generally useful...
Note: See TracBrowser for help on using the repository browser.