source: projects/specs/trunk/p/pcre2/pcre2-vl.spec @ 11676

Revision 11676, 8.7 KB checked in by iwaim, 6 years ago (diff)

pcre2 10.31-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: pcre2
4Version: 10.31
5Release: 1%{?_dist_release}
6Summary: Perl-compatible regular expression library
7Summary(ja): Perl 互換の正規表現ライブラリ
8
9Group: System Environment/Libraries
10License: BSD
11URL: http://www.pcre.org/
12
13Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
14# Upstream thinks RPATH is good idea.
15Patch0: pcre2-10.31-multilib.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: zlib-devel
19BuildRequires: bzip2-devel
20BuildRequires: libedit-devel
21# New libtool to get rid of rpath
22BuildRequires: autoconf, automake, libtool
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27Packager: inagaki
28
29%description
30Perl-compatible regular expression library.
31PCRE has its own native API, but a set of "wrapper" functions that are based on
32the POSIX API are also supplied in the library libpcreposix. Note that this
33just provides a POSIX calling interface to PCRE: the regular expressions
34themselves still follow Perl syntax and semantics. The header file
35for the POSIX-style functions is called pcreposix.h.
36
37%package devel
38Summary: Development files for %{name}
39Summary(ja): %{name} の開発用ファイル
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44Development files (Headers, libraries for static linking, etc) for %{name}.
45
46
47%package -n compat32-%{name}
48Summary: Perl-compatible regular expression library
49Summary(ja): Perl 互換の正規表現ライブラリ
50Group: System Environment/Libraries
51
52%description -n compat32-%{name}
53Perl-compatible regular expression library.
54PCRE has its own native API, but a set of "wrapper" functions that are based on
55the POSIX API are also supplied in the library libpcreposix. Note that this
56just provides a POSIX calling interface to PCRE: the regular expressions
57themselves still follow Perl syntax and semantics. The header file
58for the POSIX-style functions is called pcreposix.h.
59
60
61%package -n compat32-%{name}-devel
62Summary: Development files for %{name}
63Summary(ja): %{name} の開発用ファイル
64Group: Development/Libraries
65Requires: compat32-%{name} = %{version}-%{release}
66
67%description -n compat32-%{name}-devel
68Development files (Headers, libraries for static linking, etc) for %{name}.
69
70
71%prep
72%setup -q
73# Get rid of rpath
74%patch0 -p1 -b .multilib
75# Because of rpath patch
76libtoolize --copy --force && autoreconf -vif
77# One contributor's name is non-UTF-8
78for F in ChangeLog; do
79    iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
80    touch --reference "$F" "${F}.utf8"
81    mv "${F}.utf8" "$F"
82done
83
84%build
85%configure \
86    --enable-jit \
87    --disable-static \
88    --enable-utf8 \
89    --enable-unicode-properties \
90    --enable-pcregrep-libz \
91    --enable-pcregrep-libbz2 \
92    --enable-pcretest-libedit \
93    --enable-pcre2-8 \
94    --enable-pcre2-16 \
95    --enable-pcre2-32
96
97make %{?_smp_mflags}
98
99%install
100rm -rf $RPM_BUILD_ROOT
101make install DESTDIR=$RPM_BUILD_ROOT
102
103rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
104rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
105
106%check
107%ifarch s390 s390x ppc
108# larger stack is needed on s390, ppc
109ulimit -s 10240
110%endif
111make %{?_smp_mflags} check VERBOSE=yes
112
113%clean
114rm -rf $RPM_BUILD_ROOT
115
116%post -p /sbin/ldconfig
117
118%postun -p /sbin/ldconfig
119
120%post -n compat32-%{name} -p /sbin/ldconfig
121
122%postun -n compat32-%{name} -p /sbin/ldconfig
123
124
125%files
126%defattr(-,root,root)
127%doc AUTHORS COPYING ChangeLog LICENCE NEWS README
128%{_bindir}/pcre2grep
129%{_libdir}/*.so.*
130%{_mandir}/man1/pcre2grep.*
131
132%files devel
133%defattr(-,root,root)
134%doc doc/html/*
135%{_bindir}/pcre2-config
136%{_bindir}/pcre2test
137%{_includedir}/*
138%{_libdir}/*.so
139%{_libdir}/pkgconfig/*.pc
140%{_mandir}/man1/pcre2-config.*
141%{_mandir}/man1/pcre2test.*
142%{_mandir}/man3/*
143
144%if %{build_compat32}
145%files -n compat32-%{name}
146%defattr(-, root, root)
147%{_libdir}/*.so.*
148
149%files -n compat32-%{name}-devel
150%defattr(-, root, root)
151%{_libdir}/*.so
152%endif
153
154
155%changelog
156* Sun May 20 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 10.31-1
157- new: pcre2 package
158- update multilib patch (Patch0)
159- drop unnecessary patch (Patch1)
160
161* Fri Jul 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.39-2
162- create comapt32 packages
163
164* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
165- new upstream release.
166- dropped Patch1000,1001: fixed in upstream.
167
168* Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
169- new upstream release.
170- removed Patch2,Patch3 (no longer needed).
171- added Patch1000 to fix CVE-2016-1283.
172
173* Sun Apr  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
174- new upstream release
175- added patches including security fix from Fedora (CVE-2014-8964)
176* Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
177  - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
178    (bug #1165626)
179  * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
180  - Reset non-matched groups within capturing group up to forced match
181    (bug #1161587)
182  * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
183  - Fix typos in manual pages (bugs #675476, #675477)
184
185* Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
186- new upstream release
187- add --enable-pcre32 and --enable-pcretest-libedit
188
189* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
190- new upstream release
191- add --enable-pcre16 --enable-pcre8 --enable-jit
192- API change
193- change includedir to /usr/include
194
195* Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
196- new upstream release
197
198* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
199- new upstream release
200
201* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
202- rebuilt with rpm-4.8.1 for pkg-config
203
204* Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
205- new upstream release
206
207* Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
208- new upstream release with security fix
209
210* Sat Feb  6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
211- new upstream release
212
213* Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
214- new upstream release
215
216* Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
217- add --enable-unicode-properties to configure option
218
219* Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
220- new upstream release
221- added BR: zlib-devel, bzip2-devel
222- removed static libraries from devel package
223- added Packager tag
224
225* Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
226- new upstream release
227- spec in UTF-8
228
229* Sun Jul  6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
230- new upstream release
231
232* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
233- use macro for Release
234
235* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
236- apply new virsioning policy.
237- remove *.la
238
239* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
240- new upstream release
241
242* Wed Nov  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
243- new upstream release
244
245* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
246- new upstream release
247
248* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
249- rebuild with new environment/toolchain
250
251* Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
252- new upstream release
253
254* Mon Sep  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
255- added --enable-utf8 option
256
257* Sun Sep  4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
258- new upstream release
259
260* Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
261- new upstream release
262- added Japanese summary
263
264* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
265- new upstream release
266
267* Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
268- new upstream release
269
270* Mon May  5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
271- skip 'make check' on alpha
272
273* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
274- change install section
275- change files section
276
277* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
278- update to 4.1
279- add %{_bindir}/pcretest
280- add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
281
282* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
283- rebuild with new toolchains
284
285* Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
286- Update to 3.9
287
288* Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
289- Update to 3.7
290
291* Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
292- Update to 3.5
293
294* Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
295- Build for VineSeed
296
297* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
298- Move libpcre to /lib, grep uses it these days (#41104)
299
300* Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
301- Move this to a separate package, used to be in kdesupport, but it's
302  generally useful...
Note: See TracBrowser for help on using the repository browser.