source: projects/specs/trunk/p/pcre/pcre-vl.spec @ 9410

Revision 9410, 7.4 KB checked in by inagaki, 9 years ago (diff)

2015-03-05 Ryoichi INAGAKI <ryo1@…>

  • opencv, suitesparse: rebuilt with tbb
  • pcre: updated with security fix
  • tbb: new


Line 
1Name: pcre
2Version: 8.36
3Release: 1%{?_dist_release}
4Summary: Perl-compatible regular expression library
5Summary(ja): Perl 互換の正規表現ライブラリ
6
7Group: System Environment/Libraries
8License: BSD
9URL: http://www.pcre.org/
10
11Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
12# Upstream thinks RPATH is good idea.
13Patch0: pcre-8.21-multilib.patch
14# Refused by upstream, bug #675477
15Patch1: pcre-8.32-refused_spelling_terminated.patch
16# Reset non-matched groups within capturing group up to forced match,
17# bug #1161587, in upstream after 8.36
18Patch2: pcre-8.36-Fix-bug-when-there-are-unset-groups-prior-to-ACCEPT-.patch
19# Fix unused memory usage on zero-repeat assertion condition, bug #1165626,
20# CVE-2014-8964, in upstream after 8.36
21Patch3: pcre-8.36-Fix-zero-repeat-assertion-condition-bug.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: zlib-devel
25BuildRequires: bzip2-devel
26BuildRequires: libedit-devel
27# New libtool to get rid of rpath
28BuildRequires: autoconf, automake, libtool
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33Packager: inagaki
34
35%description
36Perl-compatible regular expression library.
37PCRE has its own native API, but a set of "wrapper" functions that are based on
38the POSIX API are also supplied in the library libpcreposix. Note that this
39just provides a POSIX calling interface to PCRE: the regular expressions
40themselves still follow Perl syntax and semantics. The header file
41for the POSIX-style functions is called pcreposix.h.
42
43%package devel
44Summary: Development files for %{name}
45Summary(ja): %{name} の開発用ファイル
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48
49%description devel
50Development files (Headers, libraries for static linking, etc) for %{name}.
51
52%prep
53%setup -q
54# Get rid of rpath
55%patch0 -p1 -b .multilib
56%patch1 -p1 -b .terminated_typos
57%patch2 -p1 -b .reset_groups
58%patch3 -p1 -b .zero_repeat_assertion
59# Because of rpath patch
60libtoolize --copy --force && autoreconf -vif
61# One contributor's name is non-UTF-8
62for F in ChangeLog; do
63    iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
64    touch --reference "$F" "${F}.utf8"
65    mv "${F}.utf8" "$F"
66done
67
68%build
69%configure \
70    --enable-jit \
71    --disable-static \
72    --enable-utf8 \
73    --enable-unicode-properties \
74    --enable-pcregrep-libz \
75    --enable-pcregrep-libbz2 \
76    --enable-pcretest-libedit \
77    --enable-pcre8 \
78    --enable-pcre16 \
79    --enable-pcre32
80
81make %{?_smp_mflags}
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install DESTDIR=$RPM_BUILD_ROOT
86
87rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
88rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
89
90%check
91%ifarch s390 s390x ppc
92# larger stack is needed on s390, ppc
93ulimit -s 10240
94%endif
95make %{?_smp_mflags} check VERBOSE=yes
96
97%clean
98rm -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101
102%postun -p /sbin/ldconfig
103
104
105%files
106%defattr(-,root,root)
107%doc AUTHORS COPYING ChangeLog LICENCE NEWS README
108%{_bindir}/pcregrep
109%{_libdir}/*.so.*
110%{_mandir}/man1/pcregrep.*
111
112%files devel
113%defattr(-,root,root)
114%doc doc/html/*
115%{_bindir}/pcre-config
116%{_bindir}/pcretest
117%{_includedir}/*
118%{_libdir}/*.so
119%{_libdir}/pkgconfig/*.pc
120%{_mandir}/man1/pcre-config.*
121%{_mandir}/man1/pcretest.*
122%{_mandir}/man3/*
123
124%changelog
125* Thu Apr  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
126- new upstream release
127- added patches including security fix from Fedora (CVE-2014-8964)
128* Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
129  - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
130    (bug #1165626)
131  * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
132  - Reset non-matched groups within capturing group up to forced match
133    (bug #1161587)
134  * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
135  - Fix typos in manual pages (bugs #675476, #675477)
136
137* Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
138- new upstream release
139- add --enable-pcre32 and --enable-pcretest-libedit
140
141* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
142- new upstream release
143- add --enable-pcre16 --enable-pcre8 --enable-jit
144- API change
145- change includedir to /usr/include
146
147* Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
148- new upstream release
149
150* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
151- new upstream release
152
153* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
154- rebuilt with rpm-4.8.1 for pkg-config
155
156* Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
157- new upstream release
158
159* Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
160- new upstream release with security fix
161
162* Sat Feb  6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
163- new upstream release
164
165* Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
166- new upstream release
167
168* Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
169- add --enable-unicode-properties to configure option
170
171* Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
172- new upstream release
173- added BR: zlib-devel, bzip2-devel
174- removed static libraries from devel package
175- added Packager tag
176
177* Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
178- new upstream release
179- spec in UTF-8
180
181* Sun Jul  6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
182- new upstream release
183
184* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
185- use macro for Release
186
187* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
188- apply new virsioning policy.
189- remove *.la
190
191* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
192- new upstream release
193
194* Wed Nov  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
195- new upstream release
196
197* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
198- new upstream release
199
200* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
201- rebuild with new environment/toolchain
202
203* Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
204- new upstream release
205
206* Mon Sep  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
207- added --enable-utf8 option
208
209* Sun Sep  4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
210- new upstream release
211
212* Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
213- new upstream release
214- added Japanese summary
215
216* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
217- new upstream release
218
219* Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
220- new upstream release
221
222* Mon May  5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
223- skip 'make check' on alpha
224
225* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
226- change install section
227- change files section
228
229* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
230- update to 4.1
231- add %{_bindir}/pcretest
232- add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
233
234* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
235- rebuild with new toolchains
236
237* Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
238- Update to 3.9
239
240* Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
241- Update to 3.7
242
243* Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
244- Update to 3.5
245
246* Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
247- Build for VineSeed
248
249* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
250- Move libpcre to /lib, grep uses it these days (#41104)
251
252* Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
253- Move this to a separate package, used to be in kdesupport, but it's
254  generally useful...
Note: See TracBrowser for help on using the repository browser.