source: projects/specs/trunk/p/pcre/pcre-vl.spec @ 12084

Revision 12084, 9.2 KB checked in by tomop, 5 years ago (diff)

pcre-8.43-1

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: pcre
4Version: 8.43
5Release: 1%{?_dist_release}
6Summary: Perl-compatible regular expression library
7Summary(ja): Perl 互換の正規表現ライブラリ
8
9Group: System Environment/Libraries
10License: BSD
11URL: http://www.pcre.org/
12
13Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
14# Upstream thinks RPATH is good idea.
15Patch0: pcre-8.21-multilib.patch
16# Refused by upstream, bug #675477
17Patch1: pcre-8.32-refused_spelling_terminated.patch
18# Fix recursion stack estimator, upstream bug #2173, refused by upstream
19Patch2:     pcre-8.41-fix_stack_estimator.patch
20# Link applications to PCRE-specific symbols when using POSIX API, bug #1667614,
21
22# upstream bug 1830, partially borrowed from PCRE2, proposed to upstream,
23# This amends ABI, application built with this patch cannot run with
24# previous libpcreposix builds.
25Patch3:     pcre-8.42-Declare-POSIX-regex-function-names-as-macros-to-PCRE.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: zlib-devel
29BuildRequires: bzip2-devel
30BuildRequires: libedit-devel
31# New libtool to get rid of rpath
32BuildRequires: autoconf, automake, libtool
33
34Vendor: Project Vine
35Distribution: Vine Linux
36
37Packager: inagaki
38
39%description
40Perl-compatible regular expression library.
41PCRE has its own native API, but a set of "wrapper" functions that are based on
42the POSIX API are also supplied in the library libpcreposix. Note that this
43just provides a POSIX calling interface to PCRE: the regular expressions
44themselves still follow Perl syntax and semantics. The header file
45for the POSIX-style functions is called pcreposix.h.
46
47%package devel
48Summary: Development files for %{name}
49Summary(ja): %{name} の開発用ファイル
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description devel
54Development files (Headers, libraries for static linking, etc) for %{name}.
55
56
57%package -n compat32-%{name}
58Summary: Perl-compatible regular expression library
59Summary(ja): Perl 互換の正規表現ライブラリ
60Group: System Environment/Libraries
61
62%description -n compat32-%{name}
63Perl-compatible regular expression library.
64PCRE has its own native API, but a set of "wrapper" functions that are based on
65the POSIX API are also supplied in the library libpcreposix. Note that this
66just provides a POSIX calling interface to PCRE: the regular expressions
67themselves still follow Perl syntax and semantics. The header file
68for the POSIX-style functions is called pcreposix.h.
69
70
71%package -n compat32-%{name}-devel
72Summary: Development files for %{name}
73Summary(ja): %{name} の開発用ファイル
74Group: Development/Libraries
75Requires: compat32-%{name} = %{version}-%{release}
76
77%description -n compat32-%{name}-devel
78Development files (Headers, libraries for static linking, etc) for %{name}.
79
80
81%prep
82%setup -q
83# Get rid of rpath
84%patch0 -p1 -b .multilib
85%patch1 -p1 -b .terminated_typos
86%patch2 -p2
87%patch3 -p1
88# Because of rpath patch
89libtoolize --copy --force && autoreconf -vif
90# One contributor's name is non-UTF-8
91for F in ChangeLog; do
92    iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
93    touch --reference "$F" "${F}.utf8"
94    mv "${F}.utf8" "$F"
95done
96
97%build
98%configure \
99    --enable-jit \
100    --disable-static \
101    --enable-utf8 \
102    --enable-unicode-properties \
103    --enable-pcregrep-libz \
104    --enable-pcregrep-libbz2 \
105    --enable-pcretest-libedit \
106    --enable-pcre8 \
107    --enable-pcre16 \
108    --enable-pcre32
109
110make %{?_smp_mflags}
111
112%install
113rm -rf $RPM_BUILD_ROOT
114make install DESTDIR=$RPM_BUILD_ROOT
115
116rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
117rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
118
119%check
120%ifarch s390 s390x ppc
121# larger stack is needed on s390, ppc
122ulimit -s 10240
123%endif
124make %{?_smp_mflags} check VERBOSE=yes
125
126%clean
127rm -rf $RPM_BUILD_ROOT
128
129%post -p /sbin/ldconfig
130
131%postun -p /sbin/ldconfig
132
133%post -n compat32-%{name} -p /sbin/ldconfig
134
135%postun -n compat32-%{name} -p /sbin/ldconfig
136
137
138%files
139%defattr(-,root,root)
140%license COPYING
141%doc AUTHORS ChangeLog LICENCE NEWS README
142%{_bindir}/pcregrep
143%{_libdir}/*.so.*
144%{_mandir}/man1/pcregrep.*
145
146%files devel
147%defattr(-,root,root)
148%doc doc/html/*
149%{_bindir}/pcre-config
150%{_bindir}/pcretest
151%{_includedir}/*
152%{_libdir}/*.so
153%{_libdir}/pkgconfig/*.pc
154%{_mandir}/man1/pcre-config.*
155%{_mandir}/man1/pcretest.*
156%{_mandir}/man3/*
157
158%if %{build_compat32}
159%files -n compat32-%{name}
160%defattr(-, root, root)
161%{_libdir}/*.so.*
162
163%files -n compat32-%{name}-devel
164%defattr(-, root, root)
165%{_libdir}/*.so
166%endif
167
168
169%changelog
170* Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.43-1
171- new upstream release.
172- imported Patch2 and 3 from rawhide.
173
174* Fri Jul 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.39-2
175- create comapt32 packages
176
177* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
178- new upstream release.
179- dropped Patch1000,1001: fixed in upstream.
180
181* Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
182- new upstream release.
183- removed Patch2,Patch3 (no longer needed).
184- added Patch1000 to fix CVE-2016-1283.
185
186* Sun Apr  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
187- new upstream release
188- added patches including security fix from Fedora (CVE-2014-8964)
189* Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
190  - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
191    (bug #1165626)
192  * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
193  - Reset non-matched groups within capturing group up to forced match
194    (bug #1161587)
195  * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
196  - Fix typos in manual pages (bugs #675476, #675477)
197
198* Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
199- new upstream release
200- add --enable-pcre32 and --enable-pcretest-libedit
201
202* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
203- new upstream release
204- add --enable-pcre16 --enable-pcre8 --enable-jit
205- API change
206- change includedir to /usr/include
207
208* Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
209- new upstream release
210
211* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
212- new upstream release
213
214* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
215- rebuilt with rpm-4.8.1 for pkg-config
216
217* Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
218- new upstream release
219
220* Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
221- new upstream release with security fix
222
223* Sat Feb  6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
224- new upstream release
225
226* Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
227- new upstream release
228
229* Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
230- add --enable-unicode-properties to configure option
231
232* Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
233- new upstream release
234- added BR: zlib-devel, bzip2-devel
235- removed static libraries from devel package
236- added Packager tag
237
238* Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
239- new upstream release
240- spec in UTF-8
241
242* Sun Jul  6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
243- new upstream release
244
245* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
246- use macro for Release
247
248* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
249- apply new virsioning policy.
250- remove *.la
251
252* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
253- new upstream release
254
255* Wed Nov  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
256- new upstream release
257
258* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
259- new upstream release
260
261* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
262- rebuild with new environment/toolchain
263
264* Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
265- new upstream release
266
267* Mon Sep  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
268- added --enable-utf8 option
269
270* Sun Sep  4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
271- new upstream release
272
273* Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
274- new upstream release
275- added Japanese summary
276
277* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
278- new upstream release
279
280* Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
281- new upstream release
282
283* Mon May  5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
284- skip 'make check' on alpha
285
286* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
287- change install section
288- change files section
289
290* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
291- update to 4.1
292- add %{_bindir}/pcretest
293- add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
294
295* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
296- rebuild with new toolchains
297
298* Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
299- Update to 3.9
300
301* Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
302- Update to 3.7
303
304* Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
305- Update to 3.5
306
307* Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
308- Build for VineSeed
309
310* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
311- Move libpcre to /lib, grep uses it these days (#41104)
312
313* Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
314- Move this to a separate package, used to be in kdesupport, but it's
315  generally useful...
Note: See TracBrowser for help on using the repository browser.