source: projects/specs/trunk/p/pcre/pcre-vl.spec @ 10716

Revision 10716, 8.6 KB checked in by Takemikaduchi, 8 years ago (diff)

GNOME-3.20

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name: pcre
4Version: 8.39
5Release: 2%{?_dist_release}
6Summary: Perl-compatible regular expression library
7Summary(ja): Perl 互換の正規表現ライブラリ
8
9Group: System Environment/Libraries
10License: BSD
11URL: http://www.pcre.org/
12
13Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
14# Upstream thinks RPATH is good idea.
15Patch0: pcre-8.21-multilib.patch
16# Refused by upstream, bug #675477
17Patch1: pcre-8.32-refused_spelling_terminated.patch
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20BuildRequires: zlib-devel
21BuildRequires: bzip2-devel
22BuildRequires: libedit-devel
23# New libtool to get rid of rpath
24BuildRequires: autoconf, automake, libtool
25
26Vendor: Project Vine
27Distribution: Vine Linux
28
29Packager: inagaki
30
31%description
32Perl-compatible regular expression library.
33PCRE has its own native API, but a set of "wrapper" functions that are based on
34the POSIX API are also supplied in the library libpcreposix. Note that this
35just provides a POSIX calling interface to PCRE: the regular expressions
36themselves still follow Perl syntax and semantics. The header file
37for the POSIX-style functions is called pcreposix.h.
38
39%package devel
40Summary: Development files for %{name}
41Summary(ja): %{name} の開発用ファイル
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44
45%description devel
46Development files (Headers, libraries for static linking, etc) for %{name}.
47
48
49%package -n compat32-%{name}
50Summary: Perl-compatible regular expression library
51Summary(ja): Perl 互換の正規表現ライブラリ
52Group: System Environment/Libraries
53
54%description -n compat32-%{name}
55Perl-compatible regular expression library.
56PCRE has its own native API, but a set of "wrapper" functions that are based on
57the POSIX API are also supplied in the library libpcreposix. Note that this
58just provides a POSIX calling interface to PCRE: the regular expressions
59themselves still follow Perl syntax and semantics. The header file
60for the POSIX-style functions is called pcreposix.h.
61
62
63%package -n compat32-%{name}-devel
64Summary: Development files for %{name}
65Summary(ja): %{name} の開発用ファイル
66Group: Development/Libraries
67Requires: compat32-%{name} = %{version}-%{release}
68
69%description -n compat32-%{name}-devel
70Development files (Headers, libraries for static linking, etc) for %{name}.
71
72
73%prep
74%setup -q
75# Get rid of rpath
76%patch0 -p1 -b .multilib
77%patch1 -p1 -b .terminated_typos
78# Because of rpath patch
79libtoolize --copy --force && autoreconf -vif
80# One contributor's name is non-UTF-8
81for F in ChangeLog; do
82    iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
83    touch --reference "$F" "${F}.utf8"
84    mv "${F}.utf8" "$F"
85done
86
87%build
88%configure \
89    --enable-jit \
90    --disable-static \
91    --enable-utf8 \
92    --enable-unicode-properties \
93    --enable-pcregrep-libz \
94    --enable-pcregrep-libbz2 \
95    --enable-pcretest-libedit \
96    --enable-pcre8 \
97    --enable-pcre16 \
98    --enable-pcre32
99
100make %{?_smp_mflags}
101
102%install
103rm -rf $RPM_BUILD_ROOT
104make install DESTDIR=$RPM_BUILD_ROOT
105
106rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
107rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
108
109%check
110%ifarch s390 s390x ppc
111# larger stack is needed on s390, ppc
112ulimit -s 10240
113%endif
114make %{?_smp_mflags} check VERBOSE=yes
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%post -p /sbin/ldconfig
120
121%postun -p /sbin/ldconfig
122
123%post -n compat32-%{name} -p /sbin/ldconfig
124
125%postun -n compat32-%{name} -p /sbin/ldconfig
126
127
128%files
129%defattr(-,root,root)
130%doc AUTHORS COPYING ChangeLog LICENCE NEWS README
131%{_bindir}/pcregrep
132%{_libdir}/*.so.*
133%{_mandir}/man1/pcregrep.*
134
135%files devel
136%defattr(-,root,root)
137%doc doc/html/*
138%{_bindir}/pcre-config
139%{_bindir}/pcretest
140%{_includedir}/*
141%{_libdir}/*.so
142%{_libdir}/pkgconfig/*.pc
143%{_mandir}/man1/pcre-config.*
144%{_mandir}/man1/pcretest.*
145%{_mandir}/man3/*
146
147%if %{build_compat32}
148%files -n compat32-%{name}
149%defattr(-, root, root)
150%{_libdir}/*.so.*
151
152%files -n compat32-%{name}-devel
153%defattr(-, root, root)
154%{_libdir}/*.so
155%endif
156
157
158%changelog
159* Fri Jul 29 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.39-2
160- create comapt32 packages
161
162* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
163- new upstream release.
164- dropped Patch1000,1001: fixed in upstream.
165
166* Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
167- new upstream release.
168- removed Patch2,Patch3 (no longer needed).
169- added Patch1000 to fix CVE-2016-1283.
170
171* Sun Apr  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
172- new upstream release
173- added patches including security fix from Fedora (CVE-2014-8964)
174* Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
175  - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
176    (bug #1165626)
177  * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
178  - Reset non-matched groups within capturing group up to forced match
179    (bug #1161587)
180  * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
181  - Fix typos in manual pages (bugs #675476, #675477)
182
183* Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
184- new upstream release
185- add --enable-pcre32 and --enable-pcretest-libedit
186
187* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
188- new upstream release
189- add --enable-pcre16 --enable-pcre8 --enable-jit
190- API change
191- change includedir to /usr/include
192
193* Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
194- new upstream release
195
196* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
197- new upstream release
198
199* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
200- rebuilt with rpm-4.8.1 for pkg-config
201
202* Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
203- new upstream release
204
205* Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
206- new upstream release with security fix
207
208* Sat Feb  6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
209- new upstream release
210
211* Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
212- new upstream release
213
214* Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
215- add --enable-unicode-properties to configure option
216
217* Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
218- new upstream release
219- added BR: zlib-devel, bzip2-devel
220- removed static libraries from devel package
221- added Packager tag
222
223* Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
224- new upstream release
225- spec in UTF-8
226
227* Sun Jul  6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
228- new upstream release
229
230* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
231- use macro for Release
232
233* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
234- apply new virsioning policy.
235- remove *.la
236
237* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
238- new upstream release
239
240* Wed Nov  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
241- new upstream release
242
243* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
244- new upstream release
245
246* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
247- rebuild with new environment/toolchain
248
249* Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
250- new upstream release
251
252* Mon Sep  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
253- added --enable-utf8 option
254
255* Sun Sep  4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
256- new upstream release
257
258* Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
259- new upstream release
260- added Japanese summary
261
262* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
263- new upstream release
264
265* Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
266- new upstream release
267
268* Mon May  5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
269- skip 'make check' on alpha
270
271* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
272- change install section
273- change files section
274
275* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
276- update to 4.1
277- add %{_bindir}/pcretest
278- add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
279
280* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
281- rebuild with new toolchains
282
283* Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
284- Update to 3.9
285
286* Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
287- Update to 3.7
288
289* Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
290- Update to 3.5
291
292* Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
293- Build for VineSeed
294
295* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
296- Move libpcre to /lib, grep uses it these days (#41104)
297
298* Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
299- Move this to a separate package, used to be in kdesupport, but it's
300  generally useful...
Note: See TracBrowser for help on using the repository browser.