source: projects/specs/trunk/p/pcre/pcre-vl.spec @ 10455

Revision 10455, 7.3 KB checked in by tomop, 8 years ago (diff)

pcre-8.39-1

Line 
1Name: pcre
2Version: 8.39
3Release: 1%{?_dist_release}
4Summary: Perl-compatible regular expression library
5Summary(ja): Perl 互換の正規表現ライブラリ
6
7Group: System Environment/Libraries
8License: BSD
9URL: http://www.pcre.org/
10
11Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
12# Upstream thinks RPATH is good idea.
13Patch0: pcre-8.21-multilib.patch
14# Refused by upstream, bug #675477
15Patch1: pcre-8.32-refused_spelling_terminated.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: zlib-devel
19BuildRequires: bzip2-devel
20BuildRequires: libedit-devel
21# New libtool to get rid of rpath
22BuildRequires: autoconf, automake, libtool
23
24Vendor: Project Vine
25Distribution: Vine Linux
26
27Packager: inagaki
28
29%description
30Perl-compatible regular expression library.
31PCRE has its own native API, but a set of "wrapper" functions that are based on
32the POSIX API are also supplied in the library libpcreposix. Note that this
33just provides a POSIX calling interface to PCRE: the regular expressions
34themselves still follow Perl syntax and semantics. The header file
35for the POSIX-style functions is called pcreposix.h.
36
37%package devel
38Summary: Development files for %{name}
39Summary(ja): %{name} の開発用ファイル
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44Development files (Headers, libraries for static linking, etc) for %{name}.
45
46%prep
47%setup -q
48# Get rid of rpath
49%patch0 -p1 -b .multilib
50%patch1 -p1 -b .terminated_typos
51# Because of rpath patch
52libtoolize --copy --force && autoreconf -vif
53# One contributor's name is non-UTF-8
54for F in ChangeLog; do
55    iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
56    touch --reference "$F" "${F}.utf8"
57    mv "${F}.utf8" "$F"
58done
59
60%build
61%configure \
62    --enable-jit \
63    --disable-static \
64    --enable-utf8 \
65    --enable-unicode-properties \
66    --enable-pcregrep-libz \
67    --enable-pcregrep-libbz2 \
68    --enable-pcretest-libedit \
69    --enable-pcre8 \
70    --enable-pcre16 \
71    --enable-pcre32
72
73make %{?_smp_mflags}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77make install DESTDIR=$RPM_BUILD_ROOT
78
79rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
80rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
81
82%check
83%ifarch s390 s390x ppc
84# larger stack is needed on s390, ppc
85ulimit -s 10240
86%endif
87make %{?_smp_mflags} check VERBOSE=yes
88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96
97%files
98%defattr(-,root,root)
99%doc AUTHORS COPYING ChangeLog LICENCE NEWS README
100%{_bindir}/pcregrep
101%{_libdir}/*.so.*
102%{_mandir}/man1/pcregrep.*
103
104%files devel
105%defattr(-,root,root)
106%doc doc/html/*
107%{_bindir}/pcre-config
108%{_bindir}/pcretest
109%{_includedir}/*
110%{_libdir}/*.so
111%{_libdir}/pkgconfig/*.pc
112%{_mandir}/man1/pcre-config.*
113%{_mandir}/man1/pcretest.*
114%{_mandir}/man3/*
115
116%changelog
117* Thu Jun 30 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.39-1
118- new upstream release.
119- dropped Patch1000,1001: fixed in upstream.
120
121* Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
122- new upstream release.
123- removed Patch2,Patch3 (no longer needed).
124- added Patch1000 to fix CVE-2016-1283.
125
126* Sun Apr  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
127- new upstream release
128- added patches including security fix from Fedora (CVE-2014-8964)
129* Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
130  - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
131    (bug #1165626)
132  * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
133  - Reset non-matched groups within capturing group up to forced match
134    (bug #1161587)
135  * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
136  - Fix typos in manual pages (bugs #675476, #675477)
137
138* Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
139- new upstream release
140- add --enable-pcre32 and --enable-pcretest-libedit
141
142* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
143- new upstream release
144- add --enable-pcre16 --enable-pcre8 --enable-jit
145- API change
146- change includedir to /usr/include
147
148* Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
149- new upstream release
150
151* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
152- new upstream release
153
154* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
155- rebuilt with rpm-4.8.1 for pkg-config
156
157* Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
158- new upstream release
159
160* Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
161- new upstream release with security fix
162
163* Sat Feb  6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
164- new upstream release
165
166* Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
167- new upstream release
168
169* Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
170- add --enable-unicode-properties to configure option
171
172* Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
173- new upstream release
174- added BR: zlib-devel, bzip2-devel
175- removed static libraries from devel package
176- added Packager tag
177
178* Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
179- new upstream release
180- spec in UTF-8
181
182* Sun Jul  6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
183- new upstream release
184
185* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
186- use macro for Release
187
188* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
189- apply new virsioning policy.
190- remove *.la
191
192* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
193- new upstream release
194
195* Wed Nov  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
196- new upstream release
197
198* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
199- new upstream release
200
201* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
202- rebuild with new environment/toolchain
203
204* Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
205- new upstream release
206
207* Mon Sep  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
208- added --enable-utf8 option
209
210* Sun Sep  4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
211- new upstream release
212
213* Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
214- new upstream release
215- added Japanese summary
216
217* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
218- new upstream release
219
220* Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
221- new upstream release
222
223* Mon May  5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
224- skip 'make check' on alpha
225
226* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
227- change install section
228- change files section
229
230* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
231- update to 4.1
232- add %{_bindir}/pcretest
233- add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
234
235* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
236- rebuild with new toolchains
237
238* Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
239- Update to 3.9
240
241* Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
242- Update to 3.7
243
244* Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
245- Update to 3.5
246
247* Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
248- Build for VineSeed
249
250* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
251- Move libpcre to /lib, grep uses it these days (#41104)
252
253* Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
254- Move this to a separate package, used to be in kdesupport, but it's
255  generally useful...
Note: See TracBrowser for help on using the repository browser.