source: projects/specs/trunk/p/pcre/pcre-vl.spec @ 10099

Revision 10099, 7.3 KB checked in by tomop, 8 years ago (diff)

pcre-8.38-1

Line 
1Name: pcre
2Version: 8.38
3Release: 1%{?_dist_release}
4Summary: Perl-compatible regular expression library
5Summary(ja): Perl 互換の正規表現ライブラリ
6
7Group: System Environment/Libraries
8License: BSD
9URL: http://www.pcre.org/
10
11Source0: ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/%{name}-%{version}.tar.bz2
12# Upstream thinks RPATH is good idea.
13Patch0: pcre-8.21-multilib.patch
14# Refused by upstream, bug #675477
15Patch1: pcre-8.32-refused_spelling_terminated.patch
16
17# to fix CVE-2016-3191
18Patch1000: CVE-2016-3191.patch
19# to fix CVE-2016-1283
20Patch1001: CVE-2016-1283.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-root
23BuildRequires: zlib-devel
24BuildRequires: bzip2-devel
25BuildRequires: libedit-devel
26# New libtool to get rid of rpath
27BuildRequires: autoconf, automake, libtool
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32Packager: inagaki
33
34%description
35Perl-compatible regular expression library.
36PCRE has its own native API, but a set of "wrapper" functions that are based on
37the POSIX API are also supplied in the library libpcreposix. Note that this
38just provides a POSIX calling interface to PCRE: the regular expressions
39themselves still follow Perl syntax and semantics. The header file
40for the POSIX-style functions is called pcreposix.h.
41
42%package devel
43Summary: Development files for %{name}
44Summary(ja): %{name} の開発用ファイル
45Group: Development/Libraries
46Requires: %{name} = %{version}-%{release}
47
48%description devel
49Development files (Headers, libraries for static linking, etc) for %{name}.
50
51%prep
52%setup -q
53# Get rid of rpath
54%patch0 -p1 -b .multilib
55%patch1 -p1 -b .terminated_typos
56%patch1000 -p0 -b .CVE-2016-3191
57%patch1001 -p0 -b .CVE-2016-1283
58# Because of rpath patch
59libtoolize --copy --force && autoreconf -vif
60# One contributor's name is non-UTF-8
61for F in ChangeLog; do
62    iconv -f latin1 -t utf8 "$F" >"${F}.utf8"
63    touch --reference "$F" "${F}.utf8"
64    mv "${F}.utf8" "$F"
65done
66
67%build
68%configure \
69    --enable-jit \
70    --disable-static \
71    --enable-utf8 \
72    --enable-unicode-properties \
73    --enable-pcregrep-libz \
74    --enable-pcregrep-libbz2 \
75    --enable-pcretest-libedit \
76    --enable-pcre8 \
77    --enable-pcre16 \
78    --enable-pcre32
79
80make %{?_smp_mflags}
81
82%install
83rm -rf $RPM_BUILD_ROOT
84make install DESTDIR=$RPM_BUILD_ROOT
85
86rm -rf $RPM_BUILD_ROOT%{_datadir}/doc
87rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
88
89%check
90%ifarch s390 s390x ppc
91# larger stack is needed on s390, ppc
92ulimit -s 10240
93%endif
94make %{?_smp_mflags} check VERBOSE=yes
95
96%clean
97rm -rf $RPM_BUILD_ROOT
98
99%post -p /sbin/ldconfig
100
101%postun -p /sbin/ldconfig
102
103
104%files
105%defattr(-,root,root)
106%doc AUTHORS COPYING ChangeLog LICENCE NEWS README
107%{_bindir}/pcregrep
108%{_libdir}/*.so.*
109%{_mandir}/man1/pcregrep.*
110
111%files devel
112%defattr(-,root,root)
113%doc doc/html/*
114%{_bindir}/pcre-config
115%{_bindir}/pcretest
116%{_includedir}/*
117%{_libdir}/*.so
118%{_libdir}/pkgconfig/*.pc
119%{_mandir}/man1/pcre-config.*
120%{_mandir}/man1/pcretest.*
121%{_mandir}/man3/*
122
123%changelog
124* Wed Mar 23 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.38-1
125- new upstream release.
126- removed Patch2,Patch3 (no longer needed).
127- added Patch1000 to fix CVE-2016-1283.
128
129* Sun Apr  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.36-1
130- new upstream release
131- added patches including security fix from Fedora (CVE-2014-8964)
132* Thu Nov 20 2014 Petr Pisar <ppisar@redhat.com> - 8.36-3
133  - Fix CVE-2014-8964 (unused memory usage on zero-repeat assertion condition)
134    (bug #1165626)
135  * Fri Nov 07 2014 Petr Pisar <ppisar@redhat.com> - 8.36-2
136  - Reset non-matched groups within capturing group up to forced match
137    (bug #1161587)
138  * Mon May 09 2011 Petr Pisar <ppisar@redhat.com> - 8.12-3
139  - Fix typos in manual pages (bugs #675476, #675477)
140
141* Thu Sep 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.35-1
142- new upstream release
143- add --enable-pcre32 and --enable-pcretest-libedit
144
145* Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.31-1
146- new upstream release
147- add --enable-pcre16 --enable-pcre8 --enable-jit
148- API change
149- change includedir to /usr/include
150
151* Sat Sep 10 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.13-1
152- new upstream release
153
154* Tue Mar 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.12-1
155- new upstream release
156
157* Mon Sep 27 2010 Shu KONNO <owa@bg.wakwak.com> 8.10-2
158- rebuilt with rpm-4.8.1 for pkg-config
159
160* Thu Aug 19 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.10-1
161- new upstream release
162
163* Mon May 10 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 8.02-1
164- new upstream release with security fix
165
166* Sat Feb  6 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.01-1
167- new upstream release
168
169* Sat Jan 16 2010 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 8.00-1
170- new upstream release
171
172* Tue Jul 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.9-2
173- add --enable-unicode-properties to configure option
174
175* Wed Jun 10 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.9-1
176- new upstream release
177- added BR: zlib-devel, bzip2-devel
178- removed static libraries from devel package
179- added Packager tag
180
181* Sat Jan 24 2009 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.8-1vl5
182- new upstream release
183- spec in UTF-8
184
185* Sun Jul  6 2008 Ryoiochi INAGAKI <ryo1@bc.wakwak.com> 7.7-1vl5
186- new upstream release
187
188* Tue May 13 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
189- use macro for Release
190
191* Fri May 09 2008 Yasumichi Akahoshi <yasumichi@vinelinux.org> 7.6-1vl5
192- apply new virsioning policy.
193- remove *.la
194
195* Thu Feb  7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.6-0vl1
196- new upstream release
197
198* Wed Nov  7 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.4-0vl1
199- new upstream release
200
201* Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.2-0vl1
202- new upstream release
203
204* Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 6.6-0vl2
205- rebuild with new environment/toolchain
206
207* Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
208- new upstream release
209
210* Mon Sep  5 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl2
211- added --enable-utf8 option
212
213* Sun Sep  4 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.3-0vl1
214- new upstream release
215
216* Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.0-0vl1
217- new upstream release
218- added Japanese summary
219
220* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5-0vl1
221- new upstream release
222
223* Mon Oct 13 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.4-0vl1
224- new upstream release
225
226* Mon May  5 2003 Tomoya TAKA <taka@vinelinux.org> 4.1-0vl3
227- skip 'make check' on alpha
228
229* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl2
230- change install section
231- change files section
232
233* Fri Mar 28 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.1-0vl1
234- update to 4.1
235- add %{_bindir}/pcretest
236- add %doc AUTHORS COPYING ChangeLog INSTALL LICENCE NEWS README
237
238* Sun Dec 15 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.9-0vl2
239- rebuild with new toolchains
240
241* Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.9-0vl1
242- Update to 3.9
243
244* Wed Dec 26 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.7-0vl1
245- Update to 3.7
246
247* Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.5-0vl1
248- Update to 3.5
249
250* Wed Oct 10 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 3.4-2vl1
251- Build for VineSeed
252
253* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 3.4-2
254- Move libpcre to /lib, grep uses it these days (#41104)
255
256* Wed Apr 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
257- Move this to a separate package, used to be in kdesupport, but it's
258  generally useful...
Note: See TracBrowser for help on using the repository browser.