source: projects/specs/trunk/p/pccts/pccts-vl.spec @ 521

Revision 521, 4.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: The Purdue Compiler-Compiler Tool Set.
2Name: pccts
3Version: 1.33mr33
4Release: 1%{?_dist_release}
5Source: http://www.polhode.com/pccts133mr33.zip
6URL: http://www.polhode.com/pccts.html
7License: Public domain
8Group: Development/Tools
9BuildRoot: %{_tmppath}/%{name}-root
10Prefix: %{_prefix}
11
12%description
13The Purdue Compiler-Compiler Tool Set (PCCTS) is a set of public
14domain software tools designed to facilitate the implementation of
15compilers and other translation systems.  These tools currently
16include antlr, dlg and support code.  In many ways, PCCTS is similar
17to a highly integrated version of YACC and LEX; where antlr (ANother
18Tool for Language Recognition) corresponds to YACC and dlg (DFA-based
19Lexical analyzer Generator) functions like LEX.  However, PCCTS has
20many additional features which make it easier to use for a wider range
21of translation problems.
22
23%prep
24rm -rf $RPM_BUILD_DIR/pccts/
25unzip -q %{SOURCE0}
26%setup -DT -n pccts
27
28%build
29mkdir -p $RPM_BUILD_DIR/pccts/man/man1
30#make COPT="$RPM_OPT_FLAGS" MANDIR=man %{?_smp_mflags} pccts manpages
31make COPT="$RPM_OPT_FLAGS -DPCCTS_USE_STDARG" MANDIR=man %{?_smp_mflags} pccts manpages
32
33%install
34rm -rf $RPM_BUILD_ROOT
35
36mkdir -p $RPM_BUILD_ROOT%{prefix}/{bin,share/man/man1,include/pccts}
37
38install -s -m755 bin/antlr              $RPM_BUILD_ROOT%{_bindir}
39install    -m644 man/man1/antlr.1       $RPM_BUILD_ROOT%{_mandir}/man1
40install -s -m755 bin/dlg                $RPM_BUILD_ROOT%{_bindir}
41install    -m644 man/man1/dlg.1         $RPM_BUILD_ROOT%{_mandir}/man1
42install -s -m755 bin/genmk              $RPM_BUILD_ROOT%{_bindir}
43install -s -m755 bin/sor                $RPM_BUILD_ROOT%{_bindir}
44
45cp -a h/* $RPM_BUILD_ROOT%{_includedir}/pccts
46cp -a sorcerer/h/*.h $RPM_BUILD_ROOT%{_includedir}/pccts
47
48cp sorcerer/README README-sorcerer
49cp sorcerer/UPDATES UPDATES-sorcerer
50
51%clean
52rm -rf $RPM_BUILD_ROOT
53
54%files
55%defattr(-,root,root)
56%doc CHANGES_FROM_131.txt CHANGES_FROM_133.txt KNOWN_PROBLEMS.txt
57%doc NOTES.OS2 NOTES.bcc NOTES.msvc NOTES.watcom README RIGHTS
58%doc history.ps history.txt README-sorcerer UPDATES-sorcerer
59%attr(755,root,root) %{_bindir}/antlr
60%attr(755,root,root) %{_bindir}/dlg
61%attr(755,root,root) %{_bindir}/genmk
62%attr(755,root,root) %{_bindir}/sor
63%attr(755,root,root) %dir %{_includedir}/pccts
64%attr(644,root,root) %{_includedir}/pccts/*
65%attr(644,root,root) %{_mandir}/*/*
66
67%changelog
68* Sat Sep 06 2008 Shu KONNO <owa@bg.wakwak.com> 1.33mr33-1vl5
69- applied new versioning policy
70- added flag -DPCCTS_USE_STDARG to COPT
71
72* Sun Sep 21 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.33mr33-0vl1
73- source upgrade
74
75* Wed May 29 2002 Satoshi MACHINO <machino@vinelinux.org> 1.33mr31-4vl1
76- build on VineLinux
77- used rpmmacros
78
79* Sun May 26 2002 Tim Powers <timp@redhat.com>
80- automated rebuild
81
82* Tue May 21 2002 Mike A. Harris <mharris@redhat.com> 1.33mr31-3
83- Rebuilt in new environment to be able to build cdrdao
84
85* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
86- automated rebuild
87
88* Thu Jan 03 2002 Elliot Lee <sopwith@redhat.com>
89- Update to MR31
90
91* Mon May 21 2001 Tim Powers <timp@redhat.com>
92- rebuilt for the .distro
93
94* Mon Jul 24 2000 Prospector <prospector@redhat.com>
95- rebuilt
96
97* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
98- rebuilt
99
100* Wed Jun 21 2000 Tim Powers <timp@redhat.com>
101- fixed man page location to be FHS comliant
102
103* Mon May 8 2000 Tim Powers <timp@redhat.com>
104- updated to MR22
105
106* Tue Nov 2 1999 Tim Powers <timp@redhat.com>
107- updated to MR20
108
109* Sat Jul 10 1999 Tim Powers <timp@redhat.com>
110- updated version to mr19
111- updated URL
112
113* Wed Jan 6 1999 Michael Maher <mike@redhat.com>
114- built package for powertools
115- fixed broken includes dir
116
117* Mon Jan  4 1999 Ryan Weaver <ryanw@infohwy.com>
118  [pccts-1.33mr17-1]
119- #212. (Changed in MR17)  Mac related changes by Kenji Tanaka
120
121* Wed Dec 16 1998 Ryan Weaver <ryanw@infohwy.com>
122- Updated to 1.33 Maintainance Release 16a
123- Including sor and sorcerer header files.
124
125- #211. (Changed in MR16a)  C++ style comment in dlg
126- #210. (Changed in MR16a)  Sor accepts \r\n, \r, or \n for end-of-line
127
128* Fri Dec 11 1998 Ryan Weaver <ryanw@infohwy.com>
129- Updated to 1.33 Maintainance Release 16
130
131- #209. (Changed in MR16) Name of files changed.
132- #208. (Changed in MR16) Change in use of pccts #include files
133- #207. (Changed in MR16) dlg reports an invalid range for: [\0x00-\0xff]
134- #206. (Changed in MR16) Free zzFAILtext in ANTLRParser destructor
135- #205. (Changed in MR16) DLGStringReset argument now const
136
137* Mon Mar 23 1998 Elliot Lee <sopwith@cuc.edu> 1.33-4
138- Include header files
139
140* Mon Mar 23 1998 Elliot Lee <sopwith@cuc.edu> 1.33-3
141- Repackage for glibc
Note: See TracBrowser for help on using the repository browser.