source: projects/specs/trunk/p/parted/parted-vl.spec @ 8191

Revision 8191, 8.6 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define _sbindir    /sbin
2
3Summary: The GNU disk partition manipulation program.
4Summary(ja): ディスクパーティション操作ツール
5Name: parted
6Version: 3.1
7Release: 2%{?_dist_release}
8License: GPL
9Group: Applications/Administration
10URL: http://www.gnu.org/software/parted/
11
12Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
13
14Buildroot: %{_tmppath}/%{name}-%{version}-root
15BuildRequires: e2fsprogs-devel, ncurses-devel, readline-devel
16BuildRequires: python-devel, ncurses-devel
17BuildRequires: device-mapper-devel
18BuildRequires: libtool, automake, autoconf
19BuildRequires: gettext-devel >= 0.18
20BuildRequires: texinfo
21BuildRequires: libuuid-devel
22BuildRequires: libblkid-devel >= 2.17
23BuildRequires: gnupg
24
25Provides: libparted = %{version}-%{release}
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31GNU Parted is a program that allows you to create, destroy,
32resize, move and copy hard disk partitions. This is useful for
33creating space for new operating systems, reorganising disk
34usage, and copying data to new hard disks.
35
36%description -l ja
37GNU Parted はハードディスクのパーティションを作成/削除/リサイズ/
38移動/コピーすることが出来るプログラムです.新しいオペレーティング
39システムをインストールするスペースを確保したり,ディスクのパーティションを
40整理したり,新しいハードディスクにデータをコピーする際に非常に便利です.
41
42%package devel
43Summary: Files for developing apps which will manipulate disk partitions.
44Summary(ja) : パーティション操作をするアプリケーションの開発用ファイル
45Group: Development/Libraries
46Requires: parted = %{version}-%{release}
47Provides: libparted-devel = %{version}-%{release}
48
49%description devel
50The GNU Parted library is a set of routines for hard disk partition
51manipulation. If you want to develop programs that manipulate disk
52partitions and filesystems using the routines provided by the GNU
53Parted library, you need to install this package.
54
55%description devel -l ja
56GNU Parted ライブラリにはハードディスクのパーティションを操作する
57関数が用意されています。GNU Parted ライブラリが提供する関数を使って
58ディスクパーティションやファイルシステムを操作するプログラムを開発
59したいのであれば、このパッケージをインストールして下さい。
60
61%prep
62%setup -q
63iconv -f ISO-8859-1 -t UTF8 AUTHORS > tmp; touch -r AUTHORS tmp; mv tmp AUTHORS
64
65%build
66%configure \
67    --enable-device-mapper \
68    --enable-shared
69%__make %{?_smp_mflags}
70
71%install
72[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
73%__make install DESTDIR=$RPM_BUILD_ROOT
74
75# Remove components we do not ship
76%{__rm} -rf %{buildroot}%{_libdir}/*.la
77%{__rm} -rf %{buildroot}%{_infodir}/dir
78%{__rm} -rf %{buildroot}%{_bindir}/label
79
80%find_lang %{name}
81
82%post
83/sbin/ldconfig
84/sbin/install-info %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
85
86%postun
87/sbin/ldconfig
88
89%preun
90if [ $1 = 0 ]; then
91   /sbin/install-info --delete %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
92fi
93
94%clean
95[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
96
97%files -f %{name}.lang
98%defattr(-,root,root)
99%doc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
100%doc doc/FAT doc/USER.jp
101%{_sbindir}/*
102%{_mandir}/man8/*
103%{_libdir}/lib*.so.*
104%{_infodir}/parted.info*
105
106%files devel
107%defattr(-,root,root)
108%doc doc/API
109%{_includedir}/*
110%{_libdir}/lib*.so
111%{_libdir}/*.a
112%{_libdir}/pkgconfig/libparted.pc
113
114%changelog
115* Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1-2
116- rebuild with VineSeed environment
117
118* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1-1
119- new upstream release
120- remove Patch1
121
122* Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
123- new upstream release
124- remove Patch0
125
126* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3-1
127- new upstream release
128- drop old patches
129- new patch for 2.3 from fc14
130- add BRs: libuuid-devel, libblkid-devel >= 2.17, gnupg
131- change BR: gettext -> gettext-devel >= 0.18
132
133* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.8-2
134- rebuilt with rpm-4.8.1 for pkg-config
135
136* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
137- new upstream release
138- import patch[1-8] from fedora
139
140* Sat May 19 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.1-1vl2
141- rebuild with new environment/toolchain.
142
143* Fri Dec  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-1vl1
144- new upstream release
145- remove Patch0, 3, 100, 150, 151 and 152 (merged into upstream)
146
147* Sat Sep  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl2
148- changed Group to Applications/Administration
149
150* Wed May  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl1
151- new upstream release
152
153* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25-3vl1
154- new upstream release
155- updated Patch3, 100, 150 and 151 from Fedora
156  * Wed Nov 09 2005 Chris Lumens <clumens@redhat.com> 1.6.25-1
157  - Update DASD, iseries, and SX8 patches.
158
159* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.24-0vl1
160- new upstream release
161- updated Patch100, 151
162
163* Mon Apr 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.22-0vl1
164- new upstream release
165
166* Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.21-1vl1
167- new upstream release
168- added Patch3 and Patch152, updated Patch150 (from Fedora)
169  * Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.19-2
170  - add support for Promise SX8 devices
171  * Thu Nov 11 2004 Jeremy Katz <katzj@redhat.com> - 1.6.16-2
172  - add patch from Matt Domsch to fix consistency of GPT disk labels
173    with the EFI specification for disks > 2TB (#138480)
174
175* Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.18-0vl1
176- new upstream release
177
178* Thu Nov 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.16-0vl1
179- new upstream release
180
181* Sun Sep 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.15-0vl1
182- new upstream release
183- added BuildRequires: automake autoconf gettext
184- patches from Fedora development
185  * Tue Aug 24 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-2
186  - fix assertion error when checking flags on non-active partition (#130692)
187  - buildrequires: gettext-devel
188  * Mon Aug 16 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-1
189  - update to 1.6.12 with major changes to CHS handling to hopefully fix #115980
190  - adjust dasd patch accordingly, drop some included patches
191  * Mon Jul 19 2004 Karsten Hopp <karsten@redhat.de> 1.6.11-4
192  - update dasd patch for dos-type partitions on mainframes (scsi disks)
193
194* Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.12-0vl1
195- new upstream release
196- removed BuildRequires: automake17 autoconf
197- updated %post %postun section to install .info file
198
199* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl2
200- dropped BuildRequires: libunicode-devel
201
202* Sat Apr 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl1
203- updated to current stable release 1.6.10
204- changed BuildRequires: automake17
205- added compile optioin -Os
206- dropped patch1
207
208* Fri Jun  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.5-0vl1
209- updated to current stable release 1.6.5
210- changed summay and description based on Rawhide specfile
211
212* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 1.4.24-0vl1
213- updated to current stable release 1.4.24
214
215* Sun Jan 06 2002 Toru Sagami <sagami@vinelinux.org>
216- 1.4.21-0vl1
217- enable __libtoolize
218
219* Wed Nov 21 2001 Toru Sagami <sagami@vinelinux.org>
220- 1.4.19-0vl1
221
222* Thu Oct 04 2001 Toru Sagami <sagami@vinelinux.org>
223- 1.4.19-0vl1
224
225* Sun Aug 19 2001 Toru Sagami <sagami@vinelinux.org>
226- 1.4.18-0vl1
227- Where did any python related files go?  Erase'em.
228
229* Wed Aug 15 2001 <sagami@vinelinux.org>
230- 1.4.16-0vl1
231- build w/ --enable-shared --enable-all-static, instead of --disable-shared
232- consequently, eliminate Requires against e2fsprogs, readline
233- ldconfig at post/postun
234
235* Mon Jul 09 2001 <sagami@vinelinux.org>
236- 1.4.15-0vl1: use %%{find_lang}, added doc/FAQ
237- %%define __libtoolize /bin/true
238
239* Mon May 28 2001 <sagami@vinelinux.org>
240- 1.4.13-0vl1
241
242* Wed Apr 18 2001 <sagami@vinelinux.org>
243- 1.4.10-0vl1
244
245* Sun Jan 21 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
246- updated to 1.4.7-0vl1
247- changed Group for devel subpackage
248- added USER.jp in %doc
249
250* Sun Dec 10 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
251- 1.4.2-1vl2
252- partially used rpmmacros
253
254* Mon Nov 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
255- 1.4.2-1vl1
256- build for Vine Linux
257- added Japanese summary and description
258
259* Mon Mar 13 2000 Fabian Emmes <fab@orlen.de>
260- changed "unset LINGUAS" line
261- reintroduced %build section ;)
262- started changelog
Note: See TracBrowser for help on using the repository browser.