source: projects/specs/trunk/p/parted/parted-vl.spec @ 5356

Revision 5356, 8.5 KB checked in by Takemikaduchi, 12 years ago (diff)

parted-3.0

Line 
1%define _sbindir    /sbin
2
3Summary: The GNU disk partition manipulation program.
4Summary(ja): ディスクパーティション操作ツール
5Name: parted
6Version: 3.0
7Release: 1%{?_dist_release}
8License: GPL
9Group: Applications/Administration
10URL: http://www.gnu.org/software/parted/
11
12Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
13
14# Report partitions changes when using blkext major numbers
15Patch1: parted-2.3-lpn.patch
16
17Buildroot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: e2fsprogs-devel, ncurses-devel, readline-devel
19BuildRequires: python-devel, ncurses-devel
20BuildRequires: device-mapper-devel
21BuildRequires: libtool, automake, autoconf
22BuildRequires: gettext-devel >= 0.18
23BuildRequires: texinfo
24BuildRequires: libuuid-devel
25BuildRequires: libblkid-devel >= 2.17
26BuildRequires: gnupg
27
28Provides: libparted = %{version}-%{release}
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34GNU Parted is a program that allows you to create, destroy,
35resize, move and copy hard disk partitions. This is useful for
36creating space for new operating systems, reorganising disk
37usage, and copying data to new hard disks.
38
39%description -l ja
40GNU Parted はハードディスクのパーティションを作成/削除/リサイズ/
41移動/コピーすることが出来るプログラムです.新しいオペレーティング
42システムをインストールするスペースを確保したり,ディスクのパーティションを
43整理したり,新しいハードディスクにデータをコピーする際に非常に便利です.
44
45%package devel
46Summary: Files for developing apps which will manipulate disk partitions.
47Summary(ja) : パーティション操作をするアプリケーションの開発用ファイル
48Group: Development/Libraries
49Requires: parted = %{version}-%{release}
50Provides: libparted-devel = %{version}-%{release}
51
52%description devel
53The GNU Parted library is a set of routines for hard disk partition
54manipulation. If you want to develop programs that manipulate disk
55partitions and filesystems using the routines provided by the GNU
56Parted library, you need to install this package.
57
58%description devel -l ja
59GNU Parted ライブラリにはハードディスクのパーティションを操作する
60関数が用意されています。GNU Parted ライブラリが提供する関数を使って
61ディスクパーティションやファイルシステムを操作するプログラムを開発
62したいのであれば、このパッケージをインストールして下さい。
63
64%prep
65%setup -q
66%patch1 -p1
67iconv -f ISO-8859-1 -t UTF8 AUTHORS > tmp; touch -r AUTHORS tmp; mv tmp AUTHORS
68
69%build
70%configure \
71    --enable-device-mapper \
72    --enable-shared \
73    --enable-Werror=no
74%__make %{?_smp_mflags}
75
76%install
77[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
78%__make install DESTDIR=$RPM_BUILD_ROOT
79
80# Remove components we do not ship
81%{__rm} -rf %{buildroot}%{_libdir}/*.la
82%{__rm} -rf %{buildroot}%{_infodir}/dir
83%{__rm} -rf %{buildroot}%{_bindir}/label
84
85%find_lang %{name}
86
87%post
88/sbin/ldconfig
89/sbin/install-info %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
90
91%postun
92/sbin/ldconfig
93
94%preun
95if [ $1 = 0 ]; then
96   /sbin/install-info --delete %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
97fi
98
99%clean
100[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
101
102%files -f %{name}.lang
103%defattr(-,root,root)
104%doc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
105%doc doc/FAT doc/USER.jp
106%{_sbindir}/*
107%{_mandir}/man8/*
108%{_libdir}/lib*.so.*
109%{_infodir}/parted.info*
110
111%files devel
112%defattr(-,root,root)
113%doc doc/API
114%{_includedir}/*
115%{_libdir}/lib*.so
116%{_libdir}/*.a
117%{_libdir}/pkgconfig/libparted.pc
118
119%changelog
120* Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
121- new upstream release
122- remove Patch0
123
124* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3-1
125- new upstream release
126- drop old patches
127- new patch for 2.3 from fc14
128- add BRs: libuuid-devel, libblkid-devel >= 2.17, gnupg
129- change BR: gettext -> gettext-devel >= 0.18
130
131* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.8-2
132- rebuilt with rpm-4.8.1 for pkg-config
133
134* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
135- new upstream release
136- import patch[1-8] from fedora
137
138* Sat May 19 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.1-1vl2
139- rebuild with new environment/toolchain.
140
141* Fri Dec  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-1vl1
142- new upstream release
143- remove Patch0, 3, 100, 150, 151 and 152 (merged into upstream)
144
145* Sat Sep  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl2
146- changed Group to Applications/Administration
147
148* Wed May  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl1
149- new upstream release
150
151* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25-3vl1
152- new upstream release
153- updated Patch3, 100, 150 and 151 from Fedora
154  * Wed Nov 09 2005 Chris Lumens <clumens@redhat.com> 1.6.25-1
155  - Update DASD, iseries, and SX8 patches.
156
157* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.24-0vl1
158- new upstream release
159- updated Patch100, 151
160
161* Mon Apr 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.22-0vl1
162- new upstream release
163
164* Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.21-1vl1
165- new upstream release
166- added Patch3 and Patch152, updated Patch150 (from Fedora)
167  * Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.19-2
168  - add support for Promise SX8 devices
169  * Thu Nov 11 2004 Jeremy Katz <katzj@redhat.com> - 1.6.16-2
170  - add patch from Matt Domsch to fix consistency of GPT disk labels
171    with the EFI specification for disks > 2TB (#138480)
172
173* Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.18-0vl1
174- new upstream release
175
176* Thu Nov 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.16-0vl1
177- new upstream release
178
179* Sat Sep 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.15-0vl1
180- new upstream release
181- added BuildRequires: automake autoconf gettext
182- patches from Fedora development
183  * Tue Aug 24 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-2
184  - fix assertion error when checking flags on non-active partition (#130692)
185  - buildrequires: gettext-devel
186  * Mon Aug 16 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-1
187  - update to 1.6.12 with major changes to CHS handling to hopefully fix #115980
188  - adjust dasd patch accordingly, drop some included patches
189  * Mon Jul 19 2004 Karsten Hopp <karsten@redhat.de> 1.6.11-4
190  - update dasd patch for dos-type partitions on mainframes (scsi disks)
191
192* Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.12-0vl1
193- new upstream release
194- removed BuildRequires: automake17 autoconf
195- updated %post %postun section to install .info file
196
197* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl2
198- dropped BuildRequires: libunicode-devel
199
200* Sat Apr 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl1
201- updated to current stable release 1.6.10
202- changed BuildRequires: automake17
203- added compile optioin -Os
204- dropped patch1
205
206* Fri Jun  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.5-0vl1
207- updated to current stable release 1.6.5
208- changed summay and description based on Rawhide specfile
209
210* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 1.4.24-0vl1
211- updated to current stable release 1.4.24
212
213* Sun Jan 06 2002 Toru Sagami <sagami@vinelinux.org>
214- 1.4.21-0vl1
215- enable __libtoolize
216
217* Wed Nov 21 2001 Toru Sagami <sagami@vinelinux.org>
218- 1.4.19-0vl1
219
220* Thu Oct 04 2001 Toru Sagami <sagami@vinelinux.org>
221- 1.4.19-0vl1
222
223* Sun Aug 19 2001 Toru Sagami <sagami@vinelinux.org>
224- 1.4.18-0vl1
225- Where did any python related files go?  Erase'em.
226
227* Wed Aug 15 2001 <sagami@vinelinux.org>
228- 1.4.16-0vl1
229- build w/ --enable-shared --enable-all-static, instead of --disable-shared
230- consequently, eliminate Requires against e2fsprogs, readline
231- ldconfig at post/postun
232
233* Mon Jul 09 2001 <sagami@vinelinux.org>
234- 1.4.15-0vl1: use %%{find_lang}, added doc/FAQ
235- %%define __libtoolize /bin/true
236
237* Mon May 28 2001 <sagami@vinelinux.org>
238- 1.4.13-0vl1
239
240* Wed Apr 18 2001 <sagami@vinelinux.org>
241- 1.4.10-0vl1
242
243* Sun Jan 21 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
244- updated to 1.4.7-0vl1
245- changed Group for devel subpackage
246- added USER.jp in %doc
247
248* Sun Dec 10 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
249- 1.4.2-1vl2
250- partially used rpmmacros
251
252* Mon Nov 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
253- 1.4.2-1vl1
254- build for Vine Linux
255- added Japanese summary and description
256
257* Mon Mar 13 2000 Fabian Emmes <fab@orlen.de>
258- changed "unset LINGUAS" line
259- reintroduced %build section ;)
260- started changelog
Note: See TracBrowser for help on using the repository browser.