source: projects/specs/trunk/p/parted/parted-vl.spec @ 521

Revision 521, 8.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _sbindir    /sbin
2
3Summary: The GNU disk partition manipulation program.
4Summary(ja): ディスクパーティション操作ツール
5Name: parted
6Version: 1.8.8
7Release: 1%{?_dist_release}
8License: GPL
9Group: Applications/Administration
10URL: http://www.gnu.org/software/parted/
11
12Source0: ftp://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.bz2
13Patch0:  %{name}-1.8.8-xvd.patch
14Patch1:  %{name}-1.8.8-devmapper-header.patch
15Patch2:  %{name}-1.8.8-noinst-headers.patch
16Patch3:  %{name}-1.8.8-manpage.patch
17Patch4:  %{name}-1.8.8-gcc-4.3.patch
18Patch5:  %{name}-1.8.8-nofixgpt.patch
19Patch6:  %{name}-1.8.8-alpha.patch
20Patch7:  %{name}-1.8.8-dospartrec.patch
21Patch8:  %{name}-1.8.8-appletv.patch
22
23Buildroot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: e2fsprogs-devel, ncurses-devel, readline-devel
25BuildRequires: python-devel, ncurses-devel
26BuildRequires: device-mapper-devel
27BuildRequires: libtool, automake, autoconf
28BuildRequires: gettext, texinfo
29
30Provides: libparted = %{version}-%{release}
31
32Vendor: Project Vine
33Distribution: Vine Linux
34
35%description
36GNU Parted is a program that allows you to create, destroy,
37resize, move and copy hard disk partitions. This is useful for
38creating space for new operating systems, reorganising disk
39usage, and copying data to new hard disks.
40
41%description -l ja
42GNU Parted はハードディスクのパーティションを作成/削除/リサイズ/
43移動/コピーすることが出来るプログラムです.新しいオペレーティング
44システムをインストールするスペースを確保したり,ディスクのパーティションを
45整理したり,新しいハードディスクにデータをコピーする際に非常に便利です.
46
47%package devel
48Summary: Files for developing apps which will manipulate disk partitions.
49Summary(ja) : パーティション操作をするアプリケーションの開発用ファイル
50Group: Development/Libraries
51Requires: parted = %{version}-%{release}
52Provides: libparted-devel = %{version}-%{release}
53
54%description devel
55The GNU Parted library is a set of routines for hard disk partition
56manipulation. If you want to develop programs that manipulate disk
57partitions and filesystems using the routines provided by the GNU
58Parted library, you need to install this package.
59
60%description devel -l ja
61GNU Parted ライブラリにはハードディスクのパーティションを操作する
62関数が用意されています。GNU Parted ライブラリが提供する関数を使って
63ディスクパーティションやファイルシステムを操作するプログラムを開発
64したいのであれば、このパッケージをインストールして下さい。
65
66%prep
67%setup -q
68%patch0 -p1 -b .xvd
69%patch1 -p1 -b .devmapper
70%patch2 -p1 -b .noinst
71%patch3 -p1 -b .manpage
72%patch4 -p1 -b .gcc43
73%patch5 -p1 -b .nofixgpt
74%patch6 -p1 -b .alpha
75%patch7 -p1 -b .dospartrec
76%patch8 -p1 -b .appletv
77
78%build
79%configure \
80    --enable-device-mapper \
81    --enable-shared \
82    --enable-Werror=no
83%__make %{?_smp_mflags}
84
85%install
86[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
87%__make install DESTDIR=$RPM_BUILD_ROOT
88
89# Remove components we do not ship
90%{__rm} -rf %{buildroot}%{_libdir}/*.la
91%{__rm} -rf %{buildroot}%{_infodir}/dir
92%{__rm} -rf %{buildroot}%{_bindir}/label
93
94%find_lang %{name}
95
96%post
97/sbin/ldconfig
98/sbin/install-info %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
99
100%postun
101/sbin/ldconfig
102
103%preun
104if [ $1 = 0 ]; then
105   /sbin/install-info --delete %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
106fi
107
108%clean
109[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
110
111%files -f %{name}.lang
112%defattr(-,root,root)
113%doc AUTHORS BUGS COPYING ChangeLog NEWS README THANKS TODO
114%doc doc/FAT doc/USER.jp
115%{_sbindir}/*
116%{_mandir}/man8/*
117%{_libdir}/lib*.so.*
118%{_infodir}/parted.info*
119
120%files devel
121%defattr(-,root,root)
122%doc doc/API
123%{_includedir}/*
124%{_libdir}/lib*.so
125%{_libdir}/*.a
126%{_libdir}/pkgconfig/libparted.pc
127
128%changelog
129* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
130- new upstream release
131- import patch[1-8] from fedora
132
133* Sat May 19 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.1-1vl2
134- rebuild with new environment/toolchain.
135
136* Fri Dec  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-1vl1
137- new upstream release
138- remove Patch0, 3, 100, 150, 151 and 152 (merged into upstream)
139
140* Sat Sep  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl2
141- changed Group to Applications/Administration
142
143* Wed May  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl1
144- new upstream release
145
146* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25-3vl1
147- new upstream release
148- updated Patch3, 100, 150 and 151 from Fedora
149  * Wed Nov 09 2005 Chris Lumens <clumens@redhat.com> 1.6.25-1
150  - Update DASD, iseries, and SX8 patches.
151
152* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.24-0vl1
153- new upstream release
154- updated Patch100, 151
155
156* Mon Apr 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.22-0vl1
157- new upstream release
158
159* Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.21-1vl1
160- new upstream release
161- added Patch3 and Patch152, updated Patch150 (from Fedora)
162  * Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.19-2
163  - add support for Promise SX8 devices
164  * Thu Nov 11 2004 Jeremy Katz <katzj@redhat.com> - 1.6.16-2
165  - add patch from Matt Domsch to fix consistency of GPT disk labels
166    with the EFI specification for disks > 2TB (#138480)
167
168* Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.18-0vl1
169- new upstream release
170
171* Thu Nov 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.16-0vl1
172- new upstream release
173
174* Sat Sep 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.15-0vl1
175- new upstream release
176- added BuildRequires: automake autoconf gettext
177- patches from Fedora development
178  * Tue Aug 24 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-2
179  - fix assertion error when checking flags on non-active partition (#130692)
180  - buildrequires: gettext-devel
181  * Mon Aug 16 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-1
182  - update to 1.6.12 with major changes to CHS handling to hopefully fix #115980
183  - adjust dasd patch accordingly, drop some included patches
184  * Mon Jul 19 2004 Karsten Hopp <karsten@redhat.de> 1.6.11-4
185  - update dasd patch for dos-type partitions on mainframes (scsi disks)
186
187* Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.12-0vl1
188- new upstream release
189- removed BuildRequires: automake17 autoconf
190- updated %post %postun section to install .info file
191
192* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl2
193- dropped BuildRequires: libunicode-devel
194
195* Sat Apr 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl1
196- updated to current stable release 1.6.10
197- changed BuildRequires: automake17
198- added compile optioin -Os
199- dropped patch1
200
201* Fri Jun  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.5-0vl1
202- updated to current stable release 1.6.5
203- changed summay and description based on Rawhide specfile
204
205* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 1.4.24-0vl1
206- updated to current stable release 1.4.24
207
208* Sun Jan 06 2002 Toru Sagami <sagami@vinelinux.org>
209- 1.4.21-0vl1
210- enable __libtoolize
211
212* Wed Nov 21 2001 Toru Sagami <sagami@vinelinux.org>
213- 1.4.19-0vl1
214
215* Thu Oct 04 2001 Toru Sagami <sagami@vinelinux.org>
216- 1.4.19-0vl1
217
218* Sun Aug 19 2001 Toru Sagami <sagami@vinelinux.org>
219- 1.4.18-0vl1
220- Where did any python related files go?  Erase'em.
221
222* Wed Aug 15 2001 <sagami@vinelinux.org>
223- 1.4.16-0vl1
224- build w/ --enable-shared --enable-all-static, instead of --disable-shared
225- consequently, eliminate Requires against e2fsprogs, readline
226- ldconfig at post/postun
227
228* Mon Jul 09 2001 <sagami@vinelinux.org>
229- 1.4.15-0vl1: use %%{find_lang}, added doc/FAQ
230- %%define __libtoolize /bin/true
231
232* Mon May 28 2001 <sagami@vinelinux.org>
233- 1.4.13-0vl1
234
235* Wed Apr 18 2001 <sagami@vinelinux.org>
236- 1.4.10-0vl1
237
238* Sun Jan 21 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
239- updated to 1.4.7-0vl1
240- changed Group for devel subpackage
241- added USER.jp in %doc
242
243* Sun Dec 10 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
244- 1.4.2-1vl2
245- partially used rpmmacros
246
247* Mon Nov 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
248- 1.4.2-1vl1
249- build for Vine Linux
250- added Japanese summary and description
251
252* Mon Mar 13 2000 Fabian Emmes <fab@orlen.de>
253- changed "unset LINGUAS" line
254- reintroduced %build section ;)
255- started changelog
Note: See TracBrowser for help on using the repository browser.