source: projects/specs/trunk/p/parted/parted-vl.spec @ 12169

Revision 12169, 9.3 KB checked in by tomop, 5 years ago (diff)

parted-3.2.153-1

Line 
1%define _sbindir    /sbin
2
3Summary: The GNU disk partition manipulation program.
4Summary(ja): ディスクパーティション操作ツール
5Name: parted
6Version: 3.2.153
7Release: 1%{?_dist_release}
8License: GPLv3
9Group: Applications/Administration
10URL: http://www.gnu.org/software/parted/
11
12Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
13
14# Upstream still uses python2 for these scripts
15Patch0000: 0092-Switch-gpt-header-move-and-msdos-overlap-to-python3.patch
16
17Buildroot: %{_tmppath}/%{name}-%{version}-root
18BuildRequires: e2fsprogs-devel, ncurses-devel, readline-devel
19BuildRequires: python3-devel, ncurses-devel
20BuildRequires: device-mapper-devel
21BuildRequires: libtool, automake, autoconf
22BuildRequires: gettext-devel >= 0.18
23BuildRequires: texinfo
24BuildRequires: libuuid-devel
25BuildRequires: libblkid-devel >= 2.17
26BuildRequires: gnupg
27
28Provides: libparted = %{version}-%{release}
29
30Vendor: Project Vine
31Distribution: Vine Linux
32
33%description
34GNU Parted is a program that allows you to create, destroy,
35resize, move and copy hard disk partitions. This is useful for
36creating space for new operating systems, reorganising disk
37usage, and copying data to new hard disks.
38
39%description -l ja
40GNU Parted はハードディスクのパーティションを作成/削除/リサイズ/
41移動/コピーすることが出来るプログラムです.新しいオペレーティング
42システムをインストールするスペースを確保したり,ディスクのパーティションを
43整理したり,新しいハードディスクにデータをコピーする際に非常に便利です.
44
45%package devel
46Summary: Files for developing apps which will manipulate disk partitions.
47Summary(ja) : パーティション操作をするアプリケーションの開発用ファイル
48Group: Development/Libraries
49Requires: parted = %{version}-%{release}
50Provides: libparted-devel = %{version}-%{release}
51
52%description devel
53The GNU Parted library is a set of routines for hard disk partition
54manipulation. If you want to develop programs that manipulate disk
55partitions and filesystems using the routines provided by the GNU
56Parted library, you need to install this package.
57
58%description devel -l ja
59GNU Parted ライブラリにはハードディスクのパーティションを操作する
60関数が用意されています。GNU Parted ライブラリが提供する関数を使って
61ディスクパーティションやファイルシステムを操作するプログラムを開発
62したいのであれば、このパッケージをインストールして下さい。
63
64%prep
65%setup -q
66%patch0 -p1 -b .python3
67
68iconv -f ISO-8859-1 -t UTF8 AUTHORS > tmp; touch -r AUTHORS tmp; mv tmp AUTHORS
69
70%build
71autoreconf
72autoconf
73
74CFLAGS="$RPM_OPT_FLAGS -Wno-unused-but-set-variable"; export CFLAGS
75%configure \
76    --enable-device-mapper \
77    --enable-shared
78
79# Don't use rpath!
80%{__sed} -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
81%{__sed} -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
82
83%__make %{?_smp_mflags}
84
85%install
86[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
87%__make install DESTDIR=$RPM_BUILD_ROOT
88
89# Remove components we do not ship
90%{__rm} -rf %{buildroot}%{_libdir}/*.la
91%{__rm} -rf %{buildroot}%{_infodir}/dir
92%{__rm} -rf %{buildroot}%{_bindir}/label
93
94%find_lang %{name}
95
96%post
97/sbin/ldconfig
98/sbin/install-info %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
99
100%postun
101/sbin/ldconfig
102
103%preun
104if [ $1 = 0 ]; then
105   /sbin/install-info --delete %{_infodir}/parted.info.gz %{_infodir}/dir >/dev/null 2>&1 || :
106fi
107
108%clean
109[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
110
111%files -f %{name}.lang
112%defattr(-,root,root)
113%license COPYING
114%doc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
115%doc doc/FAT doc/USER.jp
116%{_sbindir}/*
117%{_mandir}/man8/*
118%{_libdir}/lib*.so.*
119%{_infodir}/parted.info*
120
121%files devel
122%defattr(-,root,root)
123%doc doc/API
124%{_includedir}/*
125%{_libdir}/lib*.so
126%{_libdir}/*.a
127%{_libdir}/pkgconfig/libparted*.pc
128
129%changelog
130* Mon Sep 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.153-1
131- new upstream release.
132- built with readline-8.0.
133
134* Thu Apr  2 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.2-2
135- rebuilt with readline 6.3
136
137* Sun Aug 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2-1
138- new upstream release
139
140* Wed Jan 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1-2
141- rebuild with VineSeed environment
142
143* Sun Jul 15 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1-1
144- new upstream release
145- remove Patch1
146
147* Thu Jan 05 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.0-1
148- new upstream release
149- remove Patch0
150
151* Tue Nov  9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.3-1
152- new upstream release
153- drop old patches
154- new patch for 2.3 from fc14
155- add BRs: libuuid-devel, libblkid-devel >= 2.17, gnupg
156- change BR: gettext -> gettext-devel >= 0.18
157
158* Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.8.8-2
159- rebuilt with rpm-4.8.1 for pkg-config
160
161* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
162- new upstream release
163- import patch[1-8] from fedora
164
165* Sat May 19 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.8.1-1vl2
166- rebuild with new environment/toolchain.
167
168* Fri Dec  8 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.8.1-1vl1
169- new upstream release
170- remove Patch0, 3, 100, 150, 151 and 152 (merged into upstream)
171
172* Sat Sep  9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl2
173- changed Group to Applications/Administration
174
175* Wed May  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25.1-0vl1
176- new upstream release
177
178* Thu Dec  1 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.25-3vl1
179- new upstream release
180- updated Patch3, 100, 150 and 151 from Fedora
181  * Wed Nov 09 2005 Chris Lumens <clumens@redhat.com> 1.6.25-1
182  - Update DASD, iseries, and SX8 patches.
183
184* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.24-0vl1
185- new upstream release
186- updated Patch100, 151
187
188* Mon Apr 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.22-0vl1
189- new upstream release
190
191* Thu Jan 27 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.21-1vl1
192- new upstream release
193- added Patch3 and Patch152, updated Patch150 (from Fedora)
194  * Tue Dec 14 2004 Jeremy Katz <katzj@redhat.com> - 1.6.19-2
195  - add support for Promise SX8 devices
196  * Thu Nov 11 2004 Jeremy Katz <katzj@redhat.com> - 1.6.16-2
197  - add patch from Matt Domsch to fix consistency of GPT disk labels
198    with the EFI specification for disks > 2TB (#138480)
199
200* Tue Nov 23 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.18-0vl1
201- new upstream release
202
203* Thu Nov 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.16-0vl1
204- new upstream release
205
206* Sun Sep 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.15-0vl1
207- new upstream release
208- added BuildRequires: automake autoconf gettext
209- patches from Fedora development
210  * Tue Aug 24 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-2
211  - fix assertion error when checking flags on non-active partition (#130692)
212  - buildrequires: gettext-devel
213  * Mon Aug 16 2004 Jeremy Katz <katzj@redhat.com> - 1.6.12-1
214  - update to 1.6.12 with major changes to CHS handling to hopefully fix #115980
215  - adjust dasd patch accordingly, drop some included patches
216  * Mon Jul 19 2004 Karsten Hopp <karsten@redhat.de> 1.6.11-4
217  - update dasd patch for dos-type partitions on mainframes (scsi disks)
218
219* Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.12-0vl1
220- new upstream release
221- removed BuildRequires: automake17 autoconf
222- updated %post %postun section to install .info file
223
224* Sun Apr 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl2
225- dropped BuildRequires: libunicode-devel
226
227* Sat Apr 17 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.10-0vl1
228- updated to current stable release 1.6.10
229- changed BuildRequires: automake17
230- added compile optioin -Os
231- dropped patch1
232
233* Fri Jun  6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.5-0vl1
234- updated to current stable release 1.6.5
235- changed summay and description based on Rawhide specfile
236
237* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 1.4.24-0vl1
238- updated to current stable release 1.4.24
239
240* Sun Jan 06 2002 Toru Sagami <sagami@vinelinux.org>
241- 1.4.21-0vl1
242- enable __libtoolize
243
244* Wed Nov 21 2001 Toru Sagami <sagami@vinelinux.org>
245- 1.4.19-0vl1
246
247* Thu Oct 04 2001 Toru Sagami <sagami@vinelinux.org>
248- 1.4.19-0vl1
249
250* Sun Aug 19 2001 Toru Sagami <sagami@vinelinux.org>
251- 1.4.18-0vl1
252- Where did any python related files go?  Erase'em.
253
254* Wed Aug 15 2001 <sagami@vinelinux.org>
255- 1.4.16-0vl1
256- build w/ --enable-shared --enable-all-static, instead of --disable-shared
257- consequently, eliminate Requires against e2fsprogs, readline
258- ldconfig at post/postun
259
260* Mon Jul 09 2001 <sagami@vinelinux.org>
261- 1.4.15-0vl1: use %%{find_lang}, added doc/FAQ
262- %%define __libtoolize /bin/true
263
264* Mon May 28 2001 <sagami@vinelinux.org>
265- 1.4.13-0vl1
266
267* Wed Apr 18 2001 <sagami@vinelinux.org>
268- 1.4.10-0vl1
269
270* Sun Jan 21 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
271- updated to 1.4.7-0vl1
272- changed Group for devel subpackage
273- added USER.jp in %doc
274
275* Sun Dec 10 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
276- 1.4.2-1vl2
277- partially used rpmmacros
278
279* Mon Nov 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
280- 1.4.2-1vl1
281- build for Vine Linux
282- added Japanese summary and description
283
284* Mon Mar 13 2000 Fabian Emmes <fab@orlen.de>
285- changed "unset LINGUAS" line
286- reintroduced %build section ;)
287- started changelog
Note: See TracBrowser for help on using the repository browser.